Jump to content

Adaptec 2940 SCSI

7 posts in this topic

Recommended Posts

Need help with the driver!


I resently updated from 10.4.1 to 10.4.3g. My Adaptec SCSI 2940 worked just fine in 10.4.1 but no in 10.4.3, it doesnt even load any driver. I tried to copy over the Adaptec 78XXSCSI.kext, but when i try to load it i get this error:


localhost kernel[0]: extension "com.apple.iokit.IOSCSIFamily" cannot be found

localhost kernel[0]: can't determine immediate dependencies for extension com.apple.driver.Adaptec78XXSCSI

localhost kernel[0]: Can't determine dependencies for com.apple.driver.Adaptec78XXSCSI.

localhost kernel[0]: Couldn't alloc class "Adaptec78XXSCSIController"



I am runing on:


Intel GMA900

1Gb ram

1st ATA disk WinXP

1st S-ATA OSX 10.4.3g


Any one have this problem?

Solutions Thanx!

Link to comment
Share on other sites

  • 5 months later...

How about modifying plist File using Vendor ID & Device ID.

I also wanna try to load Adaptec 78XXSCSI.kext.

There were no 78XXSCSI.kext in 10.4.6 OSX.

I really appriciate If you send me 78XXSCSI.kext by Email, ritzcarltn@gmail.com.


The informatin of my Adaptec 2940UW is followings.


Vendor I : 9004

Device ID : 8178


How about you?

Link to comment
Share on other sites

I try to install AHA2940 UW driver in JAS OSX 10.4.7.

I got 10.4.1 kext pkg by Pacifist as followings.

- IOSCSIFamily

- Adaptec78XXSCSI

But, not working.

Is there another way?

Link to comment
Share on other sites

  • 2 months later...

  • Create New...