Jump to content

Unable to get Leopard install to boot


TonyKL
 Share

13 posts in this topic

Recommended Posts

I've downloaded the BrazilMac patch and patched my MG Leopard DVD.

This all went ok.

 

Managed to install it ok (after a few learning curves) and installed the pre and post patches.

 

When I boot from the DVD and specify rd=/dev/disk0s1 then leopard boots and runs very well.

Only problem is that I can't get Leopard to boot from the HDD...

 

I've followed the steps to use fdisk to set it active, and I've copied the boot file from the latest MagicBoot onto the drive but still I dont get anywhere when I select the HDD as the bootable drive from the BIOS.

 

Is there something I'm missing or doing wrong?

 

Thanks for any pointers,

Tony

Link to comment
Share on other sites

All I can think of is that I need to install Darwin boot loader - how do I do this?

The DVD obviously has this boot loader which allows me to bootstrap the installed Leopard but without this on the HDD there's no chance I can boot it directly.

 

Must be a way to install just the Darwin Bootloader.

Link to comment
Share on other sites

Ok peeps, theres a really easy way to fix this! Listen up! Download ToH RC2 DVD. Then Burn It. Boot Off of it. Run Terminal. Type in "cd /usr/misc/" enter. Then type: "./script.sh VOLUMENAME" (name of your leopard volume, probably leopard)

And then reboot. Simple as that.

Link to comment
Share on other sites

Look at http://forum.osx86scene.com/viewtopic.php?...=a&start=75 and you find :

 

"To shellcoder

 

 

2 steps:

A) makes your partition bootable:

I named my disk I want to boot on BoBo

in root enter following commands

diskutil list

 

check BoBo is under disk0s1 if not replace disk0s1 by what you read in following lines

 

 

diskutil unmount /Volumes/BoBo

dd if=/usr/standalone/i386/boot1h of=/dev/rdisk0s1 bs=512 count=1

/usr/sbin/startupfiletool /dev/rdisk0s1 /usr/standalone/i386/boot

/usr/sbin/bless -device /dev/disk0s1 -setBoot -verbose

diskutil mount /dev/disk0s1

/usr/sbin/bless -mount "Volumes/Boot" -setBoot -verbose

Now PC will be able to boot on BoBo

:thumbsup_anim: you may set up in Bios that first disk to boot will be BoBo or select BoBo from startup menu if you have this option on your main board.

 

Hope it may help"

Thanks leonleonleonleon ....

Link to comment
Share on other sites

diskutil list

 

check BoBo is under disk0s1 if not replace disk0s1 by what you read in following lines

diskutil unmount /Volumes/BoBo

dd if=/usr/standalone/i386/boot1h of=/dev/rdisk0s1 bs=512 count=1

/usr/sbin/startupfiletool /dev/rdisk0s1 /usr/standalone/i386/boot

/usr/sbin/bless -device /dev/disk0s1 -setBoot -verbose

diskutil mount /dev/disk0s1

/usr/sbin/bless -mount "Volumes/Boot" -setBoot -verbose

Now PC will be able to boot on BoBo

 

Thanks for the info although i've done this a number of times.

Will try the ToH disc as i have that somewhere.

Link to comment
Share on other sites

Update:

 

Thanks to 3vilution - using the ToH disk and installing Leopard, then running the post-install script meant that I got a full working system booting from the HDD - woohoo ! I actually found that the BrazilMac version is better for my machine (finds 2 cores and graphics better etc) so I've re-installed that and will try using the ToH post-install script to install darwin.

 

edit: Yeah - using ToH to create the bootstrap is the way to go :-)

edit: Now, dare I go for the magic bootloader and EFI?

Link to comment
Share on other sites

 Share

×
×
  • Create New...