Jump to content

Sleep frustration


8 posts in this topic

Recommended Posts

Hey all!


I've been running my Hackintosh for quite some time now, I just recently upgraded to Leopard, and I still can't get sleep mode to work!! When I try to get the computer the sleep, the screen will just go black, but the computer would still be running, I only hear my hard drives park themselves, no blinking light or anything. However, when I put a CD into the drive first, the computer falls completely asleep, but I cannot wake it, it turns on, the HD light stays lit for a second, but the displays never turn on, and the computer doesn't respond to SSH either.


I just upgraded my kernel as well to netkas' SSE3 speedstep kernel, still no avail. Here's my specs:


ASUS P5LD2 Deluxe (Intel 945P)

Intel Pentium D

nVidia GeForce 7600 GT

Mac OS X 10.5.0 Darwin Kernel Version 9.0.0



Paulicat's AppleSMBIOS didn't work either!


Any help is greatly appreciated!!! :P


Link to comment
Share on other sites

I'm running 10.5.1 on Gigabyte GA-P35-DS4 (F8 Bios), it performs S3 sleep perfectly, every times.

When I tick sleep on Apple menu or left the machine idle, it sleeps. The only way to wake is to

tab the power button (which I think it is normal)... then it will wake, perfectly....


My software config is... vanilla kernel, netkas's dsmos.kext (from his excelent EFI V5 package), netkas's EFI boot,

netkas's AppleSMBios.kext, all vanilla kext and some NVInject & ALCInject for video&sound.


I have no success for S1 (Mac-like) sleep at all, but 100% for S3 (I set this in BIOS) on *vanilla*

kernel. Tried the new ToH speedstep kernel yesterday but it seems to break my sleep, so I changed



Trying EFI boot loader and vanilla kernel may solves this sleep problem for you as mine.

However, what I can't get to work properly on this config is restart & shutdown.

Link to comment
Share on other sites

hi James,


I've got an asus p5ld2 with e2180 and sleep is working great here, but when I use the ToH speedstep kernel it is gone.. no more waking up.

The way to get things working is to do as Alwayon said, install the EFIv5 and dsmos and the new AppleSMbios from the EFIv5 zip, and start using a vanilla kernel.

(I think you can find more info on EFI and the broken sleep on the speedstep kernel on netkas.freeflux.net)

Link to comment
Share on other sites

Okay, I just updated to 10.5.1, with the ToH 9.1.0 speedstep kernel. Now, I can successfully go to sleep with a CD in the drive, but when I wake up, it shows my desktop and my keyboard works, but my mouse is extremely choppy. Also, my second monitor never initializes. SO CLOSE!!!! ARGH!!


Any idea why that might be happening? Console provides no further details...

Link to comment
Share on other sites

  • 1 month later...

same problem here. I used to have perfect sleep/wake up on 10.5.1 before 10.5.2 nvidea kexts whic I installed to get better res on my 8600GT card. Then after 10.5.2 install and changing to 1680x1050 problems with sleep and with shut down appeared:

with S3 set in BIOS I had problem to shut down - computer seemed to turn off with fans still running and also when waking up from sleep display never turned on like no signal from GPU.

after changing to S1 mode in BIOS can shut down normally now but still have proble with waking up the screen...

Link to comment
Share on other sites


  • Create New...