Jump to content

Leopard a581 p35


7 posts in this topic

Recommended Posts

Hi all,


I have installed leopard into GA-p35ds3R motherboard, I do have ati radeon x1600 installed. first I must tell you that installation went well, I booted into leopard with the DVD in the drive. What I could not do is as below ;


1. Alc889a ; not yet fixed.

2. atiradeon x1600 ; qe/ci enable not yet fixed , after I remove kext, with the ones from 10.4.10 tiger , system did not boot correctly. I guess I could not do chown, chmod " repair permissions correctly"

3 without DVD in the drive it will not boot. no boot section on the hd


if anybody have time to help me out, this will be basic requirements for others

so thanks in advance,


best regards,

Link to comment
Share on other sites

Hi there.


First of all: You need to improve your post's title: You should mention what motherboard you are using and what you're trying to run on it, something like: "Running leopard on Gigabyte P35 - no sound, no proper boot" or something so it's a little bit more descriptive and it attracts people's attention right away.


For your sound, please follow these instructions (took from here: http://forum.insanelymac.com/index.php?sho...mp;hl=Alc889a#)

Download this file: http://rapidshare.com/files/51585161/alc889a.zip.html


the kexts included in the zip should be


ALCinject.kext and AppleHDA.kext


copy both kexts into your


System/Library/Extensions folder....


after you have copied both kexts into the folder do the following..


open up a Terminal and do the following.... Terminal is found in the Utilities folder...


type in the following...


sudo -s <press enter>


<enter password> <press enter>


chmod -R 755 /System/Library/Extensions/ALCinject.kext <press enter>


chmod -R 755 /System/Library/Extensions/AppleHDA.kext <press enter>


chown -R root:wheel /System/Library/Extensions/ALCinject.kext <press enter>


chown -R root:wheel /System/Library/Extensions/AppleHDA.kext <press enter>


rm -R /System/Library/Extensions.kextcache <press enter>


rm -R /System/Library/Extensions.mkext <press enter>


reboot <press enter>


enjoi fully working audio... verify in the Audio Panel that you have fully working audio...

That should work on Leopard too. :)


I can't help you with the video card, i run an nVidia 7900GS myself.


Your boot problem: I think you need to follow that guide on how to place in the darwin bootloader into your leopard installation. I dont have the link handy but it shouldn't be hard to find. :)


And please make topic titles more descriptive in the future, it will be of great help not only to yourself, but to everyone else. ;)

Link to comment
Share on other sites

  • 4 weeks later...




current Leopard kexts worked for me.

all i had to do was edit the ATIinject.kext, and ATIRadeonX1000.kext, with my own Device ID. :)


directions are in the zip.


p.s. i have a Sapphire (i think).


Does not work for me :( After reboot I only have blue screen. Any sugestions?


My card is Club3D X1600Pro

Link to comment
Share on other sites

  • 2 weeks later...

To make your hdd bootable you need to run the following script in Terminal (boot from the Leopard DVD again).


diskutil unmount /Volumes/[Your Volume Here]
dd if=/usr/standalone/i386/boot1h of=/dev/rdisk0s1 bs=512 count=1
/usr/sbin/startupfiletool /dev/rdisk0s1 /usr/standalone/i386/boot
/usr/sbin/bless -device /dev/disk0s1 -setBoot -verbose
diskutil mount /dev/disk0s1
/usr/sbin/bless -mount "Volumes/Boot" -setBoot -verbose


This script (from what i understood) initializes your boot sector and copies the bootloader from the dvd, also marking your partition as 'bootable'. If you don't have startupfiletool on your dvd (mine didn't have it) get pc_efi from the usual places and use it's startupfiletool (but only that, take the bootloader from the dvd)


Hope that helped somebody.

Link to comment
Share on other sites


  • Create New...