Jump to content

OSX isn't detecting SATA drives

6 posts in this topic

Recommended Posts

OSX is installed on a sata drive but the other 2 in my computer aren't getting detected. At first I thought it was because they were in raid so I deraided them but now they're still not detected. I formatted them in FAT32. Any ideas?


Asrock 939sli32

AMD Opteron 165

Hitachi SATA 2 drive - OSX installed here

2xSeagate SATA 2 drives - aren't detected.

eVGA 7600gt

Link to comment
Share on other sites

I tried NTFS as well and I tried having them be unformatted. what format should I use?



EDIT: by disabling the raid setting in the BIOS I can now see one of the 2 drives. Why the other drive isn't there I couldn't say. That problem is definitely over my head as it makes no sense to me. Anyone have a clue?

Link to comment
Share on other sites

mac doesn't use FAT32

But it can read/write on this filesystem...

As for ntfs, it can read natively, and reported to write with the help of macfuse.



I found this: parted: breaks Intel Mac partitions

We can read:

Also the partition that is created with parted has the flag 'msftres'

that cannot be removed. This flag makes most OS X tools ignore the

partition. This is probably caused by parted setting the type of the

partition to MS Reserved.

I haven't followed that bug report, and don't know if it applies to your version of parted. Have you tried formatting within windows?

Link to comment
Share on other sites


  • Create New...