Jump to content

[HELP!] Finding "/etc/fstab"


4 posts in this topic

Recommended Posts




Today, I decided to look for a way to hide my Windows XP partition in Mac OS X since I don't need access to it, and it doesn't look good on my desktop. I know I can just set the options in finder to hide hard disks, but I want to retain access to my Mac OS X partition and my Storage partition on the desktop. So I searched Google, and came across this particular page.


Problem Description

I tried my best to follow the instructions, but I made many mistakes. When I typed "cat /etc/fstab" in Terminal to check out what I saved, it appears that I made a mess in "/etc/fstab". So I know I saved it, but i have no idea how to fix it.



I tried typing "sudo tee -a /etc/fstab" and typing the line correctly this time. But when I check the file afterwards, I find out I just added ANOTHER line to the mess. I desperately searched for a way to edit this file, but I couldn't find any info. I tried searching for "/etc", "/etc/fstab", and "fstab" but there was no "/etc" folder on my HD, nor could I find it using Spotlight.


Bottom Line

I need help editing "/etc/fstab" so I can erase some of the bad lines I inserted and saved. I only know "sudo tee -a /etc/fstab", but that only let's me add to it, not edit it.


I am using Mac OS X 10.4.9/Darwin 8.9.1.



Thanks in advance,

Silly Me

Link to comment
Share on other sites

Could have just used Automator -> Shell Script :-



if [ -d /Volumes/yourwindowsdirectory ] *** this will search if the directory exist then


hdiutil unmount /Volumes/yourwindowsdirectory *** unmount the volume



save as your workflow or app

add to your startup list then logout and login to see how it works...


can always try 1st on Automator b4 you logout then login again if it works automagically...

Link to comment
Share on other sites

I used Automator and it was amazingly easy :D:weight_lift:-_- , although I believe it should be "diskutil" instead of "hdiutil". :)


I tried nano, and I'm sort of getting how it works. However, I don't know how to delete my /etc/fstab. It gives me errors in the Darwin Bootloader and I am unable to boot into Windows XP.


edit: I found out Ctrl+O will save the file. I saved the file and it should fix my problem.




Thank you so much for the quick and helpful replies!


It turns out I could have just added a "." to the beginning of my Windows partition name, and OS X wouldn't show it because it doesn't read partitions that start with a "." (according to what i read).

Link to comment
Share on other sites


  • Create New...