Jump to content

Logitech S530 Keyboard / Intel BadAxe / 10.4.9 problems...

8 posts in this topic

Recommended Posts

My two systems (look at my signature) are working very nice.

BUT: First i built machine 1, with the asrock conroe945 DVI board. All worked well. My Logitech S-530 Keyboard / Mouse combi workes as expected.

Then i built machine 2 with the intel bad axe 2 for quad core support. All works nice (i only had problems with built in audio, used the hda patcher but no real success - sound went bad after a few minutes; so i used an external behringer usb audio device - nice.)

BUT: My Logitech S-530 does not really work well. It works "a bit" but i cant assign the extra keys with the newest driver (or older drivers). It doesnt show battery state. Its the same as i had on a "real" mac, when disconnecting the s-530 and then reconnecting it - restart helps on a real mac but not on my "hacki".

I tried different OS versions (JaS 10.4.8, Uphuck 1.3, 1.4) and different kernels. No change. I treid a extra PCI USB2 card. No change. So i went back to m old Logitech wireless keyboad mouse combi (cordless keyboard) which works in every variation. I tried several IOUSBxxx kexts. No go.

Any idea? Anyone solved that?

Link to comment
Share on other sites

  • 4 weeks later...

I was looking at that board as a replacement for my Mac Pro (I don't like the feel of the Apple keyboard and mighty mice should be labeled mini-mouse). Have you installed the Logitech Control Center software? I think I read that even on a real Mac that is required to get certain things working properly.

Link to comment
Share on other sites

  • 1 month later...

So finally (thanks BJMoose!!!) it works, well, almost perfect with that driver, that is normally not to be found at logitechs website. Almost because, at the moment, the eject key seems to work somehow erratic, but doesnt throw out the cd. It sometimes acts like F12, sometimes it opens spotlight and so on... But the othe things seem to work on my first look. Maybe 2.2.2 is BETA and the release version will be 2.24 or so - but at the moment... I just ordered a second S530:-)


Far all, heres the direct download link from logitech:



Report if it works.

Link to comment
Share on other sites


  • Create New...