Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
acerbix

[Resolved] ATI X1600 Natit QE/CI problem: Need some info for comparisons:

9 posts in this topic

Recommended Posts

[Edit: This is now resolved: look at the next post for details.]

 

 

Hi,

 

I have a X1600 512MB with Device ID 0x71C2. If I use the installer posted on Diabolic's site, but do not add this device ID to the ATIRadeonX1000.kext Info.plist, then I get a good, stable, working system with changable resolution, but no QE/CI/rotation. If I add the device ID to the Info.plist, then the system boots up, System Profiler shows I have QE/CI/rotation, but the system goes into an almost-freeze state within minutes : the mouse pointer turns to the rotating beachball thingy and responds to movement, but all applications freeze up, and the system is unusable. If I use any OpenGL apps, the System goes into this state in seconds.

 

I learnt from Diabolik that the problem is with my configuration, since 0x71C2 is very well supported by Natit. I have been doing a 10.4.8 JaS install from scratch/reboot followed by the JaS 10.4.9 upgrade/reboot followed by Diabolik's x1600 Installer/add dev id to ATIRadeonX1000.kext/reboot. However, the problem persists

 

If you are fortunate enough to have X1600 working with full QE/CI on 10.4.9, will you be kind enough to share some files, so that I can compare my version to yours to see what I am doing wrong? I am looking for the following in /System/Library/Extensions

- ATINDRV.kext

- ATIRadeonX1000*

- IONDRVSupport.kext

- NatitX1600.kext

Also, if you had to do anything additional (i.e over and above) what diabolik's installer does prior to reboot and successful install, please do share that as well.

 

 

Thanks

Share this post


Link to post
Share on other sites

I have resolved this problem: while no one posted any info, there were quite a few views on this post, so I am sharing my experience in the hope that it helps others.

 

After trying a lot of permutations and combinations, I still was not able to make it work on 10.4.8 or 10.4.9 [JaS, Semthex 8.8.1 or 8.9.1 kernels) What worked for me is 10.4.10 (8.10.1 kernel). This is the process I followed:

 

1. Install from scratch using MacOS 10.4.8 JaS SSE2/SSE3/PPF1

- Install the base/core packages and any add-ons you want (like X Server, or languages)

- Do *not* install Natit, Titan, or any patches at this time

- Do not install any fixes (LogonWindow, etc) unless you need them for any other reason (i.e you have other non-related problems)

 

2. Once you have created an admin user and logged in, do the following so that you can recover in case something goes wrong:

- Drop into terminal

- sudo su - (or su -, or some other way to use the shell as root)

- mkdir /Backups (Note: Use upper case Backups and put the trailing 's'. Later on, the Koolall installer will create another folder called backup)

- cp -R /System/Library/Extensions /Backups/Extensions_10.4.8

 

3. Upgrade to 10.4.10: I used the KoolKal installer here: Link

- Things to be careful of, while using KoolKal:

- Select the following:

- MacOSX 10.4.10 Combo Intel Only

- Kernel 8.10.1 SSE3 [if you have an SSE2 only CPU, you might be out of luck: this needs the 8.10.1 kernel)

- Do *not* select 8.9.1 kernel

- Patches and drivers: Do *not* select Natit here: doing that might give you a frozen blue screen. YOU HAVE BEEN WARNED!!!

- Select any networking, SATA/ATA and/or audio drivers you need. However, if you have custom drivers (I have ALC882 audio) then you are better off not selecting any, for they might stop working. I had to go back to 10.4.8 AppleHDA to get audio back again.

- Read/Write NTFS support: You might select that if you want: it caused minor disk corruption for me, but nothing chkdsk in windows couldn't fix

- Hit the install button, and pray!

- Reboot the system when prompted to do so

- WARNING: The first time the system reboots, it might not go into the graphics login screen at all: you might see diskarb timeout errors and the system might reboot without letting you log in. This is okay for the first time. However, if this keeps on happening repeatedly, then you got a problem.

- After the first time diskarb error reboot, you should be able to log into the system.

- Select "Blue Apple"-->About this Mac to confirm that 10.4.10 is successfully installed.

 

4. Install Natit: Use Diabolik for X1600 here: Link

- Do *not* install the Stock 10.4.9 ATI kexts

- Install everything else: NatitX1600 kext, 10.4.5 ATINDRV and 10.4.7 IONDRVSupport

- Drop into Terminal

- sudo su - (or any other way to be root in the terminal)

- vi /System/Library/Extensions/ATIRadeonX1000.kext/Contents/Info.plist (You can use nano, pico, or any other editor if you are not comfortable with vi)

- Find the key IOPCIMatch

- Add the following : "0x71C21002" to the list contained between <string> and </string> right below the IOPCIMatch line. Make sure you add a space before and after the 0x71C21002 string

- Save the file and exit the editor

- cd /System/Library/Extensions

- chmod -R 755 *

- chown -R root:wheel *

- diskutil repairPermissions /

- Reboot

 

Now, you should have full working QE/CI that does not freeze!

 

Please let me know (by posting here) if this worked for you.

Share this post


Link to post
Share on other sites

told you to use these : 10.4.5 ATINDRV and 10.4.7 IONDRVSupport

 

cyclonefr woulda told you the same also, its not new infos.

 

-D-

Share this post


Link to post
Share on other sites
told you to use these : 10.4.5 ATINDRV and 10.4.7 IONDRVSupport

 

cyclonefr woulda told you the same also, its not new infos.

 

-D-

 

 

Diabolik,

 

Inspite of using 10.4.5 ATINDRV and 10.4.7 IONDRVSupport, QE/CI would cause my machine to hand with 8.8.1 and 8.9.1 kernels. I tried multiple kernels with the same result. When I switched to 10.4.10 and the 8.10.1 kernel bundled with Koolkal, the problem went away. For me, while the packaged 10.4.5 ATINDRV and 10.4.7 IONDRVSupport were necessary, the 8.10.1 kernel was also required to make QE/CI stable.

 

Thanks

Share this post


Link to post
Share on other sites

Thank Acerbix, your method worked for me

 

I installed DVD Tubgirl 10.4.10, everything work fine except my X1600P card (same your deviceID).

I install Natit driver, but it just can change resolution ..CI/QE not support. I edit ATIx1000.kext for CI/QE by Borisbadenov. After restart my vid support CI/QE..but it seem not run smoothly and slow

 

I read your topic and edit it by step 4. It worked perfecly ....

 

My system: AMD 3000+, 1GB DRR400, DFI Nforce4 Ultra D, 80GB ATA, DVD TUbgilr 10.4.10 TEST 1.

Share this post


Link to post
Share on other sites

My method is leave all 10.4.10 kexts in system and a little info edit in IOPCIMatch with uni Natit kext.

And I get QE/CI with my 1600P,but I find it's not stable in high loading game tested(like Quake 4 active all effect).

Althought,It's stable in OS GUI use.

It's not natit's fault because I tested in 10.4.10 kext in old method without natit(sure QE/CI enabled) and there are still the same problem.

So,I think that kext may have some problem with 1600P chip.

but,if you disable ATY,wormy plugin loaded(mouse tear,without res. change) and OpenGL stable again.

and all tested in 8.10.1 kernel.

 

So,I think I should waiting for 10.4.11.....or change to use another video card ^_^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×