Jump to content

Input Remapper 1.0.04 Release


42 posts in this topic

Recommended Posts

This could really be a new topic but the first post says log issues so...

 

I was directed to Input Remapper by someone on the Parallel's desktop forum who demonstrated how to prevent Command+Q quitting Parallels. It works very well.

 

So I thought I'd remap the @ and " keys which are reversed on Windows keyboards. I can successfully map the Left Shift and swap the @ and ". however when I add further key bindings for the Right Shift key the app won't accept the correct commands. In fact it replaces the mapped key sequence with nothing.

 

I've attached a screenshot. The first sequence is for Command+Q, the second and third the functioning @ and " swap using the Left shift and the last one (highlighted) is attempting to remap Right Shift+2 to Right shift+'. You'll notice the final brackets are empty.

 

Any recommendations for making this work. It would be the ideal solution if it did.

 

Thanks,

Mark.

post-134229-1189690610_thumb.png

Hi, I don't know if this is related to Input Remapper or not, but I'm experiencing the following problem. When I want to type a right bracket (]), I get a euro sign (€) instead. Given that there is a € on the key where the ] should be, this might be intented.

 

Since I'm using a belgian keyboard, I have to use Alt-Gr + $ to get to ] (and similarly Alt-Gr + ^ for [).

 

This is rather annoying, as I'm a programmer and thus am in need of the ] quite a bit. I can workaround using copy-paste, but it's a bit ominous, I think. :)

 

I tried remapping the key combination RWIN + RBRACK, but that doesn't work. I even tried generating the Left-Alt + keycode sequence (which you can use in windows to enter any character), but that doesn't work either. Actually, trying to remap that combination to any key (for example, just "A") doesn't work.

 

When I try to remap any other key (say "A") to the right bracket, I get a €. Figures.

 

any thoughts?

I am running:

 

MacBook Pro Santa Rosa 2.4ghz Nvidia 256mb 8600M GT

 

Windows Vista Ultimate 64-bit Edition

 

I have Bootcamp 1.4

 

Input remapper is working like a CHARM...EXCEPT!!!!!!!!!!!!!!!!!!

 

I HAVE ONE PROBLEM!!!:::: My Screen Brightness Will Not Change!. The iicon indicator shows up that the brightness is going higher or lower depending on whether i do fn+f1 or fn+f2....even in the Input Remapper Control CEnter you see the Screen Brightness going left and right as i click the keyboard...

 

 

my screen is not changing brightness!!!! help!!!!

 

i have reinstalled and uninstalled and restarted...and everything so many times...

 

i dont know what more to do! i uninstalled...then restarted the comp....reinstalled....then restarted the comp...

 

EVERYTHING WORKS....EXCEPT MY BRIGHTNESS!!! help =(

 

(sry for caps im very pissed! ive been workin on it for hoursss!!!

Beliyaal,

 

You are a :censored2: superstar. Thank you so much for creating this most excellent piece of software. The key mapping functions are great but the real reason I am ecstatic about your software is the fan control. I can now keep my MBP nice and cool!

 

I have posted your forum thread on the official Boot Camp thread at Apple, since many many people have heat and key mapping issues there, so I hope you don't mind.

 

Thanks once again and I'll be keeping an eye out for future versions from you.

 

;)

Hey--

 

I live by InputRemapper. After upgrading to 1.0.4, I get random hangs that force me to do a hard power off. I tried uninstalling and reinstalling 1.0.3, but the Fn keys for brightness, sound, etc. don't work anymore on 1.0.3. (This is on Vista on original MBPro.)

 

 

=Ash

hi

 

my letters and ponctuation signs keyboard touchs are not synchronize at all when I compose with XP.

 

exemple: my "m'' touch compose ",''

another exemple my "z'' touch compose "w''

 

I could add many other ones.

 

Is it a problem easy to solve. There is symbols that I don.t even know where to get them when I work with office

 

 

thank you for helping

Hi, I've been using your program for a long time now on a MBP. Almost since they came out and it has really been great.

 

However, I just bought a new iMac and I am using the new slimline bluetooth keyboard. The drivers that came with BC 1.4 don't seem to support this keyboard. When I installed Input Remapper, it doesn't seem to know what to do with the new keyboard either, although the fan control works. Do you know of any work arounds or fixes to get the eject and sound keys working. I've tried all of the remappers out there and none of them can see the eject or fn keys. If it help any, when I look at the Input Remapper config, there are no setting for anything, just the two headings.

 

Thanks

 

Mike

I have the same problem. Just got me the new Bluetooth keyboard (aluminum). Under OSX I got a Software update and everything works like a charm but under Windows it still doesn't. I hope you can support it soon so I can modify the fn key to be a CTRL key, this drives me nuts under windows.

 

keep up the good work, I bet this tools works great, just not on the new keyboards yet.

This may be slightly off topic, but:

 

Does anyone know how to switch Ctrl and Fn keys *in Mac OS X*?

 

I have seen program that makes the Fn key also Ctrl but not any program that will switch it. I'm so used to the remapped keys in Windows using Input Remapper that I want the same remapping on Mac OS X too. Basically I want to do the following in Mac:

 

Switch Fn and LCtrl

Make Enter as RCtrl

 

and that's it.

 

Any help is appreciated. Thanks.

  • 2 weeks later...

Windows 2003 SP2 on a MacBookPro 15" Santa Rosa (purchased sept 2007), NVIDIA Display:

 

Brightness Control: _not_ working at all. Sliders move, but brightness is not adjusted.

Keyboard Lights: only works when manually set. When set to auto, the lights go off, even when the sensor states 50 % brigthness.

 

So while it's a nice utitity, for the purpose I originally found it for, it doesn't work as advertised. Am I overseeing an important thing?

Hi All.

 

ok, I'm new to the Mac world, but i'm no newbie comuter user...

 

I'm having some problems with the Input Remapper utility. Mainly - it doesn't seem to be doing anything at all!

I've got a new Macbook Pro 2.4Ghz Core Duo, and i've installed Parallels, and WinXP Pro SP2 and the few programs I don't need a right click for.. no problem with anything except trying to ge the right click going.

So, I then installed the Input Remapper, and it shows in the Windows Taskbar, and when i click on 'Configure', I get a box with two words in it. Presets, and Remappings.. clicking on either does nothing, there is nothing else going on in that box.

Pressing 'fn', ctrl, or alt with any clicks does nothing...

 

Anyone any ideas what's up with this?

 

Any help much appreciated.

 

:(

Hi, I have a slightly different problem. I want to use the new Apple bluetooth KBY with my work laptop (for this reason I have no choice on OS and other things). Have solved the pairing issue with widcom drivers and broadcom chipset (If someone is interested, can provide the changed registry setting for this.) Keyboard works with the Apple drivers except the usual CTR-ALT-DEL issue. For this reason I tried remapper, but the problem is that I use W2000 and it seems to be remapper runs only on XP (same as rktools from windows to remap keys). Has anyone a solution or work around to get remapper running on W2000 ?

Thanks,Wolfgang

Official supportability of Input Remapper and Boot Camp 2.0 (ships w/ OS X Leopard 10.5)?

 

Anyone's personal experience?

 

I have just updated to Book Camp 2.0, and after reinstalling Input Remapper 10.0.04, everything seems to work fine.

I have Leopard, and reinstalled Input Remapper on my Vista Bootcamp and have noticed that Ctrl-U and Ctrl-I do not work (which is a bummer when you have to use Word and Onenote a lot.)

Guest
This topic is now closed to further replies.
×
×
  • Create New...