Jump to content

[Another] Get Radeon 9600xt working on OSx86


10 posts in this topic

Recommended Posts

After many hours wasted searching the forums and inquiring on the IRC channel, I've finally gotten my Radeon 9600xt 128mb AGP card functioning on my hackintosh (10.4.9 uphuck v1.3 DVD).


I won't bother going into details about my adventure, but I'll add some tricks and tips that I haven't seen anywhere on the forums.


Step 1: Install Callisto drivers.


-You have to be able to change your resolution before you do anything else. Even without QE/CI support or Quartz2d suport, resolution is a must. Get your Callisto drivers installed.

(http://omni.110mb.com/callisto/). I used 008, and people seem to get the most success with it anyways. 003 is for radeon mobility chipsets.


**Follow the instructions found in installation.html** (in the Callisto folder on your mac drive)


For people who are too lazy to look for it:


The installation is fairly simple, download the zip file, extract and copy the two .kext folders to your /System/Library/Extensions/ folder. Make sure that the permissions on the newly copied folders (recursive, -R) are 755 with root:wheel ownership. Lastly edit the Info.plist file in CallistoHAL.kext/ to match your ATI card's PCI device ID and reboot.

If you do not know what I'm talking about you are truly inapt - go back to Windows and forget the novelty factor of OS X. Else, if you are really desperate to use this driver then do the following:

  1. I have typed this out of my head, so if something is incorrect, let me know, ok?

  2. Download the file to the Desktop (surely you know how to download, no?)

  3. Safari will download and unzip the archive into Callisto_latest.

  4. Start a new terminal window from Applications->Utilities

  5. cd ~/Desktop

  6. cd Callisto_latest or wherever the archive was decompressed.

  7. vi CallistoHAL.kext/Contents/Info.plist

  8. Replace my own PCI device ID with yours under the IOPCIMatch key (4150 is mine...)
  Don't tell me you don't know how to use vi? Try nano or Textedit then.

  9. If your DFP monitor is detected as CRT by the driver, you can try to hard-code the EDID string of your monitor. Use the Monitor Asset Manager (or any other way) to retrieve your 128 byte HEX value string. When using MAM, you only need the actual hex values do not include line numbers (00:, 10:, 20:, etc).

  Next open the Callisto_latest folder on your desktop, then right mouse click on Callisto.kext and left click on Show Package Contents. Open the Contents folder and there you will see Info.plist.

  Double click on Info.plist file and it *should* open in Property List Editor. Click on the arrow next to the Root, then arrow next to the IOKitPersonalities, then next to the CallistoMatch.

  You will see a key called MONITOR_TYPE,EDID. Double click on it to edit it and replace the MONITOR_TYPE with DFP so it says DFP,EDID or with CRT,EDID for a CRT screen.

  In the value field of the same key replace the hex values there with the ones from your EDID, making sure that the < and > remain on the ends. You will see my original value there, it's the EDID for Apple Cinema Display 20" :). Once done, save the file with File/Save.

  Here's an imaginary EDID string, just so you see how it looks like:
  00 FF FF FF FF FF FF 00 10 AC 19 A0 4C 56 52 31 0D 10 01 03 80 2B 1B 78 EE EE 91 A3 54 4C 99 26 0F 50 54 A5 4B 00 81 80 71 4F 01 01 01 01 01 01 01 01 01 01 01 01 7C 2E 90 A0 60 1A 1E 40 30 20 36 00 B2 0E 11 00 00 1A 00 00 00 FF 00 48 46 37 33 30 36 33 52 31 52 56 4C 0A 00 00 00 FC 00 44 45 4C 4C 20 32 30 30 37 57 46 50 0A 00 00 00 FD 00 38 4C 1E 53 0E 00 0A 20 20 20 20 20 20 00 33

  It is absolutely important that you do not miss any characters in your EDID string, and that it is exactly 128 bytes long. Also have in mind that the above procedure is ONLY for non-Mobility owners, Mobility owners should not do this, your settings come from the BIOS.

 10. sudo mv Callisto* /System/Library/Extensions/
  (enter your password when prompted)

 11. sudo chown -R root:wheel /System/Library/Extensions/Callisto*
  (enter your password when prompted)

 12. sudo chmod -R 755 /System/Library/Extensions/Callisto*
  (enter your password when prompted)

 13. We might need to clean up some of the display settings files, so proceed with the following inside the terminal window:
	  * sudo rm -f /Library/Preferences/com.apple.window*

	  * rm -f ~/Library/Preferences/ByHost/com.apple.window*

	  * rm -f ~/Library/Preferences/ByHost/com.apple.pref*
 14. Also remove any display settings in your com.apple.Boot.plis file, for example:
  Graphics Mode
  This file is in the /Library/Preferences/SystemConfiguration/ folder.

 15. Before you reboot, make sure you remove the Extensions.mkext and Extensions.kextcache, so that system refreshes those and include Callisto:
  sudo rm /System/Library/Extensions.mkext
  sudo rm /System/Library/Extensions.kextcache

 16. Reboot and hope all goes well.

 17. If it does, you will see your screen's default resolution (whatever that is based on the EDID). Go to your Display Preferences and try changing a resolution in there.

 18. If you do not see new resolutions in Display Preferences, you did not follow the instructions above to the letter or the driver does not work properly on your computer, go back and try again.

 19. When you change the resolution and get a picture, congratulate yourself.
  Else, if you get a black screen, don't just click with the mouse like mad. Try using the cursor up and down key to switch between other modes and see if that brings the image back.

 20. If there's no image at all, read the Troubleshooting section for possible solutions. If those fail then the driver does not work for you. Boot into single user mode (that's -s switch in boot prompt) and remove the two KEXT files...sorry it didn't work.

 21. If you mess up your OS, don't blame me, you should've read the F.A.Q. first.

Last update: 06-Jun-06

Site and content by omni © 2006


credit and much thanks to omni for this (obviously).


I found that doing everything from the terminal was. The easier way is to copy CallistoHAL.kext to your desktop. Then, right click --> show package contents --> Contents --> Info.plist (open with texteditor). After you edit the line which is specified in the Callisto install instructions, save the .plist file. Go back to /System/Library/Extensions where you got the original CallistoHAL.kext file and drag it into the recycle bin. It will prompt you for a password, so authenticate it. After you delete the original kext, copy the CallistoHAL from your desktop into the Extensions folder. Then, go to the terminal and type this:


sudo chown -R root:wheel /System/Library/Extensions/CallistoHAL.kext

(it will prompt you for pw after you press Enter)


sudo chmod -R 755 /System/Library/Extensions/CallistoHAL.kext

(it will prompt you for pw again)


These 2 commands will reset/repair permissions for the file CallistoHAL. Use these two commands for any file you end up editing in the Extensions folder, whether they are a .plugin file or a .kext file


**this next part is important**


Go to /System/Library and delete the two files named Extensions.mkext and Extensions.kextcache. Basically, everytime you edit something found inside the Extensions folder, you should delete those two files.

reboot to see if it worked.


Step 2: Get QE/CI working.


Try every method in this section until it works. The last one is the one I used (which I never saw on the forum) and it got my {censored} working.


-Using the same method as above, edit the Info.plist of the file called ATIRadeon9700GA.plugin (found in the Extensions folder with all the other ATI {censored}).


**under IOProviderClass key change IONDRVFramebuffer to CallistoFB, update or delete Extensions.mkext and Extensions.kextcache, repair permissions for the ATIRadeon9700GA.plugin file using the commands posted above in blue (just replace CallistoHAL.kext with ATIRadeon9700GA.plugin) then reboot.** (once again, this is all taken from omni's FAQ.html file found in the Callisto folder. credit and thanks to omni)

If that doesn't work, try doing this.


Install AGPGart (latest version). Using the same methods as above, edit the Info.plist file for AGPGart.kext. Find the line that says:




and replace it with:







repair permissions for this file, delete Extensions.mkext and Extensions.kextcache and reboot. credit and thanks to iFreddy96 for this.


The top 2 methods are the most prominent ones found on the forum (at least from what I've seen of manual methods. I don't really think katana or those other premade installers were worth the risk.


If those 2 don't work, then this one might just do it.


Using the same methods as above, edit the Info.plist for the ATIRadeon9700.kext file. Right at the very bottom of the file, there should be a line that says <string1.0.0b1</string>.


Right underneath that, put these 2 lines:





The bottom portion of your Info.plist file should look like this:

















This is what did it for me. Credit and thanks to flama for pointing this out to me on the IRC channel. If you do get QE/CI working, search the forums for MightyMouse and AntiTear2. This will get rid of the mouse tearing and artifacting you are bound to run into.


If you want to get Quartz2D enabled, go here: http://forum.osx86project.org/index.php?showtopic=11550


If I left anything out, please correct me. I did this all off the top of my head with some copy/pasting every now and then.

Link to comment
Share on other sites

I followed all the steps but I still can't get QE/CI working. The last step wouldn't boot..it gets a corrupt resolution and then reverts back but hangs after that. so it's trying to load AGPGart, Castillo, and the ATIRadeon9700 driver, is that what I'm suppose to do?

Link to comment
Share on other sites

Thank you for sharing.

I have now on my desktop pc a 9800XT with resolution change and CI and QE supported.


The third step was the magic step :thumbsdown_anim:



Radeon 9800 XT:


Chipset Model: Radeon 9800 XT

Type: Display

Bus: PCI

VRAM (Total): 128 MB

Vendor: ATI (0x1002)

Device ID: 0x4e4a

Revision ID: 0x0000



Resolution: 1440 x 900 @ 60 Hz

Depth: 32-bit Color

Core Image: Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Supported

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Works great for me, using a Saphire Radeon 9600XT 128mb AGP.

The first QE/CI method worked first go! :P


I've a question though; I notice in System Profiler that it's using the PCI bus, not the AGP bus. Does this cause any performance drop, and is there a way to set it to use AGP?

Link to comment
Share on other sites

  • 3 weeks later...
JoyMonkey: What kind of motherboard are you running that on? I haven't been able to get any AGPGart working on my 865G/ICH5 board (ASrock P4i65G). I've tried everything - I've got the Sapphire 9600XT 256mb



What I found out is that you need to change the AGP Aperature in the bios to 128mb or lower. That is what did it for me............ Found it on the AGPGart oficial site. Thanks to everyone on this site for all the help, now I have a fully working Dell E1705 and a AMD Athlon 64 4000+ desktop system running mac OS 10.4.9 with qe/ci enabled on both using mighty mouse and antitear2. :angel:

Link to comment
Share on other sites

  • 8 months later...

can someone help me with this. its not working. i cant get QE/CI working. it wont enable. i can notice a difference without them. can someone help. i followed all the instructions but the computer wont boot after that. it gets stuck at the grey apple logo. please help. thanks!

Link to comment
Share on other sites


  • Create New...