Jump to content

Leopard DVD's not bootable


5 posts in this topic

Recommended Posts

At first: excuse me for my probably suboptimal English, I'm not a native speaker but I hope you'll understand me anyway. :whistle:


I tried to burn a DVD from the Leopard disk image that's around the internet for a few days. I'm on an iBook G4, PPC architecture, and the internal DVD drive's broken because it fell down from my desk about a year ago. Mea culpa ...

I own an external DVD writer that's connected via USB 2.0 and I use that for all purposes the broken drive cannot serve anymore. So I burned the disk image on a DVD+R DL. I know that PPC Macs are not able to boot from USB devices, but I fixed that by entering the drive into Open Firmware's boot record, so that shouldn't be the problem (besides, I tried to boot from my Tiger DVD via the USB drive and that worked just fine).

When I try to boot, my machine just starts up Tiger from the hard drive and ignores the DVD. I thought it may be because the dual layer support of the drive's just not working, but even after I stripped the developer tools off the disk and burned it onto a plain DVD+R, there's no result.


Actually, I do not own an external hard drive or an iPod or anything that's large enough for the disk image to be recovered on it ... so booting from an DVD is the only option I have (maybe apart from buying an iPod, but I'm short of money actually and I'm saving every bit that's left to buy a MacBook this october).


Is there a way to force my machine to boot from the DVD or something else I can try? I'm just dying to see Leopard in action. :D


Thank you in advance,


Link to comment
Share on other sites

I ran into the same problem, What I ended up doing was, after creating a partition to install Leo on (14+ hour defrag) I created a second Partition (7Gb) and restored the image to the second Partition. Make sure you name them in some way that you will know which is which, then I went to "Startup disk" and selected the volume which I had Restored the file to... no burning nesc. I'm in the process of installing right now, I will let you know if it completes.

In Short:

Create 2 extra Partitions (Recommend having at least 20Gb of free space)

1: 12Gig (I did it with 8)

2: 8Gig (I did it with 7)


Restore Image to 8Gig Partition (Disk Utility)


Goto System Preferences


Select Startup Disk


Select Volume which was restored then hit "Restart"


Make sure to select the appropriate installation volume when going through the installer


I should note that the installer says you need a minimum of 10.1Gig (edited for clarity) in your installation destination, I disabled everything and it said I was good to go.


T-8 minutes until complete.



EDIT: Installation was successful, MAN She Screams :0)

Link to comment
Share on other sites

Ah, thanks for your hints but I already figured out what I did wrong.


My main problem was that I added the wrong partition into Open Firmware's boot record. I went for ud:1,\\:tbxi but as you can see on the image I posted earlier, the identifier is disk1s2, so adding ud:2,\\:tbxi is what fixed the problem at last.


I'm surfing with Leopard now and it's running damn smooth. I just love Spaces and the Stacks. B)

Link to comment
Share on other sites


  • Create New...