Jump to content

Anyone w/ Asus A8V and uphuck 1.3? Need tips.


11 posts in this topic

Recommended Posts



Has anyone managed to install the uphuck 1.3 release on an Asus A8V based system? I could use some tips on which components to install etc.


My specs: Asus A8V, Athlon X2 3800+, NEC 3540A DVD drive, IDE harddrive (clean), Inno3D GeForce 6200, USB mouse and keyboard.


My experience so far:


1) No mouse or keyboard at first, unplug/plug did the trick.

2) Installed AMD package with Natit 0.2, AMD SSE3 and Universal kernel 3.

3) "...boot.plist not found", Googled for it and learned that you can boot from the DVD and type rd=disk3s1 (or whatever your OS X drive is called). Does anyone know how to fix this?

4) Got to a screen telling me there was no keyboard detected. Could this be because I installed the additional USB driver?


I'd be greatful for any advice here (anyone with a similar setup?). Thanks!

Link to comment
Share on other sites

Just to let you know..you dont want to install all those kernels. Pick the one you need and install it.


For instance, select the main AMD 10.4.9 option at the top (since you have an AMD system and not Intel), then select only 1 Kernel from the Kernel options, such as Universal 3 or AMD SSE3. Selecting more than you need is not helping you..it makes things worse. I know...I did that same thing and had problems.


I selected USB under drivers, as well as others...and I have USB keyboard AND mouse and have had no problems (until I stuck a 3rd stick of 512MB PC2700 memory in my board..didnt like that for some reason and made the mouse and keyboard not work) with my USB. No unplugging and plugging back in.


Good luck.

Link to comment
Share on other sites

Ok, I managed to get into OS X today, by connecting the keyboard to another USB port on the front of the case (i.e. one of the internal connectors). OS X couldn't identify the keyboard at first and told me to press the key next to [shift]. LEDs didn't light up, no caps lock, num lock or scroll lock. But...I was finally in. Ah, the feeling. Played around a bit and then rebooted. Had to boot from the DVD as always and tell it which hd/volume to boot from. This time neither keyboard nor mouse worked. Tried every USB port. Nothing.


The installer lists my Logitech keyboard and Microsoft mouse in the system profiler.


When I start up the computer my mouse is recognized and lights up. And when I boot from the OS X DVD I get something like this:


"USBF: EHCI controller unable to take control from BIOS", and something about "AppleUSBEHCI"...


and the mouse is gone.


According to the list of compatible hardware my mobo (Asus A8V) should work fine, USB and all.


One more thing...I don't get that grey startup screen with the Apple logo, just the boot info (and I didn't choose verbose mode in the installer).

Link to comment
Share on other sites



everything is supported.


You need:


when installing, using disk partitioner, use the partition editor (even if you just want the whole disk to be used - just choose 1 partition as the scheme.) Then before you partition, choose options at the bottom and make sure it makes an MBR. Then write the partition. Then install.



*question* did you install agpgart? Not sure if this needed and would like to know.


natit issue: you prob have to put your dev id in the info.plist in your GeForce.kext and NVDAResman.kext(to change resolution).



might need this if uphuck v1.3 doesnt provide marvell lan support. might have to edit the plist, know the device/vendor id prior to installation just to avoid headaches.


and ofccourse:


repair disk permissions after changes.

boot with -F flag, or delete Extensions.kextcache and Extensions.mkext from /System/Library/

Link to comment
Share on other sites


It tries to boot now, doesn't just stop at the blinking cursor. Not sure what I did different. I think I did the same thing this time, i.e. making just one partition etc. However, after a short while the grey apple screen turns dark and I'm told to restart my computer. Must be something I installed.


By the way, what about ACPI? BIOS settings?



I chose to install AGPGart 2.1, the version I'm using now with JaS 10.4.8. Nothing I tried let me change the resolution (with uphuck). AGPGart is indeed needed, otherwise the card only works in PCI mode. It is also important to set the aperture size to 128 mb (or more?) in BIOS, otherwise it won't work. This isn't really mentioned in any of the guides, which is strange. Same thing about disabling USB legacy support and having to use a PS/2 keyboard (otherwise you can't get past the Darwin bootloader which requires you to press enter twice before the actual boot up starts).



I installed the file you linked to, but when I rebooted I got an error message (when I entered graphical mode), that OS X couldn't use the kernel extension or something. Skge.kext was installed automatically with JaS, I'm not sure which version it is. Anyway, it works great.



I think I'll go on using 10.4.8 until someone makes the mother of all installation dvds for 10.4.10.

Link to comment
Share on other sites


  • Create New...