Jump to content

Sudo wont work


21 posts in this topic

Recommended Posts

Worked fine then all of a sudden last night iget this error


sudo: can't stat /private/etc/sudoers: No such file or directory

dion-tudryns-computer:~ Dion$ postdrop: warning: unable to look up public/pickup: No such file or directory


I have absolutely no idea what tha means, i tried creating a sudoer file, but without the sudo function u can guess how well that went...


any help will be appreciated...

Link to comment
Share on other sites

Ill give it a try, thx


the apps still downloading, but i also get errors that programs cant save to settings, so everytime i open a program after a reboot its like the first time opening it, wondering if theyre related...

Link to comment
Share on other sites

Check this out: http://forums.macosxhints.com/archive/index.php/t-30693.html



What's in your root directory? ls -l / (that's lowercase LS -L)


Specifically, you should see one line that shows the symlink for /etc:

lrwxr-xr-x 1 root admin 11 10 Sep 10:38 etc -> private/etc


Since both errors are claiming that they can't find /etc (which doesn't really exist, as the symlink above shows -- it's really /private/etc) that's my first guess...


Edit to add: I'd also see if the real etc directory is still intact:

ls -ld /private/etc

to see if it's just the link that disappeared, or the whole directory.

It seems that a missing symlink (/etc) is the root of the evil here.



Link to comment
Share on other sites


  • Create New...