Jump to content

Most apps crash


19 posts in this topic

Recommended Posts

Dell Dimension 3000, Intel P4, 512MB, CPU-Z reports sse2/sse3 capable.


I'll start with the problem and then list what I did so far.


Mail works

Safari crashes while loading the start page

Calendar works

iTunes won't even open

iPhoto won't open

I tried to install Firefox, but it won't load either. Crashes when mounting the image, so I copied the app over, but it won't load.

If I try to select GetInfo on an object in the finder, it closes.


I created a second partion with Partition Magic

I installed the deadmoo image.

It booted up, but the graphics were useless. Grey and pixelated. I changed the video memory setting in the bios to 8meg and rebooted. I could only boot with the -x option (safe mode).

I deleted the AppleIntel830 and 915 .kext files as well as the TPM kext and rebooted.

It booted up with good graphics and good speed.


That's when I discovered that most apps won't run. I've read several posts and guides looking at different options. I replaced the mach_kernel with one that isn't patched for SSE3. That didn't work so I tried replacing the CoreGraphics file, looking for an unpatched version. The one from my 10.4.9 system caused it to just lock up at the grey boot screen. I reversed that and found one on torrent that said it was the original unpatched CoreGraphics. I installed that one and it booted up fine, but no change to the apps.


I'm open to any more suggestions.





Link to comment
Share on other sites

Just wanted to add the output of System Profiler for the x86:


Hardware Overview:


Machine Name: Mac

Machine Model: ACPI

CPU Type: Intel® Pentium® 4 CPU

Number Of CPUs: 1

CPU Speed: 2.79 GHz

L2 Cache (per CPU): 1 MB


Memory: 512 MB

Bus Speed: 2.13 GHz

Boot ROM Version: A02 (Dell Computer Corporation)




Type: VGA-Compatible Controller

Bus: Built-In

Vendor: Intel (0x8086)

Device ID: 0x2572

Revision ID: 0x0002

Kernel Extension Info: No Kext Loaded



Resolution: 1024 x 768

Depth: 32-bit Color

Core Image: Not Supported

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported

Link to comment
Share on other sites

That's pretty much what I thought. I just haven't been able to figure out the right combination of things to do to get them to work. Does anyone have a good list of steps to turn QE/CI on?



Link to comment
Share on other sites

Hmm, that doesn't look good. I just finished searching the wiki and the only OSX Version that supported that card seems to be 10.4.1.

The card requires a file called "AppleIntelIntegratedGraphics.kext" but apparently it has been removed from the Extensions folder and never put back.


I will keep looking and write back if I find anything,



Link to comment
Share on other sites

Go Aplications

Click on aplication that usualy crashes and right click on it.

Chose "get info".

On the opened window chose: Rosseta (if supported).

Use Rosseta for aplications that crashes only.

Link to comment
Share on other sites

Thanks for the advice, but Finder closes whenever I try to select Get Info.


I picked up a few other things I'll try tonight.


See if you can increase vid mem in bios - it's at 8meg now, but I upgraded the bios to A03. I'll see if it allows for a higher setting.


run fix disk permissions - a couple people said this helped


boot into xp first then restart into tiger - sounds odd, but may have something to do with vid memory allocation.


use -v -f options at bootup.

Link to comment
Share on other sites

The most of my trys is single disc clear installation.

I use an individual Os selector after that if i want to use dual boot system.

Best results i had with 10.4.7 so far.


Core Image and Quartz Extreme it will be unsupported with the most of the cards.

Link to comment
Share on other sites

8mb video? You need a new vid card, man.



QE/CI are not needed for most apps. I survived for a long time on a Radeon 9200 without it, and ichat was the only program that ever crashed.

Link to comment
Share on other sites

So, what's causing Safari, iTunes, Firefox, etc... to crash? Why does Finder flop if I try to Get Info on an app or folder? Is that video related or something else?


By the way, couldn't increase the bios above 8meg

fix disk permission fixed alot, but no difference

-v -f made no diff

boot to windows and Restart to Tiger made no difference.

Link to comment
Share on other sites

I don't think that's video memory the way you're thinking. I found this info about the DD3000:




* Intel Celeron D 330 (2.66GHz) Processor

* 512MB PC3200 DDR Memory

* 80GB 7,200rpm Hard Drive

* 48x CD-RW Combo Optical Drive

* AC'97 Audio with Dell A215 Stereo Speakers

* Intel Extreme 2 Integrated Graphics with 64MB Shared Memory

* v.92 56Kbps Modem and 10/100 Ethernet

* Six USB 2.0 Ports and Three PCI Slots

* Dell E773c 17" CRT Monitor

* Windows XP Home, Word Perfect Productivity Pack, MS Money 2004 and McAfee Security Center



I think it's buffer, not the whole video memory.

Link to comment
Share on other sites


  • Create New...