Jump to content

X1600 Pro Graphics Drivers give no result

11 posts in this topic

Recommended Posts

I recently got the Mac OS X 10.4.8 [JaS AMD-Intel-SSE2-SSE3 with PPF1 & PPF2] ISO and installed OSX with that, and was just amazed at the fact that I had OS X running on my machine. I just have one slight problem, all of the methods I've tried to get my graphics drivers set up have failed.


I tried Natit/UNI, that gives a black screen / no output after booting up (White Apple Logo Screen displays and spins, but when the UI should load, it just drops the display). I've tried manually editing files with Boris' method, that seemed to get a little closer as I was able to see a flash of the UI before it went to no signal if I switched to VGA instead of DVI. I've also tried the ATI Specific drivers on the Natit site with pretty much the same results.


I don't mind editing the .kext files, i think it's fun and feel like I'm learning something, so give me some ideas here on how to get this working.


Here are my system specs:

AMD Athlon 64 3000+ 1.8ghz 512 L2 Cache SSE2 Socket 939

ASUS A8R32-MVP Deluxe Socket 939 ATI XPRESS 3200 Chipset (Crossfire Capable)

2x ATI Radeon x1600 Pro (Sapphire) 256mb PCIe 16X

3x 80gb Western Digital SATA [2 are raid 0 for windows (have to unplug for mac drive to boot) and the other is partitioned in half for mac and documents]


430w Thermaltake PSU (yeah I know I need to get a stronger one)

Airnet AWD108 Wireless (cheap card, but it works... in windows anyways)

2x Gigabit Marvel Ethernet (worked right away on MacOS with no trouble)

Realtek ALC882 8-channel CODEC (worked with drivers from Here)



I think that's all that's in my system, I'll add to this if you need more info. Also, I tried both VGA & DVI with all the methods I listed above, VGA seemed to show a few more signs of it possibly working but it always just goes to a black or blue screen. I also took out my 2nd x1600 to see if that was the issue but no difference. MacOS, with the default graphics drivers, shows both graphics cards, and will probably work fine off of both, I just have no core image / Quartz, and no hardware acceleration for what I want to use MacOS for. I'm planning on switching back to mac (used them growing up but wanted to play games) but I'd like this to work to hold me over until I can afford a new one.


Also, anyone know if that wireless card works at all with Mac? I also have a Netgear MA311 that I could switch to if you guys have got that working.

Link to comment
Share on other sites

I tried his website already, the installer returned a black screen upon reboot, and I tried just the .kext file, and I'm not sure but are you just supposed to dump that into /System/Library/Extensions/ ? When I did that, on reboot it just returned some message that it was unable to load Natitx1600.kext. Do I need to rename that to something else? or edit it for my card specifically?


I read somewhere that some people were reporting problems with SLI capable motherboards? Could there be an issue with my ATI Xpress 3200 chipset? I don't see why there would be a hardware problem though since everything works fine, just not the drivers.

Link to comment
Share on other sites

I tried editing the NatitX1600.kext and put my device ID in where it lookedl like it belonged (0x71ce) and stuck it in Extensions. That didn't work, so I tried renaming the file to different existing ATI files like ATINDRV.kext and ATIRadeonX1000.kext and that also didn't work. I'm sure I'm way far from what that file is meant for, but I'm just trying every little possible thing.




Ok, with more searching I found this page explaining more about the .kext file. I'm gonna try that and see what happens. /crosses fingers...

Link to comment
Share on other sites

I had the exact same problem as you on the exact same hardware.


Here is what I did to get it working. I reinstalled with the same DVD you have, but I made sure that I DID NOT check off either of the ati drivers (agp or pcie.) Leaving it just to use the native drivers. On that install it worked fine. I then used NatitX and it worked great.

Link to comment
Share on other sites

thanks for the help so far guys, the link that I found that explained how to basically make the system use the .kext file got me much further BUT I'm stuck at another spot right now.


I can make my system boot to where I can change resolutions, but no matter what resolution I select, I get horrible glitchy lines running vertically down... post-103920-1177903055_thumb.png


This is useable but obviously, ugly and quite annoying.


The second thing I can do, is edit /System/Library/Extensions/ATIRadeonX1000.kext/Contents/info.plist, and just simply add my card's Device ID Number in, and suddenly Quartz Extreme and Core Image work, really cool looking btw with Dashboard. The problem with this, is I can't change resolutions.


If I try both fixes at the same time, the system boots and then goes to a plain blue screen when it tries to load the GUI.


Right now, I'm trying to figure out how to add my EDID to the NatitX1600.kext, I'm guessing there's just a simple setting that I'm just not getting here...

Link to comment
Share on other sites

I tried Chenwk's suggestion and unfortunatly, booting with those .kext's has made my computer stop booting, it just stays at the white apple logo screen and spins forever. I went into Single User Mode and tried to copy back my backed up .kext's but the system still won't come up.


Oh well, another day, another try. I'll wipe it clean again and start over.

Link to comment
Share on other sites

leperMessiah, try -x option in boot option, this is supposedly to be able to get you in, from there, maybe try putting back the backup file and set the user permission again. =) hope this would at least get you back to square 1 again. don't worry, i've tried plenty of times and reinstalled the OS more than i boot into it =) you'd find a suitable method somewhere to get your card working. =)

Link to comment
Share on other sites

Awesome! I got it working :(


I took Diobolik's x1600 installer from his website linked through this thread. Used Pacifist to open the package up and I took out just the ATINDRV.kext and NatitX1600.kext and threw them into my Extensions folder.


I then edited the NatitX1600.kext to include my device ID 0x71ce1002, rebooted, and my resolutions worked perfectly, no display corruption, just abosolutly perfect, but I didn't get CI/QE yet.


To get CI/QE, I edited the default ATIRadeonX1000.kext to include my device ID. Rebooted and voila, full QE/CI with resolutions.


World of Warcraft started up perfectly and I'm now downloading updates for it so hopefully I can play that smoothly so I don't have to switch back to windows to get my WoW fix.

Link to comment
Share on other sites


  • Create New...