Jump to content

USB 2.0 Troubles...

6 posts in this topic

Recommended Posts

For some reason my USB thinks it can take it's dandy time when copying files to my thumb drive. So naturally I opened up the System Profiler and looked at USB. Under my Flash Disk it only reported "Up to 12 MB/sec" for my speed... Here is a screen shot of what is reported for USB.




I have tried the general EHCI USB 2.0 driver. That did not work. After that, I installed the latest IOUSBFamily.kext from the Apple Dev site. Nothing has helped.


The EHCI topic says that 10.4.8 (8.8.1 kernel) is the only version that supports this fix right now... I am using 10.4.9 (8.9.1 kernel).

Does anyone know how to fix my issue?

My specs are in the signature.


Here is another screen shot that might help.



Link to comment
Share on other sites

OK, so I feel like an idiot.


About half way through the school day I realized why USB 2.0 speeds were not functional. I disabled USB 2.0 support in the BIOS when I was initially having trouble getting the IOUSBFamily.kext to load. It ended up that I all I had to do was correct the permissions because the script I made to install kexts didn't work. So I got USB working and I completly forgot to enable USB 2.0 back. Everything is working now that I enabled it.


Will a moderator please close this topic?

Link to comment
Share on other sites

Are you still using 10.4.9 with the 8.9.1 kernel? I was under the assumption that USB 2.0 wouldn't work at all with this setup....


Yes, I am. I recently upgraded to the latest Netkas kernel after I got USB2 working. After the update it was still working. I copied the Halo 3 MP HD Beta Footage (308MB) to my thumb drive in just under 50 seconds (it used to take 7 minutes). I have not heard that that USB2.0 didn't work with my setup. That may be the case, but the only thing that I have changed since I installed (relating to USB) is the actual USB kernel extensions. I downloaded the latest IOUSBFamily.kext from the Apple Dev site, which is V. 270.4.1. That is a higher version than what came with the 10.4.9 update. Hope that helps...


if u disabled the 2.0 usb from bios, it recognize? and speed up? and windows? does it work at 2.0 spped on win?


I disabled USB 2.0 in the BIOS. It still recognized my USB but it was running all of my hubs at 12 MB/s which is USB 1.1 speed. Once I enabled it, it sped back up to 408 MB/s. When USB 2.0 was disabled, it was slow in Windows. When I re-enabled it, Windows recognized it as USB 2.0. If you are not getting USB 2.0 speeds in any OS make sure your device is USB 2.0 compliant. If it is, and you are still not getting 2.0 speeds make sure:


-OSX: You have the latest IOUSBFamily.kext and that you have followed any directions on this forum regarding your MoBo's USB support.

-Windows: You have all of the chipset drivers installed. This can usually be found on the CD that came with your computer or MoBo. It can also be found on the manufacturer's website. This usually helps when I have this issue. I hope it helps you out.



Link to comment
Share on other sites


  • Create New...