Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

How to get SATA 'seen'/working on an Asus P5VD2-MX

5 posts in this topic

Recommended Posts

For those who are using the search facility! The P5VD2-MX's infuriating Sata is now detected if you install Kalyway 10.5.1 - the SATA socket nearest the CPU. iATKOS sees the drive from the DVD's Disk Utility but I didn't install iATKOS so don't know if it boots up. If you are using a Pentium D processor, don't select the Vanilla kernel, it won't work. Also, with this motherboard you need to get a graphics card. I use an old PNY Geforce 7300, don't forget to select during install - '7000'


A fellow P5VD2-MX user came up with a solution for the lack of SATA support for the Asus P5VD2-MX. Beyond encouragement I can take neither credit nor offer support for it. If you have little experience with installing JAS to new hardware or are a newbie, just use a regular PATA IDE drive. At some point perhaps the author will pop up here and take a bow but he says he isn't looking for name recognition. Here is a copy of the email he sent. At the time of writing it he hadn't tried out the DVD but went to bed; I'm not sure how awake he was when he wrote the below, so beware! This morning he emailed me to say it had installed to his SATA drive and about three times faster than to his PATA one. Personally I would wait a few days before trying this; I will report back if all is still well with his setup over the coming week. But for those who can't wait, here goes:-




Instructions on Adding SATA drive Support on Jass 10.4.8 AMD INTELL SSE2 SSE3 DVD.



What Tools I used:


1. UltraISO

2. Mac OS Disk Utility

3. DVD's Disk Utility

4. Toast



Setup of PC ISO (I used UltrISO)


1. Open an UltrISO.

2. Insert Mac Install DVD.

3. Extract and load Boot Image from DVD.

4. Extract PC files from DVD (should only see chain0 files).

5. Save as ISO image.


NOTE: I kept ISO on a FAT32 partition to be safe.





Setup of MAC DMG


1. With Install DVD inserted open Disk Utility.

2. Click New Image icon.

3. Select DVD rom.

4. Select Read/Write from Compression Drop Down.


NOTE: I saved the DMG onto a Mac volume.


5. Click to create image.






Copying the Extensions.mkext file


Since I wasted alot of time and DVD's with regards to permissions

I rebooted into the Jass DVD and used it's TERMINAL to do the following:


1. Create a folder on a MAC partition (example: mkdir /Volumes/<YouDriveLabel>/TempMkext ).


2. Enter the following command : cd /System/Library


3. Enter the following command : cp -Rp Extensions.mkext /Volumes/<YouDriveLabel>/TempMkext






Modification of the Extensions.mkext file


Exit from Install DVD and boot into Mac OS.



1. Mount the DVD DMG file.

2. Delete the Extensions.mkext file located in System/Library/

3. Open Terminal.

4. Navigate to the folder we copied Extensions.mkext.

5. Create a new folder in this directory (Example: tempkext ).

6. Enter the following command:


mkextunpack -a i386 -d tempkext Extensions.mkext


7. Change to the tempkext directory.

8. Enter the VEN/DEV ID to the AppleVIAATA.kext driver.


9. Change the ownership of all the drivers in this directory:


chmod -R root:wheel *


10. cd..

11. Enter the following command:


kextcache -a i386 -m Extensions.mkext tempkext


NOTE: This should give you warning messages for each kext file but say that it has been saved.


12. Enter the following command:


cp -Rp Extensions.mkext <MountedVolume/System/Library


13. Unmount image.









Burning the new image:


1. Open Toast.

2. Select Merge images.

3. Select the PC ISO.

4. Select the DVD DMG

5. Record.



"end quote"

Share this post

Link to post
Share on other sites

In the second mail he sent to me he added the following, and I quote:-


"My workaround was to manually change the ID with MacDrvie booted in Windows. When I installed the OS it took 1/3 of the time then it does installing on my IDE!



If anyone finds themselves unable to mount their SATA after a normal install and manually changing their VEN/DEV ID in the driver, tell them to try plugging the SATA cable into each SATA port on the board. When attempting to see if the board would change IDs upon switching, I found that only SATA Port 1 will actually allow it to mount even though Windows lists the same ID no matter which port I use."


End quote.




Good luck :(

Share this post

Link to post
Share on other sites

Happy Easter everyone! Someone asked a supplemental question. I seem to have become a cut and paste conduit! Here goes.






Following some of the threads that you've contributed to, it seems most people are having just straight difficulties getting their SATA's to mount. Which has put me on a side project to make this easier I should have a working program by end of day that will allow a user to enter the VEN/DEV ID and set it up automatically without going into terminal.


I wish there was an easier way to discover the correct ID automatically to .....working on that to ...hehehe




I'm a bit confused on that last e-mail:


someone asks:-


OK I read the tutorial, but if this was supposed to work shouldn't it work if you just add the ID in the kext file on installed Mac OS and then repair permissions?

Because I have the device ID in Extensions.kext, but there is no SATA.



Now if I understand correctly.....



Question :

Adding ID to the kext file on 'installed' Mac OS and repairing permissions.



Since, and I think 'repairing permissions' refers to 'Repair Disk Permissions' may not correctly repair the

permissisons on the Info.plist file located inside the AppleVIAATA.kext file.



Repair Disk Permissions can only correct file permissions listed by the packages Receipts located in


and since AppleVIAATA.kext is actually a part of the driver AppleVIA.kext, proper repair will be corrected

only on this file.


The one we use has no Receipts package since the AppleVIAATA.kext is pulled from AppleVIA.kext and

saved directly to '/System/Library/Extensions/' so that when the Extensions.mkext is created, it will

hopefully load the AppleVIAATA.kext file.


This is why it is a MUST to change the file to it's proper permissions!


Such As (If you really want to be specific):


1. After changing the ID in the Info.plist of AppleVIAATA.kext/Contents/


chown -R root:wheel Info.plist

chmod -R 644 Info.plist


2. Change back to /System/Library/Extensions/



chown -R root:wheel AppleVIAATA.kext

chmod -R 755 AppleVIAATA.kext


3. Trash Extensions.mkext and Extensions.kextcache (this will be recreated once you boot-up)





Question: Because I have the device ID in Extensions.kext, but there is no SATA.



Answer: The Extensions.kext file produced by an already installed OS is not the same as the Extensions.kext file in

the install DVD (specif the timestamp). It would seem using the newly created (by os) Extensions.mkext

would make the installer (like the OS) try and create a new and up-to-date package, which is not possible to

resave on DVD. This usually results in failed attempts bringing the Installer GUI up.


And yes, I've tried repeatedly to work with the Installed OS mkext file and replace it with the DVD's, and

there's about 5 pages worth of type that I won't bother getting into (more important this to do like get sound

working LOL) that would explain how the OS and the DVD kernels differ when it comes to using it.





The tutorial assumes that you have successfully installed MacOS and have changed the AppleVIATA.kext so

that the SATA drive will mount.


If this happens, follow the tutorial to create a new DVD Install disk that will mount the drive automatcially so

that you can install the OS directly to SATA drive.


*If you are unable to mount the drive after you've installed the OS (DVD with no SATA support), do not

follow this tutorial.

Share this post

Link to post
Share on other sites

I finally manage to boot from sata drive. i added two of this ID in appleviaata.kext , 0x53371106 0x2363197B


i manage to make a bootable dvd that sees sata, but when it installed, it didn't copy the the kext that i edit from kext cache and extentions folder. so i have to add this manually after it installed in the sata drive, using my old installation of leo in the IDE drive. after that it work flawlessly.


I looked through this forum, there was from Ramjet, that describe how to add or edit installation dvd. I think one of the step didn't work because it's not for leo. just wish that it work out of the box.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.