Jump to content

Will boot in safe-mode, but won't boot normaly (on Intel motherboard)


2 posts in this topic

Recommended Posts

Soo, I've managed to get one DVD with OSX 10.4.6 (Darwin 8.4.1) x86 instalation, right?


As I have "fully qualified" HW setup (regarding to other peoples expirience) I decided to give it a try. I managed to install it without any (in words: ANY) problems what so ever, but as soon as it came to booting off the hard drive - some problems.


Now, I asure you, I've spend two full days in searching for solution, but didn't find anyone with the same problem - thet's the reason why I'm screaming for help right now.


So, I power it on, it starts booting... and the first moment it brings up the graphical interface (only background picture - without anything else, not even a mouse cursor) it just kinda, hangs/freezes.


BUT - oddly enough, if I boot it in a safe-mode with a "-x" switch, it boots completly normaly (despite the fact that I can't use audio/network because the drivers aren't loaded)!?


That wouldn't even be so strange if there weren't a fact that the hardware is known as "compatibile" with x86 OSX.


It's the Intel platrofm with Intel D915GAG* motherboard that has integrated Intel GMA 900 video controller, Intel HDA audio (Realtek ALC860), and a Intel Celeron D processor (SSE3). There's not a single addon PCI/PCIE card fitted in any slot on the motherboard, there's one 40GB WDC PATA (NOT S-ATA!) disk connected to motherboard, along with a DVD drive, USB mouse, and... well, that's about it.


I've tried really everything I could find about some similar problems, I've tried booting with "-s" "-F" "-v" (this one is by default defined in com.apple.Boot.plist) switches, I tried disabling all features (audio, USB, even serial ports) in BIOS... tried platform=ACPI|X86PC switches... nothing worked... except "-x" of course.


If that were Windows problem, I would assume that some of the loading drivers results in system hangup - how can I find out if it's the same thing with OSX and which one? I've read somewhere that if I start system in verbose mode I can find crash log in <username>/Library/Logs/CrashReporter, but there's no such a thing when I boot in safe-mode.


The DVD image itself is with patched kernel, and when I Customize installation I can select 10.4.5 and 10.4.6 patches along with SSE3 patch. (also, some guy maxxuss is mentioned along with some txt files on the DVD... if that means something to you)


I personaly doubt that's something wrong with distribution and/or hardware because, I repeat, in safe-mode (probably without some drivers loaded at startup) I can work just fine with OSX - I can open every single application installed, I can setup preferences, modify screen resolutions, no hangups, no crashes, nothing.


So, have this happen to anyone?



* http://www.intel.com/products/motherboard/D915GAG/index.htm




I'm from Croatia... land of healty cows and crazy people... so feel free to be annoyed by my not-so-perfect english. :)

Edited by evilife
Link to comment
Share on other sites

  • 4 weeks later...



Hopefully I can help fix this.


Your hardware may be compatible, but you need to do a custom install (I used JaS 10.4.6 DVD) which has a GMA900 patch, in the original OSX installer!!!


If you find this patch separately, you may be OK, if you have the JaS 10.4.6 DVD, you will DEFINITELY BE OK!!


If you cannot find the patch anywhere, and you should by Google for GMA900 OSX86 PATCH, I can email you the package (or someone else can) if you get desparate.




themacmeister :star_smile:

Link to comment
Share on other sites


  • Create New...