Jump to content
InsanelyMac Forum
Sign in to follow this  
cuastermos

Please help with GeForce4 ti 4200

Recommended Posts

Hello, and thanks for to read this post, I'm tired of try a lot of methods that I've been reading and methods of my hand, but no success...

 

I've a working installation of 10.4.8 with semthex kernel for SSE2 experimental 9, and always that boot my computer I get a black screen before to enter GUI. If I enter in verbose mode, the last lines are of the login window. I've try with NVDANV20Hal.kext (i think that it's the mine for GeForce4 ti 4200) modifing the DEV ID in this file, in Geforce.kext and in NVDAResman.kext. I've tried my old login windows (that worked for me), and the original login windows of 10.4.8 combo update.

 

Any help? Thanks a lot.

Share this post


Link to post
Share on other sites
Advertisement

I've seen one person reporting that he had a 4xxx series card working fully.

 

However, member "np_", who is an expert in these matters - he created Macvidia - says that the NVDANV10Hal.kext and NVDANV20Hal.kext only support video cards on a PPC (PowerPC) system, not an Intel system. Since NVDANV20Hal.kext is used for 4xxx series cards, I'm not sure that the 4xxx series can ever work fully using the installed drivers being initialized by Natit or Titan.

 

Whatever you achieve with Titan or Natit might be the best you can achieve without a new driver being written for your card. Macvidia, in its current version, will not give you QE/CI.

Share this post


Link to post
Share on other sites

A lot of thanks for you help. It's possible that NVDANV10 and 20 work's only in ppc, because don't have much sense that apple recompile this kexts in order to use in intel macs that don't have this old nvidia cards. But I think that could be possible... I don't know like...

 

I've too a ATI Radeon 9550, any knows if it's possible get work, with Titan/Natit..?

Share this post


Link to post
Share on other sites

Hello,

 

I have also an Geforce4 ti 4200.I have try with NVDANV20Hal.kext,Geforce.kext and NVDAResman.kext with the DEV ID 0x025310de and it is not working.If I desactivate NVDAResman.kext I have the GUI but no CI & QE

 

So np_ & Co if you have some idee dont hesitate.

 

Thanks in advance

 

Debian

Share this post


Link to post
Share on other sites

Then isn't problem of NVDANV20Hal.kext, is of NVDAResman.kext. If it loads is because isn't PowerPC (I think). Now we must searching...

Please If somebody haves any idea, welcome is.

 

Thanks.

Share this post


Link to post
Share on other sites

I was read this post, but we need know how to. I'm searching for a solution. If I find anything I'll post here, please if you find anything post here too.

Have you tried at the same time AGPGart?

What are your graphics scores in xbench?

Edited by cuastermos

Share this post


Link to post
Share on other sites

I have a simular Geforce 3 Ti 200 (NV20-based, 0x020110de). I haven't got my card working yet. B)

 

Natit.kext, NVDANV20Hal.kext, GeForce.kext, NVDAResman.kext all load at boot-up, but the display doesn't start.

Share this post


Link to post
Share on other sites

Also have a gf4 ti4200. Natit seems to recognize my card and loads up fine, but then i get this:

 

NVDA: start display

NVDA: start display failed

 

Have no idea how to fix this.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Cool! Do you have a link? Googled and didn't see anything yet.   Never mind... you're quick! I just noticed you updated it on the 1st page THANKS!!!!!!
    • I resolved the problem. Just set this coding in your config.plist:   "
      <key>KextsToPatch</key>
              <array>
                  <dict>
                      <key>Comment</key>
                      <string>USB 10.13.4+ by PMHeart</string>
                      <key>Disabled</key>
                      <false/>
                      <key>Find</key>
                      <data>
                      g32UDw+DlwQAAA==
                      </data>
                      <key>InfoPlistPatch</key>
                      <false/>
                      <key>MatchOS</key>
                      <string>10.13.x</string>
                      <key>Name</key>
                      <string>com.apple.driver.usb.AppleUSBXHCI</string>
                      <key>Replace</key>
                      <data>
                      g32UD5CQkJCQkA==
                      </data>
                  </dict>
              </array>     "
    • New Web Driver - 387.10.10.10.30.107 for 10.13.4 build 17E202
    • I guess having pre{max-height: 500px;overflow: auto;} in CSS was too much for IPS Devs' tast.  Until an admin has hands on this, you still can use stylish plugin to accomplish it.     In fact, it is pretty easy than it appears - Just apply a simple click on the codebox (it will highlight it), then 'delete' key.
    • all the possible frequencyes i have added seems to work fine at the moment, i have added a lot of different frequencyes to support better all kinds of professional applications, inclunding strange sampling rates and goes from 8khz up to 176.4 khz, unfortunately 192 khz does not seems to work even on cards which should support it like the audigy rx, but other frequencyes just works fine and at the moment i have tested only the sound blaster audigy rx and the audigy sb0090 (1st gen audigy) and i can confirm that all the frequencyes from 8khz up to 176.4 khz does work on that card, so i think that such frequencyes should work on all the audigy 2, 2sz, 4 cards as well, tomorrow i will test with my sound blaster live! cards and i will let you know, but here are also some photos (pro tip: use cmd + alt/opton + 4 and then press space to make a screenshot of a single window):


×