Jump to content

Processor show as Unknown


8 posts in this topic

Recommended Posts

my spec:

  1. i9-14900K Raptor Lake
  2. AMD Radeon RX 580 (Polaris 20)
  3. G.Skill Trident 32GB DDR5-6000
  4. Crucial MX500 500GB SATA
  5. Asus TUF Gaming Z790-Pro WiFi
  6. Intel Raptor Point-S PCH - CNVi: WiFi Controller
  7. Realtek ALC1220P / ALC S1220A
  8. Realtek RTL8125B

 

I got almost everything to work except 2 issues.

1.  Processor name shows as Unknown.

2. Every time when I reboot or shut off and when I power back up, a pop up show "you shut your computer because a problem."

 

As for #1, I tried boot-args --> keepsyms=1 debug=0x100 npci=0x2000 alcid=1 revpatch=sbvmm,cpuname=intel revcpuname=i9 revcpu=1 and not work

attach is my config.plist.  I remove serial

 

Thank you!

 

kexts.png

Screenshot 2024-04-20 at 1.43.30 PM.png

config.plist

Link to comment
Share on other sites

The processor is really unknown for Apple. You can make it shown as some i5.

Second problem can be resolved by replacing VirtualSMC to FakeSMC.

Link to comment
Share on other sites

@loganMac,

Fix First problem: Set processorType = 4097 in your SMBIOS.
Fix second problem: go to /Library/Logs/DiagnosticReports delete all files, or delete those files that are related to the warning.
 

  • Like 2
Link to comment
Share on other sites

Thank you both.  Issue #2 not working using FakeSMC nor delete logs file from /Library/Logs/DiagnosticReports

 

To fix #1, Download CPU-Name from https://github.com/corpnewt/CPU-Name. This fix Unknown processor

 

Basically, download the file

1. On Mac, double click CPU-Name.command

2. Select #3 to Clear Name etc

3. Select #4 --> browser to your config.plist

4. Select #2 and select L

5. Select #1 and select L (Use Local Machine's Value)

6. Confirm your the result

7. Quit

8. Restart computer

9. Do ResetNvramEntry

All Done

 

Screenshot.png

Link to comment
Share on other sites

@loganMac - It really was unnecessary to clean install to get rid of the two problems you listed.

As @Mirone advised clearing out the files from /Library/Logs/DiagnosticReports Folder would have solved the 'Shut Down Popup' problem.

The Processor problem is related to wrong or incorrect data in the config.plist.

 

Happy you got sorted with a clean install but going forward, hopefully you won't have to solve every problem that way.

Edited by eSaF
  • Like 2
Link to comment
Share on other sites

Thank you for the help.  The reason I did clean installation because maybe I did something wrong causing a bug on my side.  For me, I don't mine starting fresh because I don't have any app installed on my computer plus I can better track where my mistake started. 

  • Like 1
Link to comment
Share on other sites

 Share

×
×
  • Create New...