Jump to content

Lenovo X1 Tablet Gen 3 Kaby Lake i7-8650u


10 posts in this topic

Recommended Posts

I got this Lenovo X1 Tablet Gen 3, i7-8650u, 16GB, Intel WIFI/BLUETOOTH Combo AC8265, Realtek ALC295 sound card and tried to make it into a MacBook Pro 15,2 but I can't get it to sleep. The sound card mic doesn't work although the sound works fine. It's so much different from any laptop I've hacked before. Anyhow, it's not a bad unit for running Monterey 12.6.3. To install macOS to NVME, the Samsung must be replaced. I used 1TB WD Blue for $55. Dual boot Windows 10 pro and macOS Monterey.


1. The screen works and HDMI works, the device properties has to be in the exact way for the screen to display correctly. It will work with either C087 or 1E59 platform ID.

2. The keyboard trackpad doesn't work, I use the touchscreen and it works fine. Bluetooth mouse is perfect too. If you use the touchscreen drivers then the red pin mouse doesn't work.

3. Bluetooth works perfectly with Intel Driver although NO airdrop.

4. WIFI works perfectly with Intel Driver also.

5. Ethernet USB-C from Lenovo will connect 1GB. Cheaper one would connect at 100MBS.

6. The screen is extremely bright and crisp, leave it at 1/2 I can surf the internet and other stuff for 2Hrs.

7. All the USB ports work, I can connect 8 devices.

8. The Micro USB card reader actually works.

9. The Windows key is ALT instead of ALT.


Set NVRAM on Clover boot loader V5151. This X1 doesn't have native NVRAM, I'm using Clover instead of OC. I can't seem to get NVRAM to work therefore it's so inconvenient to install macOS, it doesn't remember the lastbootvolume default to install boot volume. I found a way to make the NVRAM exist by using SSDTTime to generate SSDT-PMC.aml and the LogoutHook of OC and it worked although it's not native. 



I read all about the similar X1 C6 model but can't still get the sleep to work. The boot time isn't bad, so I can shut it down when not using it and boot it back up. If someone knows how to get this one to sleep, please let me know. Thanks.




MacBook Pro152.zip


Edited by ltooz_audis
add more information
  • Like 3
Link to comment
Share on other sites


It's like this for me too, but I was focused on the graphics and I didn't do any other work until you gave me the solution to the problem. I was ready to have the Bios unlocked by industry experts, then this Topic appeared

Link to comment
Share on other sites

  • 5 months later...
  • 2 weeks later...


New developments: I2C version 2.8 release MOD Trackpad OK, Touchscreen OK, Pen screen OK, Disconnecting the screen and activating Yoga Mode.

Now working on activating Trackpoint and right and left trackpad keys

Edited by Baio77
  • Like 1
  • Haha 1
Link to comment
Share on other sites

  • 3 months later...

  • Create New...