Jump to content

Ventura won't let me install any previous OS

4 posts in this topic

Recommended Posts

I have Ventura installed and running for months on this Z490 Gigabyte Aorus Elite, using iMac 20,1.


I'm trying to install, previous macOS to their own partition on a SATA SSD, one partition for each, Catalina, BigSur, Monterey (I need to check some SCSI specific stuff recently changed-LSILogic Ultra320 SCSI HBA is identified but device attached to it is not recognised in Ventura-it was working in Mojave on my old Z87 board, but I jumped to Monterey on the Z490 board and now on Ventura-wanna see where it last worked).


So, I downloaded each of the mentioned OS's via terminal

softwareupdate --list-full-installers  

I use either terminal 


for USB bootable, for each macOS and double Clicked the Install macOS Catalina.app - Install Install macOS - Big Sur.app macOS Monterey.app 

After minutes of seemingly no activity a dialogue pops up saying


This copy of the macOS Catalina installer application is too old to be opened on this version of macOS.I

“Install macOS Big Sur“ cannot be opened from a newer version of macOS. For more information, visit https://support.apple.com/HT201372 (same for Monterey)


None of the OS's on the USB bootable show up in StartUp Disk, and none of the OS's beside my Ventura show up in OpenCore and I cannot boot from the USB with any OS even after disconnecting my working Ventura SATA SSD.


Is there something in my OpenCore config.plist preventing this machine installing older OS?

I thought when tried BigSur that since ID'ing as iMac 20,1 that may be it, cos it came with Monterey, so I downloaded Monterey 12.6.3    21G419    17.6.31 but it still tells me I can't install older version.


I don't know why nowdays user has to double click the installer.app on the USB stick in order to start the install, years ago, created installer to USB then just reboot, hold Option and select the USB stick, not start installer before.


Screenshot 2023-03-11 at 15.27.29.png

Screenshot 2023-03-11 at 15.27.21.png

Screenshot 2023-03-11 at 15.27.14.png

Link to comment
Share on other sites

wow, I created only 1, edited it , gave me errors uploading the images, hung, complained and then created another topic, lol, two for the price of one, essentially the same content I modified with some corrections.

Link to comment
Share on other sites

  • 3 months later...


I came across your post this morning and thought to drop you some tips.


Firstly, it shown be known that throughout its history (afaik), Apple has never let the user install an older version of OSX while they are still running a newer version, period.

The only way you can do so (on a hackintosh at least) is to create a USB installer stick, and then boot from that.

With regards to your question about your system not being able to boot Catalina, that has nothing to do with Opencore itself, but rather the EFI and SMBIOS you are using.

You have to understand something about Apple OS releases. The Comet Lake platform first appeared around August 2019 - and Catalina in October 2019. But the iMac20,1 (Apple's first Comet Lake system) didn't really arrive until August 2020. Then Big Sur launched in November of that year (2020). This meant that Big Sur was the only OS that (largely) supports Comet Lake (barring the latest Catalina update 10.15.7). So Catalina or High Sierra cannot identify iMac20,1 or iMac20,2. So you must use an older SMBIOS build like iMac 19,1 or even iMac18,3. However it must also be accompanied by CPU spoofing through the use of the Kernel > Emulate function as well as using Coffee Lake IGPU device and AAPL,ig-platform ids (this is true for High Sierra). This is what I use on my Z490 Aorus Xtreme w/ 10900K to boot Catalina:




Link to comment
Share on other sites


  • Create New...