Jump to content

[SOLVED] AppleALC not recognizing AD2000B, OpenCore, Asus P5Q-E, Big Sur

Wannabe Hacker

5 posts in this topic

Recommended Posts

Requesting assistance in getting AppleALC to work on a legacy hack. My system is the following:


MB:  Asus P5Q-E

Audio Chipset: ADI AD2000B

CPU: Q9650


I am running Big Sur 11.6 using OpenCore 0.7.0.  I followed the Dortania guide on audio troubleshooting with the following results:


I confirmed proper loading of Lilu, AppleHDA and AppleALC:




gfxutil produces the following output:




This is my config.plist DeviceProperties setting:






This is what IOReg looks like. Note, despite setting layout-id as 5 it still reads 7:





Hackintool Screenshot:






According to to the AppleALC Supported Codecs page AD2000B is supported with layouts 5 and 7.  I have tried both with no success.  I have also tried using alcid boot arguments with the same values.


Happy to submit any additional info you need. Any assistance would be most appreciated. I know this is an old legacy system but I have derived a great deal of enjoyment keeping this ancient hack alive. 



edit: I have since updated OC to 0.7.8, Lilu to 1.6.0 and AppleALC to 1.6.9 I figured out how to generate the Lilu and AppleALC debug log.  I am attaching the debug log file. 



Edited yesterday at 02:37 PM by MacGeoDoc 


Edited by MacGeoDoc
Debug log uploaded
Link to comment
Share on other sites

30 minutes ago, MaLd0n said:


I had done what you suggested already but not since updating OC, Lilu and AppleALC.  Based on your suggestion, I went back and did it again and this time alcid=7 WORKS!.  

Not sure why it didn't work before but it does now and I guess that's all that really matters.  Thanks again!



Link to comment
Share on other sites


  • Create New...