Jump to content

Need help disabling kext in Big Sur with Opencore


7 posts in this topic

Recommended Posts

Hi all!


To cut the story and go straight to the point... I've done a fresh install of 11.2.8 with open core 0.7.4


Everything works BUT I need to disable AppleGFXHDA.kext so my RX Vega 64 does not freeze intermittently...


I used to have the issue in Majove... which was easily fixed by moving the kext somewhere else... But that's impossible to do in Big Sur it seems..


What is the best way of doing this?


What I've tried so far:


Blocking the kext in the config.plist


Method: https://www.reddit.com/r/hackintosh/comments/dmn84u/rx_vega_64_freezes_system_during_hw_accel_encode/

Outcome:Did not work... all my screen are still coming up as audio devices in the system profile


This is what I added under Kernel / Block in my config.plist















Renaming the AppleGFXHDA.kext to something else




Outcome:Recked my install twice... where I would start booting to recovery mode without being able to actually boot into anything else


Here is what I did in order to remove /S/L/E/AppleGFXHDA.kext  FYI my hard drive name is BigSur


1. Boot Big Sur USB installer

2. Run Terminal app

3. csrutil disable

4. csrutil authenticated-root disable

5. Reboot then back into terminal

5. mount -uw /Volumes/BigSur

6. cd /Volumes/BigSur/System/Library/Extensions

7. mv AppleGFXHDA.kext AppleGFXHDA

7. Rebuild the extensions cache using: kmutil install -u --force --volume-root /Volumes/BigSur

When doing this step I get this warning though: "Warning: com.apple.driver.KextExcludeList was not found!"

8. Create a system snapshot to take these modifications under account at next reboot:

bless --folder /Volumes/BigSur/System/Library/CoreServices --bootefi --create-snapshot

9. csrutil enable

9. Reboot

Link to comment
Share on other sites

2 hours ago, ozamal said:





If you want to BLOCK the kext, this has to be



Link to comment
Share on other sites

  • 11 months later...

HI Kext loading 's operating in root authenticated space. Since Big Sur and APFS it's root S/L/E s write-protected by CSR

Related to 


As of now I think you can try to disable SIP authenticated-root to block or force a Kext

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...