Jump to content

(SOLVED!) No Sound Asus B560M Plus Gaming + i7 11700K'F' + RX550


monostroy
 Share

13 posts in this topic

Recommended Posts

 

Audio issue has been SOLVED!

Please read the explanation from this Thread below.

Btw, you're great MaLd0n, And Allan too! 👍

 

 

Hi All.. I think I've made mistake with my choosing hardware.

I've already installed Catalina 10.5.7 (19H1323) on this PC (Asus B560M Plus Gaming + i7 11700K'F' + RX550)
And now, I'm facing a problem with the Audio (ALC897). Although HDMI Audio through RX550 is working fine.
I have use Layout id : 66 and 69, the volume icon seem fine.. But still no sound.


And another problem about the VDA Decoder, since the processor that I use is Gen.11 with 'F' series, will this problem be solved? 

 

Anyone can help me?

 


Here my screenshot and resource files :

 

702803804_ScreenShot2021-09-09at22_32_25.thumb.png.ee8378dc5bc4c49a9ffecb391d07c770.png

 

1160831495_ScreenShot2021-09-10at01_14_26.png.1367130ede48e8bc9710db4a71a3d634.png

 

342136638_ScreenShot2021-09-09at23_48_47.thumb.png.57e82d6d9e1bf0f01a679adfca5d8a94.png

 

 

 

Resources Files :

 

From 'RunMe' app.zip

 

ACPI origin.zip

 

Edited by monostroy
Solved

15 hours ago, MaLd0n said:

extract one sendme with this efi folder

https://tinyurl.com/2ur3vc56

reset nvram first time

Hi MaLd0n, thanks for your reply..

 

I have replaced the EFI folder, but it still no luck..

No output audio device.

And my RX550 gpu become 7mb

 

931959814_ScreenShot2021-09-10at20_16_28.png.6a811c438070d4d68f1c124f41204655.png

 

 

And i believe this audio issue, has an impact when I play YouTube, and other offline video files.

They don't play..

 

922369496_ScreenShot2021-09-10at20_36_21.png.832a3b80f1064946d77f59dd407587aa.png

 

But when I change output audio to the HDMI Output, YouTube and offline video will play smoothly..

These problem, so far I know it has correlation with the processor.

 

But will it affect to the audio too?

 

 

 

 

16 hours ago, Allan said:

Try this: config.plist.zip

EDIT: And according to your IOReg output, you don't have the proper power management. 😬

 

Screen Shot 2021-09-09 at 19.14.33.png

Hi Allan.. I have no idea with that. 😬

Is there something wrong with the configuration? or because this machine is relatively too early?

 

 

 

Edited by monostroy

Now that you're using the EFI folder that @MaLd0n sent you, keep with it, the next steps is the fine tune.

 

You can send the IOReg output to see the details.

  • Like 2

2 hours ago, MaLd0n said:

 

Wow.. Thank you MaLd0n,  all USB port and the audio working good.

 

But I have a new problem now, browser (Safari or Chrome) look glitchy and laggy, and I lost Metal on my GPU.

And sometimes safari reloaded it self.. 😬

 

Spoiler

201244772_ScreenShot2021-09-11at04_00_38.png.2038d6344b695e2716e349bdcdd74dcd.png

 

 

And sadly, I hear FCPX not support for my (F) series processor? Is that right? 😢

 

Spoiler

1028514644_ScreenShot2021-09-11at04_09_49.png.f7eec09f0cbc9c4b09e7ede7c7d2e4c4.png

 

 

Edited by monostroy

But, when I turn back to Clover.. My Metal my GPU status is Supported. And I think QE/CI work well.

No glitch or laggy on the browser..

 

Here's the screenshot :

Spoiler

1810453012_ScreenShot2021-09-11at04_51_48.thumb.png.1f9fb7195884781b0f4fa7f6625220bb.png

 

 

Here's my Device/Properties in clover : Wait, I'll add it, and I hope it will work in OC..

 

Spoiler

789502769_ScreenShot2021-09-11at04_53_32.png.8c7194b6e546e60a00b5039a01eec8c5.png

 

 


replace dsdt DSDT.aml.zip

add ur old video patch

Quote

 <key>PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)</key>
                <dict>
                    <key>device-id</key>
                    <data>/2c=</data>
                    <key>vendor-id</key>
                    <data>AhA=</data>
                </dict>

 

  • Like 2

1 hour ago, MaLd0n said:

replace dsdt DSDT.aml.zip

add ur old video patch

 

 

OMG.. UNBELIEVABLE!!

I think all the hardware already works now! OMG.. you're great MaLd0N! 🤗

And thanks to Allan too.. 👍

 

Btw, I'm not yet add your last DSDT.aml, I've just edited last video patch in OpenCore Configurator.

And check all devices. 

 

And what makes me more happier is about FCPX

After, I almost desperate when I heard this F series processor had issue in FCPX..

But, now I think, maybe I just opened the wrong version of FCPX. 😆

 

FCPX 10.4.8

Spoiler

130605429_ScreenShot2021-09-11at06_28_30.thumb.png.9ee045fd4aec78af0358b017ed674d4f.png

 

 

After it, I will add your DSDT file.. I'll report it later.

 

-----

 

EDIT :

I have added your latest DSDT file. It Working Good👍

- I just tried the front audio port, Front Audio : Working Good. But Front Mic/headset not working. Then I change Alcid:69 to 66, Front Mic Worked👍

 

I think all the big problem was SOLVED!

 

The only issue is on the boot glitch, but I think it's just a cosmetic, not a big deal.

 

Boot Glitch around 1-2sec :

Spoiler

IMG_2800.PNG.1e5ceb3c53e075ecd55c2694338f39a8.PNG

 

 

 

Edited by monostroy
  • Like 1

2 hours ago, monostroy said:

The only issue is on the boot glitch, but I think it's just a cosmetic, not a big deal.

Yes, its just cosmetic. Maybe in the future we have a patch to fix it. 😉


  • monostroy changed the title to (SOLVED!) No Sound Asus B560M Plus Gaming + i7 11700K'F' + RX550
 Share

×
×
  • Create New...