Jump to content

Sleep stopped working [OC 0.7.2, BS 11.5.2, 10850k]


stooovie
 Share

7 posts in this topic

Recommended Posts

For some reason, since a few days ago, my desktop system no longer enters sleep. Big Sur 11.5.2 on OC 0.7.2 (and 0.7.3), i9 10850k on Asus Prime Z490-P, RX 580 8GB.

I mean the manual Apple menu->Sleep command. I don't want auto-sleep on idle.

Sleep worked fine for over a year, including Wake on LAN. Absolutely zero issues until like two days ago.

I'm not aware of anything that could break it. No changes in BIOS, no MacOS update, no OC/kexts update (I have updated the kexts to the latest ones since I started having the issue, but it doesn't work even with older OC+Kexts backup), no new devices plugged in. 

Info

Windows running on a separate nvme sleeps fine. No issue there. 

USB is properly mapped.

NVRam has been reset, no dice.

Wake by PCI and RTC in BIOS are disabled.

Tried different user account, nope.

I have done all the sleep troubleshooting steps from the Dortania guide.

I have done "pmset -a restoredefaults", nothing.

Enable PowerNap and Wake for network access are unchecked, Use Bluetooth devices to wake up is unchecked.

Pmset -g returns this:

standby 1
Sleep On Power Button 1
womp 0
hibernatefile /var/vm/sleepimage
proximitywake 1
powernap 0
networkoversleep 0
disksleep 0
standbydelayhigh 86400
sleep 0 (sleep prevented by runningboardd, runningboardd, mds_stores, sharingd)
hibernatemode 3
ttyskeepawake 1
displaysleep 10
highstandbythreshold 50
standbydelaylow 86400

Hibernatemode=0 makes no difference either.

Here's EFI: https://drive.google.com/file/d/1pEndCOEI93SfM7ybP_YlRoyL0H2hWnmN/view?usp=sharing

Any other tips? Thanks!

 

EDIT: somehow running Onyx with all Maintenance options enabled fixed the issue. I don't really know what it was but the system sleeps correctly now, always.

Edited by stooovie
Link to comment
Share on other sites

2 hours ago, stooovie said:

sleep 0 (sleep prevented by runningboardd, runningboardd, mds_stores, sharingd)

This is the clue right here, Open System Preferences/Sharing and see what is preventing Sleep, try deselecting the items one by one and test Sleep, this step usually finds the culprit that is preventing Sleep. Good luck.

  • Like 1
Link to comment
Share on other sites

Try these commands in Terminal and see if it helps:

sudo pmset hibernatemode 0
sudo rm /var/vm/sleepimage
sudo touch /var/vm/sleepimage
sudo chflags uchg /var/vm/sleepimage

Basically, it changes Hibernation mode, removes the current sleep image, creates a write protected 0 byte sleepimage.

Edited by 5T33Z0
  • Like 2
Link to comment
Share on other sites

44 minutes ago, stooovie said:

Hi, somehow running Onyx with all Maintenance options enabled fixed the issue. I don't really know what it was but the system sleeps correctly now, always.

WARNING:
There is a specific version of OnyX for each major version of the operating system.
Use the correct version, and don't try to use a version intended for an earlier operating system.

 

OnyX for macOS Monterey 12 will be available about 15 days after the official release of macOS Monterey.

 

Just thought this warning is worth mentioning.

Link to comment
Share on other sites

4 hours ago, stooovie said:

For some reason, since a few days ago, my desktop system no longer enters sleep. Big Sur 11.5.2 on OC 0.7.2 (and 0.7.3), i9 10850k on Asus Prime Z490-P, RX 580 8GB.

Test 1

Use this ACPI folder, copy rename GPRW to XPRW in config and adjust the order of the kext .Archivio.zip

 

Test 2

To your efi add these filesSSDT-USBW + Kext.zip

Edited by Baio77
Link to comment
Share on other sites

 Share

×
×
  • Create New...