Jump to content

[How To] Solutions for 10.4.8 and 8.8.1 Kernel


15 posts in this topic

Recommended Posts

10.4.8 Installation and Kernels


This is a compilation of many different solutions available for installing 10.4.8 and the new kernel. It is not exhaustive. If you don't find what you want, search for it.


Please do not post questions in this thread looking for a solution that is not listed. Use other threads for that.


Please do post other good known similar solutions in this thread. I will try to incorporate any posted solutions into the list. Otherwise, users can read the thread for any other solutions.



Methods for installing 10.4.8 for the 8.8.1 kernel

- Find the "Final" release on Demon:
JaS.10.4.8.AMD.Int el.SSE2.SSE3
There is a follow-on PPF1 patch by JaS also on Demon:
JaS.10.4.8.AMD.Int el.SSe2.SSe3.v1p ppf
. As an alternative, member
Mac OS X 10.4.8 JaS PPF 1 Integrated
on Demon. This incorporates the PPF1 patch into JaS' 10.4.8 for you.


Because of a defect in the Disk Utility on the iso, member
has published a PPF2 patch for the iso. You must first apply the PPF1 patch before applying the PPF2 patch found
. Use PPF-O-Matic to apply the patches to the iso file. Keep a copy of the original iso before applying the patches.


There is an older "beta" iso:
MAC OS X 10.4.8 Intel Only Jas re-seed (
Intel SSE3
Only - NO AMD)
- find it on Demon. The kernel on this iso is not compatible with VMWare.

TubGirl ISO
- Find this "Final" release on thePirate:
OSX 1048
. For
SSE2 and SSE3

To install the iso to a computer with AMD64+nForce 4, use
VMWare method.

Aberracus method
- For Mifki or DaemonES kernels for SSE3. Read


eGWan's patcher
- For Mifki or Semthex kernels for Intel SSE3. Start with a working older installation. Apply Apple 10.4.8 update. Use the all-purpose patcher found


macnub method
- For Mifki kernel on Dell Inspiron 6400/E1505. Read


Pastebin method
- Read


Paulicat method
- Read


mcfresh method for
SSE2 on Intel
(and maybe AMD)
- SSE2 is still currently experimental, use with caution. Read


SaberSHO method for
- SSE2 is still currently experimental, use with caution. Read


-TiLT- method for
- SSE2 is still currently experimental, use with caution. Read


wmarsh method for Intel
- Use the TubGirl AMD DVD to install to Intel (yes) using VMWare and this


Obtaining the 8.8.1 kernel

- created a kernel (Intel & AMD SSE3 only) based on Mifki's work. Ask him to give you a link. It "works with amd patched 10.4.8 binaries. can use hpet, if present."


- his final kernel (Intel SSE3 only) is on the JaS 10.4.8 install DVD.


- you can obtain his latest kernel (Intel & AMD SSE3 only) several ways:
- visit
(irc.macspeak.net) channel:
and ask for it.


hippiex Live Update
- go


Prasys Live Update
- go


Older versions
- older versions of the kernel can be found on the 10.4.8 install DVD's.


How to Install the 8.8.1 kernel

10.4.8 Install DVD's
- Drag the kernel out of the root directory of the DVD or use
to extract/install the kernel from the packages in directory: /System/Installation/Packages


Manual method
- Download a kernel archive and unzip/unrar the archive.

- Place the mach_kernel file on your Desktop

- Open Terminal (in Utilities folder) and type:
sudo cp /mach_kernel /mach_kernel.back
(type your password)
sudo cp -f ~/Desktop/mach_kernel /
sudo chown root:wheel /mach_kernel*
sudo chmod 644 /mach_kernel*

- Then reboot.
Installer method

hippiex Live Update
- only updates using latest available Semthex kernel. Download it


Prasys Live Update
- only updates using latest available Semthex kernel. Download it


Booting the 8.8.1 kernel

If you have difficulty booting after installing, try pressing F8 at boot and typing:
-v -f

If you still have difficulty booting, use the old kernel by pressing F8 at boot and typing:


Time is Wrong or Audio Stutters

If after upgrading to 10.4.8, your clock isn't keeping time and your audio and video stutters, the early 8.8.1 kernels need to have FSB set at boot. The best way to solve this is to update to the latest kernel. See above for methods. Otherwise, you need to set the FSB frequency. It is set to 200 by default.


At boot, type: fsb=xxx (where xxx is a number like 133, 166 or 200)
fsb is a frequency

fsb (freq) = fsb (speed) / 4

Find your fsb (speed) in your BIOS or:

(OSX) System Profiler -> Hardware -> Bus Speed (fsb speed)

(OSX) Terminal type: sysctl hw.busfrequency -> (fsb speed) -> divide by 4,000,000 -> fsb (freq)

(Win) PC Wizard -> Mainboard -> Chipset -> fsb (speed) and fsb (freq) are both avail

Remember to divide the speed by 4. If your FSB (speed) is 667, then your FSB (freq) = 166 because 667/4 = 166


At boot, type fsb=166 (use your value) or put the fsb in your boot.plist under Kernel Flags:

<key>Kernel Flags</key>

</string> (use your value)

Helpers for the 8.8.1 kernel

x1650 AGP Video Card
- Use this


About This Mac Crash Fix
- Paulicat created


AMD iTunes Preference Fix
- Xtraa created


- if you are having trouble with the new kernel and need to send your particular system data to Semthex or someone else for analysis, then use
script from Prasys to package the data.


Hiding Files like mach_kernel
- Read


Intel GMA900
- Read
and find packages on Demon.


Minipatcher v2
- For AMD DVD only, fixes Asian input problem, login window crash and other app crashes. Read


Realtek 8139
- For 8.8.1 kernel (10.4.8) only - Read
by orByte.


Samba/Minipatcher combo
- For AMD only, contains the minipatcher V2 and the {censored}-X Samba/AFS network patcher. Read
from my1stmacisaHACK.


Security Update patcher
- For AMD only, fixes problems after updating with Security Update 2006-007. Read


System Profiler Fix
- Improve your System Profiler function under 10.4.8 and the new kernel using Colonels package


OSX 10.4.8 Jmicron JMB IDE patch
- Member thedguy created a PPF patch to the JaS 10.4.8 Intel SSE3 Only Reseed DVD to allow it to boot on JMicron IDE drives. Find it on the Demon and read about it


pion package
- Intended for a Gigabyte Ds3/4, it contains: Audio fix, JMicron SATA/IDE fix, Yukon 8053 fix, 10.4.8 USB driver, System Profiler fix and PS/2 fix. Get it


- Read
. Versions for 8.4.1 kernel and 8.8.1 kernel by orByte.

Link to comment
Share on other sites

  • 2 months later...
Just a suggestion....

You should explain how to check which kernel they currently have


open terminal, type "uname -a" without the "" apparently, that should tell you

Link to comment
Share on other sites

  • 3 weeks later...

are this the latest guidelines to install the latest version of mac os x?


I tried once 10.4.4 but now I want to install it again.


I have an asus a8n32-sli and a sata harddisk (also raid, which i doubt i can install in, but you never know)

Link to comment
Share on other sites

:whistle: Ive tried 2 different iso's. 10.4.6 myz and Mac_OS_X_10.4.8_-_JaS_AMD_Intel_SSE2_SSE3_incl._PPF1. the first one i was just VMing and never got it to boot all the way up. the second one i started DLed with the intention to dual boot. i installed winXP , partitioned using acronis disk suite 10, then burned the iso and restarted. got osx installed, with the customizers: ppf1, and sse2/3, and kext replace for intel. when i restart it tries boot straight into osx without letting me access windows (the acronis boot selector is installed) then hits the white apple screen where it turns grey and tells me i need to restart my machine. i patched the iso with this (thanks defiant) and havnt reburned. my desktop (the one im using, osx is on my laptop) dvd burner doesnt support dvd+r for some reason. which means i need to get into windows on the laptop so i can burn the updated iso. aslo worth mentioning is the first aid section of the disk util tells me that the disk is fine and mounts it. so my questions are:


1) how can i get into windows? i tried to use the osx startup disk to mark the windows partition as primary but when i type any command into the prompt it just throws me back into the countdown to install osx from the dvd.


2) is it even worth me doing all this? is the ppf2 patch the likly problem?


my build:

P105-S9312 Genuine Windows® XP Professional, Intel® Core™ Duo Processor T2500, 2048MB

DDR2 SDRAM, 200GB HDD (4200RPM), 17" WXGA+ TruBrite™, DVD SuperMulti

Double Layer, 802.11 a/b/g, NVIDIA® GeForce Go 7900 GS 256MB GDDR3 SDRAM

VRAM, Express Media Player

Operating System

Genuine Windows® XP Professional

Processor and Chipset3

Intel® Centrino® Mobile Technology featuring:

Intel® Core™ Duo Processor T2500 2.0GHz, 2MB L2, 667MHz FSB

Mobile Intel® 945PM Express Chipset

Intel® PRO/Wireless 3945ABG (802.11a/b/g)


Configured with 2048MB PC5300 667MHz DDR2 SDRAM

Hard Disk Drive

200GB (4200 RPM) Serial-ATA (SATA) hard disk drive


PCI-Express™ x16 graphics subsystem, featuring:

NVIDIA® GeForce™ Go 7900 GS with 256MB DDR3 discrete graphics memory


Built-in harman/kardon® stereo speakers

SRS Labs audio enhancements9

o SRS TruSurround XT® virtual surround sound

o SRS WOW™ stereo enhancement

16-bit stereo software sound

o Intel® High Definition Audio

Edited by epicor
Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

I have problems with the kernel 8.8.1. I tried manual method and hippiex Live Update.

At the boot


Failed to load extension com.apple.driver.AppleFileSystemDriver.

Failed to load extension com.apple.iokit.IOATABlockStorage.

Failed to load extension com.apple.iokit.IOSCSIMultimediaCommandsDevice.

Failed to load extension com.apple.iokit.IOSCSITaskUserClient.


followed by


Still waiting for root device





AMD 3200+ Venice SSE3

Asus A8V

ATI Sapphire X1600 Pro 256 MB AGP


Jas 10.4.6 DVD + Jas combo update 10.4.8, Darwin 8.4.1

Link to comment
Share on other sites

  • 3 months later...

Hello to everybody


I have a stupid question: why MAC OS 10.4.9 & 10.4.10 you made for SSE3 CPUs only? If you can’t fit drivers for all soft, put it in one ISO file anyway. Or put all applications like iPhoto & iCal to another DVD image. Everybody will easily figure out how to install them manually. People who want to install MAC OS on regular computer can’t afford latest hardware usually. Why did you remove from latest images support for a lot of hardware?


For example: image with kernel made 5.26.2005 7.44MB supports my keyboard & touchpad in PCG-V505AX. But image 10.4.8 with kernel made 12.10.2006 3.96MB doesn’t support it (this kernel has 0x003A8D2F trouble on PCG-V505AX & MSI 865GM2 also).


I hope that everybody understand, that Vista really sucks & a lot of people looking for alternative OS for their computers.


I will be happy if your MAC OS support the same hardware as Ubuntu.


It’s very sad, that a lot of people have troubles with “unable to find driver for this platform: “ACPI”, 0x003A8D22F. It looks like almost everybody has this trouble. I tried to install JaS on both my computers with the same result.




I found one installation image, which you can install if you have the same trouble:


I downloaded it on eMule file name is: Mac Os X 10.4 Tiger For Intel X86, Bootable And Installable.iso File size is: 4.192.384KB You can download it & I will help you as much as I can – I will share it on my computer. But it sucks to have 10.4.1…


But anyway, I’m so happy that you try to help people…

Link to comment
Share on other sites

My machine will boot up the installer, but sometimes freezes when i try to use different functions in the disk utility and always freezes while installing the OS. After it checks the disk, it starts to install the base files and always freezes at that point. What do I do? Check my sig for specs.

Link to comment
Share on other sites

  • 3 weeks later...

"Darwin cerebral-assasins-computer.local 8.8.1 Darwin Kernel Version 8.8.1: Sat Dec 9 22:18:27 AZOT 2006; semthex:/nebukadnezar/BUILD/obj/RELEASE_I386 i386 i386"


this is what comes up when i give a "uname -a" command.. does this mean i have the original darwin or the semthex 8.8.1 kernel and if so.. are there any updates ?

Link to comment
Share on other sites

I can't mount a .dmg image after upgrading a Jas 10.4.9 SSE3 intel install with the Prasys autoupdater. Kernel is 8.8.1 and my audio stuttering issue is resolved finally, but now when I download a dmg file from the net and try to in

stall it, it hangs for a while then gives the message:

The following disk images failed to mount

Image Reason

vlc-0.8.6c.dmg Device not configured


In dmesg I see alot of :

Couldn't alloc class "com_mifki_r3d3"


Thanks for any help

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...
Not sure if this is apprpriate here, but its my first success in this process...


Took me forever to find out the solution to panic caused by "cpu > num_cpus" error on my AMD 64 3500+


On boot enter "cpus=1"





I have also received the panic caused by "cpu > num_cpus" error on my AMD 64 5000. Could u please elaborate where to enter "cpus"=1"? I do not get any opportunity to type anything. Several lines run by and suddenly another screen freezes with the panic message.


Await ur reply...Thx.

Link to comment
Share on other sites

  • 2 weeks later...


I have also received the panic caused by "cpu > num_cpus" error on my AMD 64 5000. Could u please elaborate where to enter "cpus"=1"? I do not get any opportunity to type anything. Several lines run by and suddenly another screen freezes with the panic message.


Await ur reply...Thx.


What do you get after that on the panic?

What are the dependancies?

If it mentions com.apple.driver.APPLEACPIPLATFORM

Try reading this thread, http://forum.insanelymac.com/index.php?showtopic=74905

Link to comment
Share on other sites

  • 2 years later...

Mac OS X 10.4.8 will now run on any generic x86-based PC. Well, almost. Kernel coder Semthex has posted what he claims is an entirely legal release of the Mac operating system's foundation layer. The only snag: you can't boot into the familiar GUI.

Link to comment
Share on other sites


  • Create New...