Jump to content

Imposible instalar Catalina en Asus Z590-A...


53 posts in this topic

Recommended Posts

7 minutes ago, miliuco said:

@antuneddu What are you doing here? Ho l'impressione che tu conosca già molto la lingua spagnola :)

enough there are many similarities, then with the translator I speak all languages ... I see that you also speak Spanish well :lol:  

 

buenas noches... hasta mañana

  • Haha 1
Link to comment
Share on other sites

Posted (edited)
13 hours ago, miliuco said:

Sí, con el 11700K tiene que ir todo más rápido, eso seguro, ya me contarás. Con esta CPU 11 es más recomendable que con la 10 deshabilitar la iGPU en BIOS y quitar el código de config.plist. Con el disco NVME Samsung 980 Pro que tienes, madre mía!!! Por cierto, los Samsung 970 Evo Plus no funcionaban en macOS hasta que actualizabas su firmware desde Windows pero veo que este nuevo sí funciona tal cual, no? Es de lo más nuevo que hay, PICe 4.

 

Por el pantallazo parece OC 0.6.7 (del 1 de marzo) así que me moveré en esa versión que por otro lado va estupendamente pero, si la dejamos bien fina, intentamos pasar a 0.6.9 que tiene mejoras para las placas y CPU nuevas como las tuyas.

 

 

Por cierto, tienes unos deberes que se me olvidó comentarte. Un How to de cómo flashear la VBIOS de la RX 580, yo nunca lo he hecho, es por aprender una cosa más.

 

Buenos días @miliuco traigo malas noticias... :(

 

No inicia Mac...

 

He cambiado el procesador y no inicia...

 

No entiendo como no porqué, pero no debería influir en nada... 

 

Te puede sonar algo de esta imagen para saber qué hacer?

 

Muchisimas gracias amigo mío!

16217667108307541993281444476840.jpg

Edited by LuisImpreza
Link to comment
Share on other sites

Posted (edited)

El problema que tengo con tu nueva CPU es que en las guías de Dortania todavía no está publicada la de la 11 generación, sólo llega hasta Comet Lake:

https://dortania.github.io/OpenCore-Install-Guide/config.plist/comet-lake.html

Creo que la 10 gen. se encuentra como Comet Lake y también como Ice Lake. Creo que la 11 se llama Rocket Lake así que eso es lo que tenemos que buscar.

 

Algo hay que modificar en config.plist o en los SSDT que es específico para la 11. Busca tú que yo también echaré un vistazo esta tarde a ver cómo preparamos una EFI para la nueva CPU.

 

No creo que influya pero ¿has hecho ResetNVRAM la primera vez que arrancas con la nueva CPU?

 

Lo que es casi seguro es que hay que inyectar código de CPU Comet Lake, al menos es lo básico que leo en Dortania:

"Rocket Lake: Requires Comet Lake CPUID 0x0A0671".

 

Date cuenta que la 11 es muy nueva. Esta tarde lo miro.

 

 

Edited by miliuco
  • Like 1
Link to comment
Share on other sites

Posted (edited)
6 minutes ago, miliuco said:

El problema que tengo con tu nueva CPU es que en las guías de Dortania todavía no está publicada la de la 11 generación, sólo llega hasta Comet Lake:

https://dortania.github.io/OpenCore-Install-Guide/config.plist/comet-lake.html

Creo que la 10 gen. se encuentra como Comet Lake y también como Ice Lake. Creo que la 11 se llama Rocket Lake así que eso es lo que tenemos que buscar.

 

Algo hay que modificar en config.plist o en los SSDT que es específico para la 11. Busca tú que yo también echaré un vistazo esta tarde a ver cómo preparamos una EFI para la nueva CPU.

 

No creo que influya pero ¿has hecho ResetNVRAM la primera vez que arrancas con la nueva CPU?

 

 

 

Voy a ir buscando yo también tío, la cuestión es que he visto a un montón de usuario con una Z590 Vision de Gigabyte y no han tenido un sólo problema ni tener que configurar nada... 

 

Voy a hacer ResetNVRAM por probar, hasta que no hablara contigo, no me he atrevido a hacer nada más que cargar valores de fábrica en placa y dejarlo todo como estaba después por si las moscas.

 

Un abrazo y voy a ello!

 

Muchas gracias tío... No te imaginas todo lo que tenía pendiente trabajar hoy con él para dejarlo a punto para ya mañana empezar con él... :( 

 

@miliuco he realizado el ResetNVRAM y ahora la partición de arranque UEFI del OpenCore no está... Es como si se hubiera borrado :cry:

 

Con el USB de la instalación he probado a entrar y el mismo error...

Edited by LuisImpreza
Link to comment
Share on other sites

Posted (edited)
2 hours ago, miliuco said:

El problema que tengo con tu nueva CPU es que en las guías de Dortania todavía no está publicada la de la 11 generación, sólo llega hasta Comet Lake:

https://dortania.github.io/OpenCore-Install-Guide/config.plist/comet-lake.html

Creo que la 10 gen. se encuentra como Comet Lake y también como Ice Lake. Creo que la 11 se llama Rocket Lake así que eso es lo que tenemos que buscar.

 

Algo hay que modificar en config.plist o en los SSDT que es específico para la 11. Busca tú que yo también echaré un vistazo esta tarde a ver cómo preparamos una EFI para la nueva CPU.

 

No creo que influya pero ¿has hecho ResetNVRAM la primera vez que arrancas con la nueva CPU?

 

Lo que es casi seguro es que hay que inyectar código de CPU Comet Lake, al menos es lo básico que leo en Dortania:

"Rocket Lake: Requires Comet Lake CPUID 0x0A0671".

 

Date cuenta que la 11 es muy nueva. Esta tarde lo miro.

 

 

 

En mi caso, lo único que he hecho ha sido:

 

1-Cambiar procesador 10700K por 11700K

2-Cambiar NVME de puerto para que de 3.0 pase a 4.0 y conseguir la velocidad real.

3-Cargar valores de fábrica y volver a desactivar todo lo no compatible con Hakcintosh.

 

Adjunto en esta cita oculta el resultado en texto del fallo de Opencore:

 

Spoiler

00:000 00:000 AAPL: [EB|#LOG:INIT] 2021-05-23T14:02:02
00:046 00:046 AAPL: [EB|#VERSION] boot.efi 422.140.3~2 (Official), built 2020-06-07T17:22:20-0700
00:092 00:046 AAPL: [EB|#BUILD] BUILD-INFO[298]:{"DisplayName":"boot.efi","DisplayVersion":"422.140.3~2","RecordUuid":"B6FD6584-F0DA-41E8-9542-FAD5E7448407","BuildTime":"2020-06-07T17:22:20-0700","ProjectName":"efiboot","ProductName":"boot.efi","SourceVersion":"422.140.3","BuildVersion":"2","BuildConfiguration":"Release","BuildType":"Official"}
00:167 00:074 AAPL: [EB|#H:IS] 0
00:213 00:046 AAPL: [EB|#WL:MODE] 0
00:288 00:075 AAPL: [EB|#CONFIG:SRC] <default>
00:334 00:046 AAPL: [EB|#CONFIG| 0] boot-save-log : 0x0000000000000002 (0x0000000000000002 < 0xFFFFFFFFFFFFFFFF) <default>
00:410 00:075 AAPL: [EB|#CONFIG| 1] wake-save-log : 0x0000000000000002 (0x0000000000000002 < 0x0000000000000002) <default>
00:456 00:045 AAPL: [EB|#CONFIG| 2] console       : 0x0000000000000001 (0x0000000000000001 < 0x0000000000000001) <default>
00:502 00:046 AAPL: [EB|#CONFIG| 3] serial        : 0x0000000000000000 (0x0000000000000000 < 0x0000000000000000) <default>
00:577 00:075 AAPL: [EB|#CONFIG| 4] embed-log-dt  : 0x0000000000000000 (0x0000000000000000 < 0x0000000000000000) <default>
00:623 00:046 AAPL: [EB|#CONFIG| 5] timestamps    : 0x0000000000000000 (0x0000000000000000 < 0xFFFFFFFFFFFFFFFF) <default>
00:699 00:075 AAPL: [EB|#CONFIG| 6] log-level     : 0x0000000000000001 (0x0000000000000001 & 0x0000000000000001) <default>
00:745 00:045 AAPL: [EB|#CONFIG| 7] breakpoint    : 0x0000000000000000 (0x0000000000000000 & 0x0000000000000000) <default>
00:791 00:045 AAPL: [EB|#CONFIG| 8] kc-read-size  : 0x0000000000100000 (0x0000000000100000 < 0xFFFFFFFFFFFFFFFF) <default>
00:865 00:074 AAPL: [EB|#H:IS] 0
00:912 00:046 AAPL: [EB|#WL|0] 0x01 0x01   0 0x00
00:987 00:075 AAPL: [EB|#BRD:NV] Mac-AF89B6D9451A490B
01:033 00:045 AAPL: [EB|#WL|1] 0x01 0x01   2 0x00
01:079 00:046 AAPL: [EB|`BST:IDT] {
01:154 00:074 AAPL: [EB|`BST:IDT] }
01:201 00:046 AAPL: [EB|#WL|2] 0x01 0x01   3 0x00
01:277 00:076 AAPL: [EB|#WL|3] 0x01 0x01   4 0x00
01:324 00:046 AAPL: [EB|#BRD:NV] Mac-AF89B6D9451A490B
01:371 00:046 AAPL: [EB|#WL|4] 0x01 0x01   5 0x00
01:447 00:076 AAPL: [EB|`H:CHK] BM: 0x0000000000000000
01:493 00:046 AAPL: [EB|`H:CHK] Err(0xE) @ GV boot-signature
01:570 00:076 AAPL: [EB|#WL|5] 0x01 0x01  23 0x0E
01:616 00:046 AAPL: [EB|`H:CPM] Err(0xE), (24, 24) @ GV Persistent-memory-note
01:663 00:046 AAPL: [EB|#SB:P] 0x0
01:740 00:076 AAPL: [EB|#LIMG:DP] Acpi(PNP0A03,0)/Pci(6|0)/Pci(0|0)/?[ 0x83 0x17 0x10 0x0 0x1 0x0 0x0 0x0 0x0 0x25 0x38 0xB1 0x11 0xB0 0x31 0x30 ]/HD(Part2,Sig31173F2D-0CF0-4BE2-910F-9C29996816B7)/VenMedia(BE74FCF7-0B7C-49F3-9147-01F4042E6842)
01:785 00:045 AAPL: [EB|#LIMG:FP] \D66194B8-21AD-4C6F-A2B1-17451A1F94A5\System\Library\CoreServices\boot.efi
01:863 00:077 AAPL: [EB|#LIMG:OPT] ()
01:910 00:046 AAPL: [EB|`OPT:LXF] 'LF (\\D66194B8-21AD-4C6F-A2B1-17451A1F94A5\\System\\Library\\CoreServices\\com.apple.Boot.plist)
01:956 00:046 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: \\D66194B8-21AD-4C6F-A2B1-17451A1F94A5\\System\\Library\\CoreServices\\com.apple.Boot.plist, DP: 0
02:033 00:076 AAPL: [EB|`LD:OFS] Err(0xE) @ OPEN (\\D66194B8-21AD-4C6F-A2B1-17451A1F94A5\\System\\Library\\CoreServices\\com.apple.Boot.plist)
02:079 00:045 AAPL: [EB|`OPT:LXF] Err(0xE) @ 'LF
02:155 00:076 AAPL: [EB|`OPT:LXF] 'LF (Library\\Preferences\\SystemConfiguration\\com.apple.Boot.plist)
02:201 00:046 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: Library\\Preferences\\SystemConfiguration\\com.apple.Boot.plist, DP: 0
02:248 00:046 AAPL: [EB:#KF] ()
02:324 00:076 AAPL: [EB|#MBA:CL] ()
02:370 00:046 AAPL: [EB|#MBA:NV] (-v alcid=11)
02:447 00:076 AAPL: [EB|#MBA:KF] ()
02:493 00:045 AAPL: [EB|#MBA:OUT] (-v alcid=11)
02:570 00:076 AAPL: [EB|#LOG:VERBOSE] 2021-05-23T14:02:05
02:616 00:046 AAPL: [EB|#OPT:BM] 0x84102
02:662 00:046 AAPL: [EB|`OPT:LXF] 'LF (\\D66194B8-21AD-4C6F-A2B1-17451A1F94A5\\System\\Library\\CoreServices\\PlatformSupport.plist)
02:738 00:076 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: \\D66194B8-21AD-4C6F-A2B1-17451A1F94A5\\System\\Library\\CoreServices\\PlatformSupport.plist, DP: 0
02:785 00:047 AAPL: [EB|#B:VAw]
02:862 00:076 AAPL: [EB|#P:CPR] N
02:908 00:046 AAPL: [EB|#P:MPI] N
02:954 00:046 AAPL: [EB|#P:BPI] N
03:031 00:076 AAPL: [EB|`CS:CSKSD] {
03:077 00:045 AAPL: [EB|`CS:CSKSD] Err(0xE) @ GV 8D63D4FE-BD3C-4AAD-881D-86FD974BC1DF:boot-info-payload
03:153 00:076 AAPL: [EB|#WL|6] 0x01 0x01   6 0x0E
03:199 00:046 AAPL: [EB|`CS:LFC] {
03:246 00:046 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: System\\Library\\Caches\\com.apple.corestorage\\EncryptedRoot.plist.wipekey, DP: 0
03:323 00:077 AAPL: [EB|`FS:AGSVH] Err(0xE) @ LocHB 59D76AE4-37E3-55A7-B460-EF13D46E6020
03:369 00:045 AAPL: [EB|`G:CS] } Ok(0)
03:450 00:080 AAPL: [EB|`LD:LF] FIO: 0, DIR: 1, P: <null string>, DP: 1
03:498 00:048 AAPL: [EB|`B:SBS] SZ: 621112
03:551 00:053 AAPL: [EB|#B:SHA] f4031e1840ae80899574cd5a1feedc6b106d0f87
03:632 00:080 AAPL: [EB|`WL:PWLFNV] Err(0xE) @ GV wake-failure
03:680 00:048 AAPL: [EB|`WL:DT] Err(0xE) @ WL:PWLFNV
03:759 00:078 AAPL: [EB|`WL:PWLFRTC] ! @ RTC:R
03:808 00:048 AAPL: [EB|`WL:DT] Err(0xE) @ WL:PWLFRTC
03:887 00:078 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.0
03:935 00:048 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.1
03:984 00:049 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.2
04:063 00:078 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.3
04:112 00:048 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.4
04:191 00:078 AAPL: [EB|`FS:AGSVH] Err(0xE) @ 'AGU.5
04:243 00:052 AAPL: [EB|`LD:LKC] BPDK -> (System\Library\PrelinkedKernels\prelinkedkernel.development)
04:299 00:056 AAPL: [EB|`LD:OFS] Err(0xE) @ OPEN (System\\Library\\PrelinkedKernels\\prelinkedkernel.development)
04:382 00:082 AAPL: [EB|`LD:LKC] BPDK,!R -> (System\Library\PrelinkedKernels\prelinkedkernel)
06:265 01:883 AAPL: [EB|`LD:LKFS] } Ok(0)
06:345 00:079 AAPL: [EB|`LD:LKC] } Ok(0)
06:395 00:049 AAPL: [EB|#FWFM] 0xFFDFFF7F
06:443 00:048 AAPL: [EB|#FWFT] 0xFD8FF576
06:521 00:078 AAPL: [EB|#CSR:IN] 0x00000040
06:570 00:048 AAPL: [EB|#CSR:OUT] 0x00000040
06:648 00:077 AAPL: [EB|`BST:FBS] {
06:697 00:048 AAPL: [EB|`BST:FBS] BA.ADSZ: 0
06:745 00:048 AAPL: [EB|`BST:FBS] BA.KSDSZ: 0
06:828 00:082 AAPL: [EB|`B:WFDW] Err(0xE), 0 @ LocHB 71B4903C-14EC-42C4-BDC6-CE1449930E49
06:876 00:048 AAPL: [EB|#LOG:DT] 2021-05-23T14:02:09
06:957 00:080 AAPL: [EB|#LOG:EXITBS:START] 2021-05-23T14:02:09
 

 

Mira lo que he leído en otro sitio @miliuco 

 

CPUID for Rocket Lake Processors

{Cpuid1Data} EB 06 09 00 00 00 00 00 00 00 00 00 00 00 00 00

{Cpuid1Mask} FF FF FF FF 00 00 00 00 00 00 00 00 00 00 00 00

 

He leído muchísimo que ya he borrado de este post compañero @miliuco

 

Te comento que ya lo he solucionado poniendo eso y cambiando el smbios por macpro 7.1 que es el único que lo reconoce...

 

No arranca con Opencore 6.9, lo he dejado en el 6.7, no sé si arrancará en el 7.0.

 

Lo noto más lento que antes y eso no mola pero nada... :( 

 

Estoy pasando un Benchmark para comparar con el de ayer...

 

Edito:

 

1307 Single Core y 7556 Multi Core i7 10700K

 

1349 Single Core y 6883 Multi Core i7 11700K

 

Lamentable...

 

El disco duro tampoco va a la velocidad que debería de 7000, se queda en 5600 que me doy por satisfecho, pero es una pena.

 

Un abrazo tío!

IMG_20210523_151627_compress35.jpg

IMG_20210523_151730_compress30.jpg

IMG_20210523_151740_compress91.jpg

Edited by LuisImpreza
Quitar mucho contenido.
Link to comment
Share on other sites

Posted (edited)

Ya he estado mirando sobre tu nueva CPU y no tengo buenas noticas para ti. El problema principal es que NO hay ningún Mac con Rocket Lake y muy probablemente no lo llegará a haber. Por eso el soporte para esta generación de CPU es tan precario. Piensa que desde Sky Lake la arquitectura básica de los Intel ha sido la misma pero en la 11 gen. ha cambiado y ya no es posible decir: si funciona una CPU 10 también funcionará una 11.

 

Por supuesto en Windows sí debería funcionar sin problemas, simplemente configurando la BIOS. Pero en Mac es muy problemático, sobre todo conseguir funcionamiento óptimo. La única cosa imprescindible es pasar el id de CPU Comet Lake en config.plist, esto se consigue escribiendo lo que me comentas en el post de IM:

 

CPUID for Rocket Lake Processors
{Cpuid1Data} EB 06 09 00 00 00 00 00 00 00 00 00 00 00 00 00
{Cpuid1Mask} FF FF FF FF 00 00 00 00 00 00 00 00 00 00 00 00

 

Esto y poner SMBIOS de MacPro7,1. Así que las 2 cosas fundamentales las has descubierto solo.

 

Para usar MacPro7,1 sin esos avisos de memoria mal configurada hay que recurrir a la extensión RestrictEvents que es precisamente para esto:

https://github.com/acidanthera/RestrictEvents/releases

Descarga la 1.0.1 release. La colocas en Kexts y la añades en config.plist. El único cambio que has de notar es la desaparición de esos avisos y que la pestaña Memoria de Acerca de este Mac muestra el aspecto de los otros Mac.

 

Manda la EFI que estás usando con la CPU 11. Entera en ZIP. Te aviso que los programas de correo no suelen aceptar carpetas EFI por tener binarios, así que mejor súbela al hilo de IM que allí sí se puede subir. La revisaré intentando actualizar OpenCore porque, con esta CPU, cuanto más nuevo sea OpenCore mejor irá. Por ahora poco más te puedo decir. Rocket Lake actualmente se considera opción arriesgada para hackintosh. Si podemos hacer que mejore a la CPU 10, pues bien. En caso contrario, tienes que plantearte si usar sólo Windows o regresar a la CPU 10 que ya es una máquina excelente pero, claro, tú quieres ver PCIe 4. Vamos a intentar la mejora de la EFI.

 

Saludos, Emilio.

 

 

Edited by miliuco
Link to comment
Share on other sites

Posted (edited)

@LuisImpreza

Viene la prueba de fuego. Esta es la EFI con OpenCore 0.7.0, última versión que aunque todavía es beta funciona bien y en 6 o 7 días saldrá como definitiva.

  • tienes lo que ya tenías en tu EFI anterior
  • añadido un parche en config.plist para mejorar detección y funcionamiento de la Eth
  • añadida RestrictEvents.kext para quitar los avisos de memoria de MacPro7,1
  • actualizadas las kexts de OpenCore a sus últimas versiones
  • añadido menú gráfico, se consigue con el driver OpenCanopy.efi, por ahora me quedo en el tema de iconos por defecto de los autores de OpenCore que es más sencillo de configurar, si funciona ya será fácil poner cualquier otro tema que te guste. A mí este tema predefinido me encanta, es el que suelo usar porque es el que más se parece a un Mac real.

Recuerda que siempre que se arranca con una EFI diferente, sobre todo si es también diferente OpenCore, hay que hacer ResetNVRAM en el primer arranque.

¡Suerte!

 

 

 

EFI Z590-A 11700K OC 0.7.0.zip

Edited by miliuco
Attached file error.
  • Like 1
Link to comment
Share on other sites

Posted (edited)
4 hours ago, miliuco said:

@LuisImpreza

Viene la prueba de fuego. Esta es la EFI con OpenCore 0.7.0, última versión que aunque todavía es beta funciona bien y en 6 o 7 días saldrá como definitiva.

  • tienes lo que ya tenías en tu EFI anterior
  • añadido un parche en config.plist para mejorar detección y funcionamiento de la Eth
  • añadida RestrictEvents.kext para quitar los avisos de memoria de MacPro7,1
  • actualizadas las kexts de OpenCore a sus últimas versiones
  • añadido menú gráfico, se consigue con el driver OpenCanopy.efi, por ahora me quedo en el tema de iconos por defecto de los autores de OpenCore que es más sencillo de configurar, si funciona ya será fácil poner cualquier otro tema que te guste. A mí este tema predefinido me encanta, es el que suelo usar porque es el que más se parece a un Mac real.

Recuerda que siempre que se arranca con una EFI diferente, sobre todo si es también diferente OpenCore, hay que hacer ResetNVRAM en el primer arranque.

¡Suerte!

 

 

 

EFI Z590-A 11700K OC 0.7.0.zip 3.29 MB · 1 download

 

Buenas tardes amigo mío!

 

Nada, finalmente no hay suerte... :(

 

He realizado el reset antes de arrancar y da igual... 

IMG_20210524_163525_compress60.jpg

Edited by LuisImpreza
Link to comment
Share on other sites

Posted (edited)

Cambia el config.plist de mi EFI por este. El único cambio es desactivar el parche de la Eth que no estaba anteriormente en tu config.plist. Prueba y comenta.

Pregunta: ¿han salido los iconos de OpenCore o el menú de texto que ya conoces?

No quitamos todavía -v de boot-args hasta que lo tengamos controlado, para poder ver los mensajes del arranque y ver los errores.

 

config.plist

Edited by miliuco
  • Like 1
Link to comment
Share on other sites

4 minutes ago, miliuco said:

Cambia el config.plist de mi EFI por este. El único cambio es desactivar el parche de la Eth que no estaba anteriormente en tu config.plist. Prueba y comenta.

Pregunta: ¿han salido los iconos de OpenCore o el menú de texto que ya conoces?

No quitamos todavía -v de boot-args hasta que lo tengamos controlado, para poder ver los mensajes del arranque y ver los errores.

 

config.plist 21.46 kB · 0 downloads

 

Misma pantalla Emilio :(

 

Por lo que nombra antes de quedarse parado, hace mención al NVME, no? 

 

Hay un montón de errores ACPI, no sé si has modificado alguno o directamente lo provoca la nueva versión de Opencore que me extrañaría muchísimo que no funcionara con una placa tan nueva... Voy a probar con la 0.69 antes de nada...

 

gracias amigo mío!!!

Link to comment
Share on other sites

4 minutes ago, miliuco said:

Si tampoco va (recuerda ResetNVRAM) usa esta EFI, yo puse versiones más modernas de los SSDT pero, ya que el error es de ACPI, vamos a colocar exactamente los mismos SSDT que tenías en tu EFI que arrancaba bien.

 

EFI Z590-A 11700K OC 0.7.0 2.zip 3.29 MB · 1 download

Probado tío y sigue sin arrancar, misma pantalla... Yo creo que respetando mi ACPI, podría haber posibilidades... No sé si lo has metido en esta, pero sigue sin funcionar...

Link to comment
Share on other sites

Posted (edited)

3ª versión de la EFI pero esta vez en ACPI pongo solamente los SSDT recomendados por Dortania para Comet Lake ya que no hay guía todavía para Rocket Lake:

https://dortania.github.io/OpenCore-Install-Guide/config.plist/comet-lake.html

A veces es prueba error. Si esta 3ª no va, vuelvo a la EFI con OC 0.6.7 que tenías preparada y ponemos kexts recientes.

 

Dime si ves iconos o texto antes de empezar los mensajes de arranque.

 

EFI Z590-A 11700K OC 0.7.0 3.zip

4 minutes ago, LuisImpreza said:

Probado tío y sigue sin arrancar, misma pantalla... Yo creo que respetando mi ACPI, podría haber posibilidades... No sé si lo has metido en esta, pero sigue sin funcionar...

Esta versión 2 tiene los SSDT de tu carpeta con 0.6.7, exactamente los mimos.

Edited by miliuco
  • Like 1
Link to comment
Share on other sites

Posted (edited)
9 minutes ago, miliuco said:

3ª versión de la EFI pero esta vez en ACPI pongo solamente los SSDT recomendados por Dortania para Comet Lake ya que no hay guía todavía para Rocket Lake:

https://dortania.github.io/OpenCore-Install-Guide/config.plist/comet-lake.html

A veces es prueba error. Si esta 3ª no va, vuelvo a la EFI con OC 0.6.7 que tenías preparada y ponemos kexts recientes.

 

Dime si ves iconos o texto antes de empezar los mensajes de arranque.

 

EFI Z590-A 11700K OC 0.7.0 3.zip 3.29 MB · 0 downloads

Esta versión 2 tiene los SSDT de tu carpeta con 0.6.7, exactamente los mimos.

 

Arrancado! Pero no me funciona ningún USB :O 

 

Respecto al menú Emilio, sí me salen los iconos bonitos, no el texto tío! Muchísimas gracias por el trabajazo! Está dando un trabajo del copón...

Edited by LuisImpreza
Link to comment
Share on other sites

Posted (edited)
9 minutes ago, LuisImpreza said:

 

Arrancado! Pero no me funciona ningún USB :O 

 

Respecto al menú Emilio, sí me salen los iconos bonitos, no el texto tío! Muchísimas gracias por el trabajazo! Está dando un trabajo del copón...

 

Es porque quité SSDT-USB-Reset.aml que lo tenías en tu EFI para ir paso a paso. Lo añadimos ahora y probamos 1 único cambio a la vez.

 

Los iconos dan gusto eh? Qué diferencia con el texto. Pregunta: salen los iconos  al comenzar el arranque de macOS se va a texto (modo verbose) y en algún momento sale la manzana y después el escritorio, es así?

 

EFI Z590-A 11700K OC 0.7.0 4.zip

Edited by miliuco
  • Like 1
Link to comment
Share on other sites

Posted (edited)
16 minutes ago, miliuco said:

 

Es porque quité SSDT-USB-Reset.aml que lo tenías en tu EFI para ir paso a paso. Lo añadimos ahora y probamos 1 único cambio a la vez.

 

Los iconos dan gusto eh? Qué diferencia con el texto. Pregunta: salen los iconos  al comenzar el arranque de macOS se va a texto (modo verbose) y en algún momento sale la manzana y después el escritorio, es así?

 

EFI Z590-A 11700K OC 0.7.0 4.zip 3.29 MB · 0 downloads

 

Y... Arrancó!!!! :)

 

Lo primero sale el menú para elegir sistema, luego salen todas las letras negras y un poco después la barra de la manzana cargando el sistema, una vez ya finalicemos la config del todo, se quita el -V y listo! 

 

Decirte que al final lo has conseguido!!! 

Muchísimas gracias por todo!!! Dime qué más voy comprobando, el Ethernet no coge 2.5 ni de coña, menudo cabrón! Jaja

 

Y copiando mi carpeta Microsoft en la misma carpeta del boot y OC como hacía antes para que detectara la partición, ya no sale tampoco... Pero bueno, vamos paso a paso. Enorme trabajo Emilio :)

 

 

 

 

 

 

Edited by LuisImpreza
Link to comment
Share on other sites

Posted (edited)

Nada, aquí estoy de nuevo, tuve visita y ya es tarde para salir. Hoy no, mañana :)

 

Cosas que quiero saber:

  • ¿vuelves a tener puertos USB? ¿funcionan bien?
  • ¿han desaparecido los avisos de la memoria del MacPro?
  • cronometra: segundos desde que das al botón de encendido del PC hasta que tienes delante el menú de OpenCore
  • cronometra: segundos desde que se quita el menú de OpenCore (empieza el arranque en modo verbose) hasta que tienes el escritorio de macOS en marcha.

La Eth por ahora en mac no va a funcionar a 2,5, espera a ver si alguien saca un parche o algo pero estamos parados en 1GB.

No necesitas la carpeta Microsoft, por eso la quité yo. Los sistemas de archivos y dispositivos que aparecen en el menú de OpenCore se controlan desde la clave Misc > Security > ScanPolicy. Si vale 0 se muestran todos los sistemas y dispositivos, es la que tenías tú al principio y en caso de problemas se puede poner para ver el sistema Windows. Pero prueba con el valor 2689795 que, si muestra bien Windows, me gusta más que el 0 que busca todo tipo de sistemas y es ligeramente menos efectiva y elegante.

 

Edited by miliuco
  • Like 1
Link to comment
Share on other sites

Posted (edited)
35 minutes ago, miliuco said:

Nada, aquí estoy de nuevo, tuve visita y ya es tarde para salir. Hoy no, mañana :)

 

Cosas que quiero saber:

  • ¿vuelves a tener puertos USB? ¿funcionan bien?
  • ¿han desaparecido los avisos de la memoria del MacPro?
  • cronometra: segundos desde que das al botón de encendido del PC hasta que tienes delante el menú de OpenCore
  • cronometra: segundos desde que se quita el menú de OpenCore (empieza el arranque en modo verbose) hasta que tienes el escritorio de macOS en marcha.

La Eth por ahora en mac no va a funcionar a 2,5, espera a ver si alguien saca un parche o algo pero estamos parados en 1GB.

No necesitas la carpeta Microsoft, por eso la quité yo. Los sistemas de archivos y dispositivos que aparecen en el menú de OpenCore se controlan desde la clave Misc > Security > ScanPolicy. Si vale 0 se muestran todos los sistemas y dispositivos, es la que tenías tú al principio y en caso de problemas se puede poner para ver el sistema Windows. Pero prueba con el valor 2689795 que, si muestra bien Windows, me gusta más que el 0 que busca todo tipo de sistemas y es ligeramente menos efectiva y elegante.

 

 

 

Jajajaja me parto contigo, eres un crack!

 

Te comento:

 

1- Puertos USB en orden, todos funcionando, USB-C no lo he probado, pero vamos, no lo necesito.

2- Han desaparecido los aviosos de memoria, lástima que no me quite lo de las actualizaciones a Big Sur :P

3- Al encender el equipo tarda 15 segundos, pero es por la comprobación de miles de cosas de mi placa.

Desde el menú Opencore hasta la pantalla inicial del sistema 18 segundos, antes cuándo no funcionaban los USB mucho más rápido, pero es lo que toca.

4- Ethernet que funcione a 1gb, me sobra por el momento, porque teniendo 1gb de Digi como tengo en fibra, con que me llegue a tope, me sirve.

5- Sistemas, ahora pongo ese valor y a ver qué tal, sobre todo es para que pueda acceder a Windows entre otras cosas :D

 

Estaba puesto ese valor Emilio, he puesto 0 pero sigo sin ver Windows.

 

Enorme y brutal trabajo compañero! Hago todo y estoy de vuelta en 5 minutos!

 

Muchísimas gracias otra vez más!!! :)

 

Edito: @miliuco ya tienes los datos y lo de Windows ;)

 

IMG_20210524_191614.jpg

Edited by LuisImpreza
Link to comment
Share on other sites

Cuando estás en Catalina o anterior, tienes el indicador de actualización disponible a Big Sur. Esto es así hasta en los Mac de verdad. No hay tu tía.

Link to comment
Share on other sites

Quote

Al encender el equipo tarda 15 segundos, pero es por la comprobación de miles de cosas de mi placa.

Desde el menú Opencore hasta la pantalla inicial del sistema 18 segundos, antes cuándo no funcionaban los USB mucho más rápido, pero es lo que toca.

Los 15" iniciales parecen muchos para tu placa pero eso no tiene relación con OpenCore o macOS.

Los 18" al escritorio me parecen más normales, teniendo en cuenta que estamos en un sistema no plenamente optimizado.

Parece mentira que esté pensando en 33" de arranque como más de lo normal, hace unos años hubiera parecido un Ferrari.

 

En BIOS > Boot pon el disco de macOS como primer dispositivo de arranque y el de windows como 2º y borra los que haya más de 2. En ScanPolicy sigue con 0 (cero). Reinicia y ResetNVRAM. Sale Windows?

  • Like 1
Link to comment
Share on other sites

Posted (edited)
5 minutes ago, miliuco said:

Los 15" iniciales parecen muchos para tu placa pero eso no tiene relación con OpenCore o macOS.

Los 18" al escritorio me parecen más normales, teniendo en cuenta que estamos en un sistema no plenamente optimizado.

Parece mentira que esté pensando en 33" de arranque como más de lo normal, hace unos años hubiera parecido un Ferrari.

 

En BIOS > Boot pon el disco de macOS como primer dispositivo de arranque y el de windows como 2º y borra los que haya más de 2. En ScanPolicy sigue con 0 (cero). Reinicia y ResetNVRAM. Sale Windows?

 

Todo hecho y sigue sin salir Windows, el booteo estaba así. Voy a probar a copiar la carpeta de Microsoft ahora que está en 0.

 

Edito: Efectivamente tiene que estar en 0 y con la carpeta Microsoft en la carpeta EFI junto a Boot y OC!

 

;)

 

Edited by LuisImpreza
  • Like 1
Link to comment
Share on other sites

Bueno, pues se puede decir que absolutamente todo funcionando gracias al enorme compañero @miliuco

 

Mi equipo por fin tiene todo en orden y aunque ha costado una barbaridad, siempre hay personas buenas repartidas por el mundo...

 

Enormes gracias compañero y cualquier cosa, estoy por aquí! ;)

 

PD: En el correo te pregunto una última pijada y ya te dejo vivir :P

 

Un abrazo!!!

Link to comment
Share on other sites

 Share

×
×
  • Create New...