Jump to content

HP Pavalion CS4838ND Mac OS


20 posts in this topic

Recommended Posts

Hi my verry snappy 15inch HP laptop with the following specs 
Intel I7 10th gen 1065G7 

16GB DDR4 ram 

1TB NVME SSD 

Nvidia MX250 and Intel Iris Plus gpus 

I want to run Mac os on this i know Intel wifi chip will mostlikly doesnt work 

I can Supply a DSDT.aml if needed 

 

I think you have a chance but this is not trivial task. 

This CPU, Intel WiFi and Iris Plus are compatible with macOS 11 using several tricks and files can be found on our forum.

Posted (edited)

I know but i cant get the usb to boot 

I have attached a DSDT created with a windows cmd script SSDTTime 
Creation of usb with goes normally but clover has issues booting also has opencore


I already have the beta intelwifi drivers 


Big sur i will have to check on creating a usb with big sur 

DSDT.aml

Edited by sojab0on0005
Used tool names that are not suported

Any advice to create a big sur usb drive with working bootloader 

I have the BDU tool but when i boot clover that it downloads and put on it i get a bunch error texts on boot See attached screenshot

Opencore does error out i a simmular way.

 

IMG_5259.jpg

This error means that the version of macOS you try to install can't be installed on the computer with Board-ID=Mac-942...

See your config.plist -> SMBIOS section.

Posted (edited)

After some fideling with opencore and the icelake ssdts 

i gotnit to a kernel panic see attached smbios set to MacBookAir9,1 as advised in opencore guide

7FE88847-A409-4E4A-B869-037F8446D182.jpeg

opencore-2021-03-18-130955.txt opencore-2021-03-18-131749.txt opencore-2021-03-18-131823.txt opencore-2021-03-18-120508.txt opencore-2021-03-18-121618.txt opencore-2021-03-18-122121.txt

Edited by sojab0on0005
Smbios setting not given added multiple open core logs

You may need to set the DevirtualiseMmio option to True and set the MmioWhitelist for a specific MMIO.

https://dortania.github.io/OpenCore-Install-Guide/troubleshooting/extended/kernel-issues.html#kernel-panic-on-invalid-frame-pointer

 

See also my reply in the topic below, which has a similar problem.

 

Or, convert 0xFF4B81E9 address into decimal and add it to the MmioWhitelist in the Booter section of Config.plist.

Of course, this also requires the DevirtualiseMmio option to be set to True.

535307139_2021-03-189_35_42.png.e8057a3db5b375153501ac4c9b076498.png

 

Edited by shl628

Will tey that when i can do it, i have rebuild the usb drive woth same smbios settings and opencore now it pannics like 

i have de dsdt files for icelake and for set the values for hp in the config with propertree.

 

0516517F-BFE4-41CE-9D89-29F060FD9E89.jpeg

Posted (edited)

i hd that option on as well 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>LapicKernelPanic</key>
    <true/>
</dict>
</plist>
copied directly from my config.plist file



After some fiddeling with the config.plist in opencore configurator to set the CR2 fault adress it  now goes allot furhter in booting but it blocks at unsuported PCH 

service exited with abnormal code 1
Added boot hang picture

1B7D10A8-51B7-4995-AC8E-6E313978220F.jpeg

Edited by sojab0on0005
did the CR2 adress change hnags at unsuported PCH
Posted (edited)

Very strange 

After installing from usb it boot to the installer part where it estiamtes timed goes trough with that part but when I try to boot the next run from the m.2 ssd it panics 

and creates a kernel dump some where but where and how can I get that dump to see what is goon on 

Cant seen to find the reason, except for the aml files it spits contant errors with reading faults during boot 

Edited by sojab0on0005
Posted (edited)

I got it as far as booting to a apple logo but on every keystroke my screen flashes 

and the bar won't fill up 

any advise on where to look in the config

have attached current config plist without the Platform uuid and serials 

config.plist

Edited by sojab0on0005
attached most current Config.plist

EFI.zip

 

Here is an Open Core EFI that will boot Intel Skylake and 520 graphics laptop. 

 

You can modify for your hardware.

 

Itlwm.kext 1.2.0 works for intel 3165 wifi with Heliport.app in both Catalina and Big Sur.

 

You can add a hardware profile of choice to the config.plist.

 

Change the NVRAM csr-active-config to 67080000 for Big Sur updates.

 

Lapic is enabled in config.plist.

 

Look here for working configs:

https://github.com/topics/hackintosh?o=desc&s=updated

 

more:

https://github.com/1hbb/OpenIntelWireless-Factory/releases

 

 

 

 

I have it working to the point that audio is not coming up, as well as the SMbios settings are not pushed. 

 

I have heliport as tool to fix the wifi setup 

 

I ran this to check things like the guiide says for audio but I can't seen to find the ALC id 
 

kextstat | grep -E "AppleHDA|AppleALC|Lilu"

   42    8 0xffffff7f831a0000 0x2b000    0x2b000    as.vit9696.Lilu (1.4.7) 141DD55D-6559-32B6-8DBF-7DA82899F24C <8 6 5 3 2 1>

   48    0 0xffffff7f84099000 0x16e000   0x16e000   as.vit9696.AppleALC (1.5.8) 1A32BE2A-36E2-36F6-A16F-B8CDFE904F26 <42 13 8 6 5 3 2 1>

  133    1 0xffffff7f81ec8000 0x1d000    0x1d000    com.apple.driver.AppleHDAController (283.15) 18E9D42A-B1F4-3332-9D50-EAF28AF632E6 <132 113 89 13 8 7 6 5 3 1>

  145    0 0xffffff7f852fc000 0xe6000    0xe6000    com.apple.driver.AppleHDA (283.15) 0C7317DB-ED4E-395D-9517-6AEA788732BE <144 133 132 118 113 89 7 6 5 3 1>

I have also ran 
 

/gfxutil -f HDEF                                                     

zsh: no such file or directory: ./gfxutil

michel@Mac Downloads % cd gfxutil-1

michel@Mac gfxutil-1 % ./gfxutil -f HDEF

00:1f.3 8086:34c8 /PCI0@0/HDEF@1F,3 = PciRoot(0x0)/Pci(0x1F,0x3)

 

Based in the device ids its an Ice Lake-LP Smart Sound Technology Audio Controller but if I check windows under audio it states its Realtek HD audio 

 

If someone can point me to a ALC id or witch audio drivers in need that wil help me fix my audio I will post my Config plist maybe its mis configured bij OpenCore configurator taken out the generated serials and uuids 

 

 

config.plist

Here is some excerpted audio config information from the web that may help others:
 

 

Use AppleALC/AppleHDA , avoid VoodooHDA.

Use AppleALC with Open Core layoutid as opposed to boot argument ALCID.

 

Configuring your Audio Device

 

Audio devices are much simpler to configure than they used to be thanks to the development of AppleALC. AppleALC is a kernel extension that provides native Apple audio capabilites. To use it, the first thing you will need to know is what audio codec your laptop uses. If you don't already know, or if you're unsure, you can use a Linux live USB to do a codec dump. A codec dump provides a treasure trove of information about your device and the paths it uses to connect things like internal amplifiers to speakers or headphones.

 

Creating a Codec Dump

 

If you do need a codec dump for whatever reason, boot from your Linux live USB and find the nearest terminal or command line. The following command will display the details of your codec on screen with a pause so you can read it.

cat /proc/asound/card0/codec#0 | less

 

The first line should provide your codec. It will look something like this:

Codec: Realtek ALC294

 

If you would like to save the codec to a file so you can reference it again when you're back in macOS, cat it to a file instead and save the file to the boot partition of the USB drive, on another USB drive, or somewhere on your network.

cat /proc/asound/card0/codec#0 > /mnt/MyOtherUSBDrive/codec.txt

Now that you're familiar with your codec, let's install AppleALC.

 

AppleALC Prerequisites

 

If you're dual booting with Windows or Linux, you should enable the Devices/Audio/ResetHDA property which will reset the audio device on startup to flush any configuration .

 

Installing AppleALC

 

Installing AppleALC is simple. You just need to download the AppleALC kext from the project's release page and add the kext to OC/K. You can find it here. You may have it already if you installed it when making the USB. If you do add it, make sure to edit your config.plist

Download AppleALC @ Github

 

Your new AppleALC kext path should look like it does in the tree below.

 

EFI
└── OC
    └── Kexts
        └── AppleALC.kext

 

Before rebooting, let's configure it!

 

Configuring AppleALC

This is where things can get a little tricky, as just about every implementation of the same codec is different. Knowing your codec makes things somewhat easier as you can look it up in the AppleALC WIKI and find all of the layouts that could work with it.

AppleALC Supported Codecs

 

If you don't find your codec listed, you might find that it's just a rebranded version of another so it wouldn't hurt to search for "AppleALC {your codec}".

 

Once you have a list of layouts, but you don't know which is the right one you can test them one by one. Just configure the layout id in config.plist with your favorite plist editor and reboot. If audio works, congratulations! Otherwise, repeat until you've found it.

 

Open up your plist editor and the config.plist, then browse to DeviceProperties/Add and set the alc-layout-id parameter to your layout id. It should look something like this.

 

None of the Layout IDs Worked!

 

Well, you still have some options although none of them will be fun. The first option would be to take that codec dump that we made earlier and build a new layout for your device, or you could try using VoodooHDA instead. Let's talk about both options.

 

Creating a New Layout for AppleALC

 

This nets the best benefit for you and for everyone else because you'll end up with native support and others with the same device can use it too. It's the most difficult option though. Here's some documentation to help get you started.

HDA Fix - HaC Mini Hackintosh - by osy (Great guide on how to make your own HDA patches)

AppleALC: Adding Codec Support

 

Using VoodooHDA

 

VoodooHDA is an alternative to AppleALC, and it works pretty well but rather than adding native support, VoodooHDA provides its own audio solution. Installing it is pretty straightforward. Simply download the kext, preference pane, and settings loader and add them to your system. The kext goes in C/k/O, if you have AppleALC installed you'll want to remove it. Open (execute) the preferences pane and it should prompt you to install, if it doesn't drag it onto System Preferences and it'll install that way. The settings loader should be installed to Applications, and you should run it once to enable it. They can be downloaded here.

 

Download VoodooHDA @ SourceForge

 

As with AppleALC, it should follow the same pattern in the tree.

 

EFI
└── OC
    └── Kexts
        └── VoodooHDA.kext

 

 

 

Posted (edited)

tried this it detects the speakers but no audio output coming from them 

ALC295 Layout 3 

trying layout 24 as shown in the ALC295 config on GitHub still no audio from speakers 

 

at the point of giving up 

 

Edited by sojab0on0005
layout 24 does work either

Audio is working over internal speakers and external port now , but battery percentage and time remaining isn not 

 

Have ACPI battery management and SMC version tested 

ACPI doesn't detect the battery 
SMC gives errors about bit length or something 

 

After trying to get the smbios data corrected lilu suddenly broke

 

everytime i boot it states

lilu dev: @ failed to obtain model information Consrant and wont boot further.

do i really need to recreate a usb with a clean opencore or clover and the right kexts to inject and put up the right boot flags.

 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...