Jump to content

Realtek RTL8125 kext not working


16 posts in this topic

Recommended Posts

Hi, I,'ve been trying to install catalina on my pc(msi mpg gamig plus z490, cpu i7 10700k) an I can enter the installation menu with open core but I can' t get the lan running. As soon as the apple sign comes the ethernet light turns of. I just have a windows pc. I tried all the kexts I could find for this lan but none worked... what am I doing wrong? 

Show please exact name of your LAN card and its DeviceID. You can look into Windows Device Manager and look Compatible IDs.

You can also take Clover and upload here preboot.log obtained by F2.

Hi, the exact name of my LanCard is: 1x Realtek® RTL8125B 2.5G LAN. I used open core. you can find my efi in the attachments. I´v tried everything now. but I can´t come any further than the installation screen. 

 

Edited by El Gallo

Hi thanks for the help but I can´t even enter the system because it is not installed. And I can´t install it because you need a internet connection to install and therefore I need my Lan working. So no chance. I just got another PC here where I have only windows installed. The one I wanna make a hakintosh is nothing on. It is a newly build pc.

The problem I have with a full installer that my opencore says at the beginning that this plattform is not supportet with this mac osx version. Why is that? I used the iMac 20,1 and the iMac 20,2 to generate smbios...none of them works

 

Edited by El Gallo

That's already a progress! The NIC may be initialised anew later in the boot process, so for now we need to find out which of the many possible causes of the dreaded halt at EXITBS:START applies. Do you have an OpenCore log? If not, switch to the Debug version.

 

To change the SMBIOS, edit the config.plist, with matching MLB/Serial/UUID (which you should not leave in attachements).

Edited by etorix

Yes, but it's not obvious what the issue is, besides the boot-arg, which should read "-v debug=0x100 keepsyms=1" (in any order, and optionally with alcid=1). At this stage, OpenCore has handed over to OS X but the Darwin kernel is barely begnning to initialise.

Have you tried different settings?

Do you have the OpenCore log for this boot attempt?

No I don´t have it. I formated the stick again now. What settings should I try? I tried different versions of the iMac in the mbios. I can boot again and see if I can find the log file

Hi, I´ve found a solution for my problem!! In the install menu I had to go to the terminal tool and type in: ifconfig en0 media 1000baseT mediaopt full-duplex

 

then the lan connection startet to work

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...