Jump to content
zogthegreat

OpenCore - How to adjust boot options?

5 posts in this topic

Recommended Posts

Hi everyone! Happy New Year. I hope that 2021 is a better year for all of us!

 

So my adventures in learning OpenCore continues. I've managed to get my laptop to boot and run properly with OpenCore, although I still have some tweaking to do.

 

On of the things that I want to do is have a "clean boot" i.e. no boot options showing, just boot directly into Mac OS with out having the select boot options showing. My goal is to have a more Mac experience for the user, (my daughter in this case).

 

I've been reading the documentation found here:

 

https://github.com/nmano0006/Getting-Started-With-OpenCore-1

 

And I have managed to get the boot chime working, but I can't find any documentation on editing boot options. Can anyone point me in the right direction?

 

Thanks!

 

zog

Edited by zogthegreat
Share this post

If I understand correctly you do not wish to see the boot screen where you pick the options to boot from, if so then look in this section at the Timeout option and set it to 0. I think this will allow you to do what you want and just have it boot into the install.

 


<key>Boot</key>
        <dict>
            <key>ConsoleAttributes</key>
            <integer>0</integer>
            <key>HibernateMode</key>
            <string>None</string>
            <key>HideAuxiliary</key>
            <false/>
            <key>PickerAttributes</key>
            <integer>1</integer>
            <key>PickerAudioAssist</key>
            <false/>
            <key>PickerMode</key>
            <string>External</string>
            <key>PollAppleHotKeys</key>
            <false/>
            <key>ShowPicker</key>
            <true/>
            <key>TakeoffDelay</key>
            <integer>0</integer>
            <key>Timeout</key>
            <integer>5</integer>         <---------- change to 0
        </dict>

 

Or if you would like to see icons at that screen instead of text then it is the PickerMode, PickerAttributes and ShowPicker that need to be changed along with the image files being placed in the Resources directory like you see in my Boot section of the config.plist I show here.

Share this post

 

@MacUser2525, thanks for the advice. It didn't help, but it did start me on the right path. Sometimes, that's what you need in life! I managed to figure it out while trying to solve another problem. I'm having a message popup just before the OpenCore picker shows up:

 

opencore_2.jpg

 

I couldn't find anything in my config.plist so I ran it through a sanity checker:

 

https://opencore.slowgeek.com/?file=laptopbroadwell064XiMl6o&amp;rs=laptopbroadwell064

 

While going through it, I noticed the section "ShowPicker=Yes". I changed it to 'No" and now the laptop is booting like a genuine Mac! :)

 

Does anyone have any suggestions on the "No schema" error? I can't find anything in my config.plist and nothing comes up on the sanity checker.

 

@Hervé The Dortania guide is what I have been using for for my setup, with various Googling for things that aren't working like I want.

 

(EDIT) I just tried the "ocvalidate" that's found in the OpenCore-0.6.4-RELEASE\Utilities\ocvalidate and it also didn't return any errors.

Edited by zogthegreat
Share this post

  • 2 weeks later...

@zogthegreat No Schema Errors refer to missing, changed or removed entries in the config.

 

In this case. DeduplicateBootOrder was removed in Version 0.6.5. Just delete this line from your config and you're fine

 

Check the changelog you can find inside the Docs folder of the OpenCore Download if you come accross issues like this in the future and compare your config with the current sample using OCConfigCompare.

Edited by 5T33Z0
Share this post

×