Jump to content

Ryzen with B450 board, USB 3.1 ports missing and no USB audio in some ports


3 posts in this topic

Recommended Posts

Hi everyone, first post here, long time lurker.

 

osX version: 10.13.6 running with opencore 0.6.3

MB: Gigabyte B450 aorus M

CPU: AMD ryzen 7 3700x

graphics: Nvidia GTX1070

 

USB 3.1 ports are nowhere to be seen in my new hackintosh, even after resetting RHUB, port mapping etc. Additionally USB ports connected to the CPU I/O USB (shown as Matisse USB 3.0 Host Controller in DPCImanager) don’t work with audio over USB, only KB/mouse and 2.0 speed storage.

 

Basically every 3.1 port shows only as 2.0 in IORegistryExplorer , plus USB 3.1 ports in the CPU I/O behave weirdly. Everything else, works fine, even sleep.

 

Can't upgrade osX version because I need CUDA for work.

 

Any help appreciated.

Thanks for the tip but I'vs already tried and it doesn't work. Let me explain the problem a little better.

 

The motherboard has two USB controllers, the board chipset which has a bunch of ports (6x2.0, 2x3.0 and 2x3.1) and the CPU I/O (4x3.1). None of the 3.1 ports are working at 3.0 speed, they only appear as 2.0 ports in High Sierra. I don't care too much about it because I have 2 ports working at actual 3.0 speeds. My problem is that audio over USB does not work in the CPU I/O USB ports.

 

Along with the computer I bought a new audio interface and I can not make it work in osX. For some weird reason the audio interface refuses to be detected in any of the chipset USB ports, it only gets detected when plugged into the CPU I/O ports. The same exact thing happens in Windows so that is a dead end. In osX when I plug it to the CPU I/O ports, the audio interface gets connected, I can play around with it using its software but there's no sound (the console shows a bunch of errors). Thing is, my old audio interface also fails to work if I plug it to the CPU I/O ports, although it works without any problem in any of the chipset USB ports, including the two 3.1 ports working as 2.0.

 

As I've just mentioned, the motherboard only has 2 usb controllers: the chipset is named PTXH in the DSDT and the CPU I/O is named XCH0. The DSDT is a little messed up, every single USB port is listed as either type 3 or 10 (there are no type c ports in the motherboard). PTXH has 22 ports (which apparently is pretty common in B450 motherboards), although there's only 14 actual ports in the MB (counting 3.x ports as HS and SS), and XHC0 has 8 ports (4x2 so that's correct). The USB ports themselves are not named HSXX or SSXX: they are POTx and PTxx in the PTXH controller and PRTx in XHC0. System report show both buses as USB316bus, and all 6 USB 3.1 ports are missing. IORegistryExplorer shows 12 ports in PTXH and 4 ports in XHC0.

 

I've spent quite a lot of time searching all over the web and trying any possible solution I could find, but none works:
- USB port mapping does not work (tried various guides)
- SSDT stuff like changing USB port names, resetting RHUB, fixes like XHC1 to SHCI or modifying SSDT-EC/USBX did not help.
- Neither algrey's ryzen USB patch or USB 10.13.6+ by PMHeart patch work.
- No USB related kext worked, USBinjectall etc (I know they are mostly meant for Intel CPUs but I tried anyway out of desperation)
- Even swapped some kexts from /System/Library/Extensions/ for older versions without any luck.

 

So far I haven't even been able to make the 3.1 ports show on IORegistryExplorer. Furthermore, I've noticed that I get the following messages in the verbose log:

 

kernel: (AppleUSBXHCIPCI) 000001.902954 XHC0@60000000: AppleUSBXHCIPCI::createPort: port 5 unsupported protocol USB  3.10
kernel: (AppleUSBXHCIPCI) 000001.912508 XHC0@60000000: AppleUSBXHCIPCI::createPort: port 6 unsupported protocol USB  3.10
kernel: (AppleUSBXHCIPCI) 000001.913016 XHC0@60000000: AppleUSBXHCIPCI::createPort: port 7 unsupported protocol USB  3.10
kernel: (AppleUSBXHCIPCI) 000001.913505 XHC0@60000000: AppleUSBXHCIPCI::createPort: port 8 unsupported protocol USB  3.10
kernel: (AppleUSBXHCIPCI) 000001.958819 PTXH@00000000: AppleUSBXHCIPCI::createPort: port 1 unsupported protocol USB  3.10
kernel: (AppleUSBXHCIPCI) 000001.959762 PTXH@00000000: AppleUSBXHCIPCI::createPort: port 2 unsupported protocol USB  3.10


I think the problem comes from the Matisse USB Host controller inside the Ryzen CPU, I'm referring to the USB audio not working, although I suspect both issues are related. If I was able to make audio work over the CPU USB ports I would be happy enough even without them working as 3.0.


I've seen people complaining about similar issues but no one with the same symptoms, it is a weirdly specific problem. Some people having trouble with USB 3 in High Sierra solved it by upgrading to Mojave or Catalina. Unfortunately, I'm stuck with High Sierra unless Apple decides to become friends with Nvidia again.

 

If anyone has the same mobo please try to confirm that USB 3.1 ports are nowhere to be seen an that XHC0 has issues with USB audio.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...