Jump to content

Can't use USB Mouse or Keyboard in Big Sur Installer


17 posts in this topic

Recommended Posts

Hi, I'm currently trying to install Big Sur on my Dell Precision M4800 laptop with an i7-4600M. I'm following the dortitania guide at https://dortania.github.io/OpenCore-Install-Guide/, and the installer boots to the GUI just fine, but I can't proceed with the installation because I can't move the mouse or use the keyboard at all. Any ideas?

Here are my kexts:

IntelMausi.kext

AirportItlwm.kext

AppleALC.kext

IntelBluetoothFirmware.kext

IntelBluetoothInjector.kext

Lilu.kext

SMCDellSensors.kext

SMCProcessor.kext

SMCSuperIO.kext

USBInjectAll.kext

VirtualSMC.kext

VoodooPS2Controller.kext

WhateverGreen.kext

XHCI-unsupported.kext (it's in the folder but I took it out of config.plist to see if it made a difference)

config.plist

I tried using the DrHurt kext just now, removing the old VoodooPS2Controller kext, and got a "Dependency com.apple.iokit.IOHIDSystem fallback to com.apple.iokit.IOHIDFamily succeeded. Please fix your kext!" error during early boot, I tried using one of the USB HID patches from the guide that was meant for machines older than mine, but it didn't work, so I'm first going to try and revert that patch, and then I'm going to check if it happened with the other kext.

Also: I got that error twice.

The DrHurt kext seemed to be what was creating that error, and also keep in mind the system still boots fine with it, just figured it might've been an error that was the source of the problem.

I'd also like to mention that it's not just the trackpad that doesn't work. The keyboard doesn't work either and plugging in a usb mouse doesn't even light up and pressing numlock and capslock on the keyboard doesn't enact a response.

Additionally, I got a version mismatch error with ProperTree when doing an OC Snapshot and don't know what it means. Not sure if it's related or not.

mismatch.PNG

@limurphy, these are indeed for the OC Picker, not macOS. These are hardly ever required on systems operating in UEFI mode. I've only ever needed those on systems operating in Legacy mode.

 

@person4268, all I'd expect you to need in terms of drivers would be HfsPlus.efi + OpenRutime.efi (that's all I've needed on my Dell laptops (Ivy Bridge Latitude E6230 + Kaby Lake R Latitude 7490). AudioDxe required if you want the boot chime. I'd get rid of all those Keyboard/Mouse drivers.

 

With regards to absence of keyboard/mouse/touchpad in macOS, I can't understand why the kexts that worked for other M4800 owners in previous macOS versions would not work in Big Sur. Makes no sense at all...

 

All I can say about your OC config is that:

  1. you inject an incorrect and unknown Type property to your iGPU device. The correct injection would be:
    • device_type    String     Display controller
  2. your SMBIOS Info is incomplete. You've clearly not followed Dortania's guide on this matter and used the generator tool (or Clover Configurator to that effect) to copy/paste the required data...
  3. most importantly, I'm not sure about that prev-lang:kbd NVRAM parameter being set to DATA with a value of 656E2D55 533A30. Try and revert to default String type and value en-US:0 to begin with.

 

Can't see how the 1st 2 would affect the input devices of your Hack but the 3rd one may definitely play a part...

1. I think I misunderstood the guide on the first one, don't think an invalid property would cause much but I'll remove it.

2. Maybe I just badly censored it? I did use the guide for everything, and deviated from it minimally.  I was trying to quickly censor the serial numbers like it said in the pinned post, which I quickly did in notepad. I'll double check with the guide when I have time. Maybe making it look like I left values at their default was a bad idea.

3. I'll test this out when I have time, in about 3 hours.

What should I look for? I'm using all of the ACPI stuff recommended for Haswell laptops in the guide except for the I2C stuff because I know for sure that I don't have an I2C trackpad and tried using SSDTTime with no success. Currently searching around for stuff involving USBInjectAll not working but can only seem to find things where USB3 doesn't work or some ports don't work. Is there a way to log kernel output from the install usb?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...