Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
ankarastrix

Big Sur wake/sleep problem

3 posts in this topic

Recommended Posts

I have a problem, I select the "sleep" option from the menu, the mac goes to sleep but does not "wake up" (screen). I can't even change smbios from iMac17.1 to iMac18.1 + when I change the mac it boots, the progress bar and apple icon are visible and then the screen goes off.

config.plist

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ltooz_audis
      This is how I boot Big Sur on HP M7-J120DX 17" i7-4700MQ HD4600 Haswell Laptop using OpenCore 0.6.4
       
       
      Cheers,
      Louis
    • By ltooz_audis
      How I create EFI folder that works with all laptops and PCs on Big Sur using OpenCore 0.6.4.
       
      Cheers,
      Louis
    • By ltooz_audis
      This is how I installed and fixed my DW1820a (BCM94350) Wifi and Bluetooth Combo in my HP EliteBook 820 G3
       
      Cheers,
      Louis
    • By Enckyridion
      Hello. Is any Qualcomm Atheros AR8152 PCI-E Fast Ethernet Controller (NDIS 6.30) kext working on this new version of Big Sur? If so, could you help me? I've been looking for days and everyone I test doesn't work. Thank you.
    • By blazinsmokey
      I've written some detailed guide in my time but I'm going to keep this one shorter. I want to accomplish 2 things with this write up.
      1. Address the native nvram problem, this is huge for people with similar hardware moving forward with Big Sur.
      2. Help others get installed and booted with a very clean setup.

      Hardware and Overview
      ASUS Maximus VII Hero Z97, 4790K, Sapphire Nitro+ RX 580 8GB, HDMI to 43" 4K screen.
       
      Modifying the BIOS to get native nvram fix for Big Sur is also confirmed working for these boards
      ASUS Z97 ROG Maximus VII Hero ASUS Z97-A, requires manual modifying of BIOS file ASUS Z97-P ASUS Z97 ROG Maximus VII Gene ASUS Z97 ROG Maximus VII Ranger ASUS Z97 ROG Maximus VII Impact ASUS Z97 ROG Maximus VII Formula ASUS H97M-E ASUS Z97-PRO(Wi-Fi ac)  
      This included setup was used to upgrade directly to from Catalina to Big Sur but installation should be fine as well.

      Using OpenCore 0.6.3 and latest kexts. Using SMBIOS iMacPro1,1 even tho it may be frowned upon but it worked for DRM at least in Catalina, not willing to change it now. You can however do as you please.

      Everything pretty much works. FaceTime, Messages, AppStore etc. Waking the computer from sleep though requires pressing the PWR button.

      There is no options in OpenCore or Clover, drivers or magic to get native nvram working. You have to modify the BIOS or flash an old one that doesn't have the white list as discussed below. So if you can't go through with fixing the NVRAM, you will have to use the transplant method.

      NVRAM Problem
      Big Sur installer fails after about 20% progress in the Apple logo, fails shortly after disk#: device is write locked ending with apfs_vfsop_unmount. Verbose output below just before restart. I imagine a new install the same problem occurs because after the first state information on the drive and whatever is stored in the native nvram and the installer can't access something that is not there because it wasn't saved in the first place.


      Background
      Reddit post here starts to question it as Haswell in general but seemed more an issue with ASUS Z97 boards. A comment in that thread led me to Vit9696 saying fix your NVRAM. All other paths led to devs are aware and it's an macOS bug or giving up and transplanting the installation by using another machine. Well I ain't having none of that, Vit9696 said fix nvram, so I fixed it.

      Why
      Vit9696 actually solved this for us years ago here. The key take away is the whitelist part and replacing NvramSmi driver.
      Fix
      As stated above we can extract the NvramSmi driver from an older BIOS and the replace it in the latest one. I believe most our boards from this era are no longer being supported but the latest firmwares do have microcode to patch vulnerabilities like Spectre, meltdown, etc. It would be ideal to go this route and it's not that hard and working nvram is great!

      I'm guessing another way would be to flash back to old BIOS where native nvram is working and upgrade/install Big Sur and then flash the latest after. You could save your BIOS profile if available that way you won't have to set everything back up. If this is also the case for incremental updates, sounds like a nightmare.

      How (I chose to fix)

      Replacing the NvramSmi driver made the most sense and it was relatively easy. I am no expert and you know the responsibility I take in anyone trying this **** and failing, ZERO.

      To find a BIOS version before the whitelist was added to the NvramSmi driver I used the dates from the link in Vit9696's quotes. User 314TeR said his ASUS Maximus VII Impact nvram broke after 0412 which was released 2014/10/17 and worked with 0217 released 2017/07/28. To me anything after 2014/10/17 will have added the whitelist.

      So with my board I downloaded version 1104.

      Download UEFITool 0.26.0 as the latest versions won't let you rebuild/replace.

      Download latest BIOS and one without whitelist.

      Load older BIOS in UEFI tool, my case 1104. Search with text nvramsmi and extract as is, the file section. Like below. Save the ffs, name it whatever and close out we are done here.



      Load the latest BIOS now, 3503 in my case and search nvramsmi again. This time replace as is and select the ffs you just named and saved.


       
      You can't flash the modified BIOS as usual, they are contained in a way with write security. I just used my board's USB Flashback Utility. Named the modified BIOS to M7H.CAP, each board will have it's own naming method. Copied to a fat32 usb, stuck it in the correct USB port in the back and pressed the button for 3 seconds. 2 minutes later and I was booting my modified BIOS and restarted the upgrade process again from within macOS.
       
      That last bit is IMPORTANT, if you were trying to upgrade from Catalina and have the bootable option to install MacOS it still won't work after you fixed your nvram. You MUST restart the process again from within Catalina. 
      If you don't have USB Flashback Utility, take a look here for alternative ways.

      After BIOS modified flash test your nvram, mine worked right away. Then I tried the upgrade and that worked fine. I believe it was 4 phases total and 3 reboots. Took about 25 minutes on SSD.

      My modified BIOS 3503 is attached, don't be stupid with it and try to install on a different board. Rename it accordingly if you want to use it.

      Some BIOS Settings
      AHCI - Enabled
      VTD - Disabled
      Primary Display - Auto
      CPU Graphics Multi Monitor - Disabled
      Legacy USB - Enabled
      xHCI - Enabled
      EHCI handoff - Enabled
      Fast Boot - Disabled
      Secure Boot - Other OS
      CSM - Disabled

      OpenCore Configuration Basic Understanding
      ACPI SSDT-EC.aml - fix for EC on Catalina and above SSDT-GPRW.aml - fixes immediate wake from sleep, paired with rename patch in plist SSDT-LPCB.aml - allows AppleLPC to be loaded, helps with power management SSDT-PLUG.aml - necessary for CPU identification and power management SSDT-SBUS-MCHC.aml - allows AppleSMBusPCI/Family/Controller SSDT-USBX.aml - USB power config Drivers AudioDxe.efi - boot chime HfsPlus.efi - reading Hfs partitions OpenCanopy.efi - GUI boot picker OpenRuntime.efi - NVRAM, memory management, etc Kexts AppleALC.kext - audio IntelMausiEthernet.kext - nic Lilu - various fixes and system enhancements USBPorts.kext - USB Mapping (you can edit this details in USB section) VirtuaSMC.kext - Apple SMC emulator WhateverGreen.kext - various fixes for graphics and system devices Resources download from binary resources, removed all audio except boot chime Tools OpenShell.efi - shell cli config.plist Highly suggest looking at the Dortania Guide Haswell section if you are want to know why x is set the way it is, I don't have time for that and that information is readily available USB Ports
      If all accessible ports are enabled in our system it is going to break the 15 port limit so a single sacrifice needs to be made. Instead of wiping out a whole port, I personally removed USB 2.0 ability on one of the USB 3 ports.

      The included USBPorts.kext includes all 16 ports, so the last USB 3.0 port SSP6 port(furthest from ethernet) will not function at 3.0 speeds if you use this kext as is. Customizing is simple with the kext. Open the plist inside the kext and you can remove the one port/functionality you don't need. Included are pictures labeling what is what HSXX and SSPX. There's also a SSDT included to help identify.

      Shout out to @YoshiMac for posting images of the USB ports mapped out. I included some of his work so you have quick access when deciding but his post is great as well. Hopefully I can return the favor a bit with this guide.

      OpenCore Config Customize
      While I added a SMBIOS just to get you going, you need to get your own SMBIOS - > https://dortania.github.io/OpenCore-Install-Guide/config.plist/haswell.html#platforminfo I'm using UIScale 2 for HiDPI, where as you may need to change to 1 Boot args currently uses verbose, you can remove that if all is well after I'm sure I'm forgetting to mention stuff, just let me know if I should warn about some other stuff here. Files Attached
      The included EFI is OpenCore 0.6.3 with updated kexts as of 11/18/2020

      USB Folder includes pics of the mapping and original USBPorts.kext with 16 ports for back up. There is also .dsl file which maps the ports if you need some clarification textually, do not use it.

      Modified 3503 bios for Maximus VII Hero with replaced NvramSmi from 1104.

      Well that wraps it up I think. If you need any extra advice or questions shoot away.
       
      Asus Maximus VII Hero OC 0.6.3 Share.zip
       
      BIOS in next post due to size limit
       
      Modified 3503 bios for Maximus VII Hero with replaced NvramSmi from 1104.
      3503modifiedM7H.CAP
×