Jump to content
Dirk_Digler

SOLVED: Is Mojave possible on Xeon X5450 LGA 771

7 posts in this topic

Recommended Posts

Hi all. Is Mojave possible on Dual Xeon X5450? I know one has to replace event plugin and ideally have Kepler card, but I've been struggling for months now unsuccessfully to upgrade from Hi Sierra to Mojave on a Dell Precision T5400.

 

I'm just wondering now if its the end of the line for this old workstation and Hi Sierra is the limit. 

 

Has anyone here managed to get Mojave (or even Catalina) running on LGA 771? Is it possible? If so can you give me any details of what is needed please?

 

Thanks 

 

Share this post


Link to post
Share on other sites
Advertisement

No reason why it wouldn't. Like many other people, I've got Mojave (and Catalina) running on my WolfDale C2D (E8600) platform. Make sure you use a suitable SMBIOS (eg: iMac13,2).

Share this post


Link to post
Share on other sites

Hervé

 

Thank you so much for your quick reply, I've been on this for weeks and weeks, literally pulling my hair out and at 68 I aint got much left :)

 

It's almost there, it's on the final restart where it get to the point at "setting your Mac up" to create the user account but I get a mouse pointer in the top LH side of the screen then it panics and reboots. I think the install is good because if I take the hard drive out and place it in the Vostro 260 it will complete install and boot to the desktop, just not in the Dell T5400. If I boot with -v and tell it to stay put on panick the last thing I see is the screen shot below. SMBIOS is set to iMac 14.2 . There must be a kext or a setting I haven't set/used but I'm flying blind by the seat of my pants at this stage clueless now, literally clutching at straws.

 

49 minutes ago, Hervé said:

I've got Mojave (and Catalina) running on my WolfDale C2D (E8600) platform

 

Yes I have been over to other forum where you have a Vostro 200 with Mojave and Catalina installed, even downloaded the folder but didn't see anything I'm not using apart from the PS2 kext as I have it turned off in the bios. I started with this T5400 on SL and it has gone through all the versions of OSX pretty well. Its currently running High Sierra very well apart from it doesn't always turn off at shutdown - it sometimes (not always) reboots. I've never got to the bottom that either. All my stuff and emails etc are on this T5400 hence why I'd like to stay with it if at all possible. I have replaced the user event plugin from the one on HS, I also saw an error that says "invalid PCIE MMIO" so something isn't right.1983679085_Mojavelasterror.thumb.png.a5726be29f9607b9e6f5ff94a9bbf931.png

 

Again many thanks for taking the time to reply, but if you could just take a look at the screen shot and pass comment on what you think may be the issue I'd be very grateful.

 

Share this post


Link to post
Share on other sites

You definitely have a Kepler card for sure but it looks like graphics are not initialising. It would also appear you have a GT740 and I'm aware of issues with this GK107 model... Post your zipped Clover EFI folder if you need further assistance and do specify if you just inject kexts through Clover or cache them from /S/L/E and/or from /L/E. What video output port are you using?

Edited by Hervé

Share this post


Link to post
Share on other sites

Yes I have a GT740 card in there, but it works OK on the other 2 machines with Mojave, and I also in the past have fitted a Quadro K600 card (also Kepler) but had exactly the same results. If I take a working drive out of the Vostro 260 and look at the folders the structure of the folders is the same *except* that I don't have a user account set up yet as it hangs when it gets to the setup screen. But I notice that the installation in question does not have an APPLE folder in the EFI folder whereas the other one does (see attached screen shot). Whether or not this has any bearing on the issue I don't know as I'm now chasing my tail in circles. You will likely see mistakes now in the clover folder where stuff shouldn't be as I'm in too deep for myself. It seems I'm close but no cigar........ The bios version is A11 the last available for this machine.

 

I have ziped up the clover folder as you requested and attached same for your inspection and comments.

 

 

 

 

1089917292_foldercomparison.thumb.png.3313ee14801fe048990e85233b148678.png

 

 

You'll also see a DSDT file in the patched folder, I don't know why but I have *never* been able to boot this PC without a DSDT in the patched folder. Many years ago I edited this file to fix the cmos reset issue when I first started with 10.6.8, where this has been corrupted or not along the way I do not know, and being honest with you now have 'lost too many grey cells' to attempt to try and inspect it :worried_anim:. So that might be worth taking a quick look at see if theres anything there that shouldn't be that could be causing the issue.

 

 

*NOTE*

You 'may' see references in the attached ziped folder that came from a site that is "not to be mentioned/discussed here". Up until now this has been my only source for installation material as after years of struggling on my own I have only just started asking for help so please excuse this. I mention this because of the rules, and do not wish to be penalised so soon.

 

 

Again my thanks for your time 

EFI.zip

3 hours ago, Hervé said:

do specify if you just inject kexts through Clover or cache them from /S/L/E and/or from /L/E. What video output port are you using?

 

 

Sorry forget about this....

 

Only one kext in kext/other and that is fakesmc, I believe the rest are in /L/E

The graphics card has 3 ports, DVI/VGA/HDMI. I normally use the DVI port but I've tried all 3 with same results 

 

 

Screen Shot 2020-02-15 at 13.07.28.png

Edited by Dirk_Digler
added screen shot of /L/E

Share this post


Link to post
Share on other sites

Well a bit more info. I took out the GT740 from PCIE slot 4 and replaced it with a Quadro K600 and put it in PCIE slot 1. I had exactly the same results. Unfortunately they both have the same die - GK107 and I don't have another Kepler or supported card to try.

 

I have a GT120 (PC version) albeit it'll have no acceleration I guess, don't know if it will boot with that it, Is that worth a try you think?

 

If I take the hard drive out of the Vostro 260 which has a good working Mojave system on it and place it in the T5400 it does the same thing - just reboots.  :wallbash:

 

Attached below is the output from PCI devices screen shot. Don't know if that will through any light on it.

 

1700051841_ScreenShot2020-02-16at00_56_03.thumb.png.5c9698b771b0b904212537973777bc92.png

 

Thanks again

 

Share this post


Link to post
Share on other sites

SOLVED: Confirmed now working on LGA771 - 2 x Xeon X5450: Dell T5400: NVIDIA GT740: SM bios iMac 10.1

 I have this working well on external USB 2 and I have to thank mald0n for this  :thanks_speechbubble: :guitar:

 

Not 100% sure I have it exactly right as its slightly different, and I still think my DSDT could do with sorting but it now boots up all the way after some tinkering, and its running well so far.

 

This has been a real PINTA for me as Ive struggled with this for a very long time without success. So glad its up and running.:thumbsup_anim:

 

Its not exactly a flying machine but at 68, time goes so FAST for me now anyway :hysterical:

 

 

n182989182_Screenshot2020-02-19at14_55_25.png.60d4643755ca6f458ddcbf545c0e85f6.png

 

 

https://www.olarila.com/topic/5676-folders-for-all-chipsets-clover-and-opencore/

 

417153511_Screenshot2020-02-19at15_15_58.png.4b2bffb4ba1928ad675b273bcdd47f81.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×