Jump to content
Krani93

Stuck on Attempting System Restart.. MACH Reboot |Opencore OSX Catalina

6 posts in this topic

Recommended Posts

Hi guys,

 

I'm trying to install Catalina on a Lenovo m720q (i5-8600T with B360).

After some other issues I'm know stuck at attached screen.

Im using latest opencore version and have my EFI folder attached.

 

Can someone help me I've got no clue what to try next :/ 

 

 

Cheers!

IMG_7077.jpg

EFI.7z

Share this post


Link to post
Share on other sites
Advertisement

I've checked your EFI folder. It seems like you have left the legacy drivers in that folder.

Also, there's a shell.efi file there which seems unnecessary.

Try removing those and check.

Share this post


Link to post
Share on other sites
18 hours ago, SniperBuddy said:

I've checked your EFI folder. It seems like you have left the legacy drivers in that folder.

Also, there's a shell.efi file there which seems unnecessary.

Try removing those and check.

Thanks! I've removed NvmExpressDxe.efi, AppleUsbKbDxe.efi and XhciDxe.efi and deleted shell.efi. still same message though.. any other idea?

Share this post


Link to post
Share on other sites

yes, I have, system is a tiny form factor desktop pc though not laptop 

Edited by Krani93

Share this post


Link to post
Share on other sites

I also faced this problem. Solved this by following the Intel Framebuffer patching present here - https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.IntelHD.en.md

 

You can swap the 0xXXXXX code into ProperTree's data form by using this tool - https://www.scadacore.com/tools/programming-calculators/online-hex-converter/

 Make sure to use the DCBA version.

Edited by SniperBuddy
Updated HEX swapping site.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DI2edd
      Hi,
       
      I'm writing from a Catalina QEMU/KVM VM which, I must say, works pretty damn well besides the fact that rebooting just doesn't work. But first, a bit of background:
      I'm using OpenCore 0.5.5 through DuetPkg because I'm forced on SeaBIOS (legacy boot) because of legacy IGD passthrough (OVMF doesn't support the semi-hack that's needed for it to function), and that works well enough; I switched from Clover because it didn't allow me to use the "host" cpu model on QEMU, which OpenCore did, and so far so good.
       
      The problem is that, whenever i attempt a reboot, the screen would just turn black and thats's it. I can even see that every 30 seconds it polls the battery's status through ACPI (I modified QEMU for that and left some debugging printfs).
      On the other hand, shutting down works as expected. One thing I noticed is that, on shutdown, I can see the last line of verbose output on the screen is "CPU_HALTED", whereas on reboot I don't get that (don't even know if that's to be expected).
       
      The point is that I'm not even sure this is a bootloader issue, because I booted a Fedora live ISO through OpenCore, and that rebooted with no problems, but at the same time I remember that with Clover I didn't have such an issue. Perhaps it was one of Clover's "Fixes" that is not automatic with OpenCore?
       
      Anyway, I attached my config.plist.
       
      Thank you.
      config.plist
    • By fercho3138
      Hi!
      So I've successfully built my rig and installed Mac os
      Gigabyte Aorus Z390 Pro Wifi Intel Core i7 9700k Ballistix Sport 32gb Samsung evo 500gb nv Sapphire Radeon RX 580 Pulse Corsair h60 The thing is that I got it running perfectly, even performed some heavy video renderings with no problem but sometimes it just restarts on its own, sometimes when I'm using Chrome, sometimes when I'm editing or whatever other task. Last time it happened I got the forbidden sign on the screen so I tried to boot up again using the -v flag and I got the "Couldn't allocate runtime area" message, which is very strange because I had no problems in booting up the system after I made my configurations in the config.plist

      Please someone give me some help with this problem, I'm completly stucked!!
      config.plist
    • By SniperBuddy
      Hello guys,
      I'm relatively new to the world of hackintosh.
      I'm trying to install the latest Mac OS - Catalina with the help of Opencore, however, this is the error that's displayed while booting from the USB:
       
      https://drive.google.com/open?id=1Xd4V2wZ2fEsgRyfVcXlJHXMPGa85g2s3
       
      You can take a look at my config.plist file from here - https://drive.google.com/file/d/17FZpTcVp4RFSaxdm6yW4uELkt7MaLdmt/view?usp=sharing
       
      I'm using the Acer E575 G laptop with Kabylake (i5 7200u)
       
      Any help would be gladly appreciated!
       
      Edit: I've fixed this problem by following this guide completely - https://khronokernel-2.gitbook.io/opencore-vanilla-desktop-guide/intel-config.plist/kaby-lake
       
      This is due to OpenCore being unable to find any drives with the current ScanPolicy, setting to 0 will allow all boot options to be shown
       
       
       
       
       
       
       
    • By DanZiRuleZ
      Dear All, 
       
      trying to install Catalina on my ASUS Z87 Plus, I followed the Haswell guide to the letter, all set up now, USB stick boots ok, Catalina installs on SSD, but then when trying to boot it I am receiving Kernel Panic and no idea how to move forward. 
       
      Have the debug options, but opencore will only dump boot messages where I don't see much sticking out.
       
      My last resort would be just installing clover on the already installed SSD's EFI partition, it at all possible. High Sierra is working fine and I did get Clover with Mojave once but stuck with High Sierra with my GTX960 video card...
       
      Attached is the kernel panic and my EFI setup if anyone can help me troubleshoot.
      Many thanks
      D.
       

      EFI.zip
    • By n.d.k
      After several weeks of testing OC bootloader,  disecting its source code and also Clover's source code as well, I finally switch from Clover to OC as my main bootloader. Wait! don't get the wrong idea that OpenCore is better than Clover. They both work equally well, producing a bootable macOS as an end result with simliar boot time. OC design direction is different with Clover, I believe it's not intended as a Clover replacement, but more narrowing down to macOS specifically. However, macOS is not the only OS that i am using, so, i decided to add some minimal necessary source code modification to the OC to get some of the features I need. I like to share my customized OC forked https://github.com/n-d-k/OpenCorePkg , you have to compile it yourself if you want, i will not provide pre build binary.    
       
      Additional features/changes:
      ============
       
      [ Multi-Boot ]
        - ACPI patches are optional for non macOS with setting ACPI->Quirks->EnableForAll to yes (default is no).
        - Booter Quirtks, SMBIOS and Device Properties patches will only applied to macOS.
          
      [ Hotkeys ]
        - Full functional Hotkeys [1-9] corresponding to Boot Entry's Index number and dedicated W (Windows) / X (macOS) keys can be used without seeing Boot Picker.
        - While in boot picker, F10 can use to take a snapshot of the screen.
                
      [ Ui Boot Picker ]
        - Bios Date/time, auto boot to the same OS or manual set to always boot one OS mode, and OC version are displayed in boot picker.
        - Auto boot to previous booted OS (if Misc->Security->AllowSetDefault is NO/false).
        - macOS Recovery/Tools Entries are hidden by default, use Spacebar in Boot Menu as a toggle on/off to show/hide hidden entries.
                
      [ Custom Entries ]
         - Custom entries are now listed first in picker menu and by the orders they are appeared in Misc->Boot->Entries, before all other entries.
         - Ability to change entry name found by auto scanner by adding custom entry with the exact same device path,
           this will give users the option to complete change how all boot entries listed in Boot Picker.
          
      [ Others ]
         - No verbose apfs.efi driver loading (if using apfs.efi instead of ApfsDriverLoader.efi).
          - ndk-macbuild.tool script are set to compile with latest edk2 (One can easily set to stable edk2 if prefer).
          - NvmExpressDxe driver build script are also available for system without native nvme support. (Compatible with OC and Clover).
       
      Usage:
       - To build OpenCore, run "./ndk-macbuild.tool" at Terminal (require Xcode and Xcode Command Line Tool installed, and open xcode to accept license agreement before compiling).
       - To build NvmExpressDxe driver, run "./buildnvme.sh".
       
      4k screen resolutions

       
       

       
      Customized by @btwise

       
       
       
×