Jump to content
Ragimund (HP Z820)

Mojave 10.14.6 Update (2019-001) starts update install but reboots after a while, install fails.

3 posts in this topic

Recommended Posts

Hi All,

Noob here asking Help or Hints,

trying to build my first Hackintosh from HP Z820. Almost done...

 

Read Z820 Sierra & High Sierra Z820 installation guides in this forum - following them I managed to create a Booting Mojave install USB and successful

installation of Mojave 10.14.6 in to SSD. Via Clover Boot view I can choose Mojave SSD and it boots Ok, logging in Ok.

 

Everything "looks" to work Ok.

-CPU recognised Ok.

-SSD & HDU Ok.

-GPU Radeon RX580, 2 x DP in use.

-Dual displays Ok (Full HD, no internal speakers)

-Wired LAN working (2 Wired LAN RJ-45 connectors, using the one without text label "AMT" (?))

-No Wifi (no dongle)

-Audio working: line out & headphones, airplay (ALC262, injected 28) Ok.

-Bluetooth dongle (Ebay) in USB2.0 port Ok (paired BT Speaker, Keyboard and Mouse).

-Front: 1 x USB2.0, 2 x USB3.0 (all as USB2.0 mode, I think).

-Back: 4 x USB2.0, 2 x USB3.0 (all as USB2.0 mode, I think).

-Back: Firewire OK/NOK ? Don't own any fw device at the moment, how to test, not important now.

 

Not yet signed to any Apple service, iCloud, etc. Not yet installed any other software except Clover 5098 and Hackintools 2.8.6

 

MY PROBLEM:

System Preferences is showing Update, Mojave 2019-001 (1.55GB). Safari was updated Ok with another smaller update.

I try to install the Mojave Update. It downloads it Ok, warns about needed Restart and after accept it starts to install it.

Apple logo visible, progress bar visible, text "Installing Software Update" visible. Progress bar shows a minor progress - stays almost in the beginning...

and Wham! - Rebooting :(

 

Logging in Ok, System Update window pops open and offers the same update again...

 

Have read plenty of articles from different Forums (sorry, I'm desperate, Noob) and I have a feeling that it relates to my Z820 USB's (maybe??).

HP Z820 uses "Texas Instruments USB3.0 xHCI Host Controller" - NOT Intel like Apple. That's why All my USB are in "usb2.0 mode" (??).

 

I installed the system with SSD/HDU cables in factory settings (in SAS/SATA connectors. AstekFusion2Adapter & AstekFusion2Family kexts), worked fine.

I changed the SSD/HDU cables to different connectors (ACHI 0 / 1) like in Z820 High Sierra guide later and Booted Ok. Tried Update, FAIL.

 

Have no idea what's wrong or what's causing this - like I said, I'm a Noob and trying to build my first Hackintosh...

 

Can anyone Help Noob ?

 

 

 

Share this post


Link to post
Share on other sites
Advertisement

The process you describe is perfectly normal. What you seem to ignore is that, once system restarts, you're supposed to reboot the "install macOS from ..." partition at Clover's main menu. It's been like that since High Sierra...

 

If you reboot the actual Mojave partition, the update will never complete and you'll just be back where you started from.

 

Edited by Hervé

Share this post


Link to post
Share on other sites

Hi, Thanks.

 

I chose the "Boot macOS Install from Mojave SSD" (there was 5 choices), it started to install, screen went grey and looked like it installs Mojave again (thought I messed again :D ) and rebooted near the end, still same menu in Clover, took it again (2nd time), same process - this time progress bar went all the way to end. Rebooted by itself.

 

This time there was only 4 choices in the Clover menu (no Install anywhere anymore), took the "Boot macOS from Mojave SSD".

Boots Ok, Logging In, asks about Siri (new!),  System Preferences and Dock shows STILL red (1) !!??

opened Software Update - Checking..... "Your Mac is up to date - macOS Mojave 10.14.6". 

 

I have disabled the Catalina update notification via Terminal (Googled commands, Noob):

sudo softwareupdate --ignore "macOS Catalina"

defaults write com.apple.systempreferences AttentionPrefBundleIDs 0

killall Dock

 

Dock stays clean few minutes and Red (1) comes visible again, Software Update - but checking says "...Up to Date..."

 

I don't understand, why ?? What's wrong...

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By BALDY_MAN
      I thought it would be fun. to see peoples OLD fatefull. Hackintoshes. (you know the one. that alway updates easy. and just runs.  Here,s mine



    • By marzib
      I'm trying to upgrade from Sierra to High Sierra. My Sierra is working and booting great with the latest Clover 5.0 r5115, but when trying to upgrade to High Sierra, any time the computer reboots into the installer, it gets stuck at the line "Start ReadKernelCache". The screenshot is attached. I've tried the following troubleshooting steps that I've read in other similar posts, none of which worked. It always remains stuck at that line:
       
      Boot with UseKernelCache=No and/or -x and or -f Temporarily remove discrete graphics card and try to install with integrated graphics Add MATS to the Drop Tables list in Clover Configurator Look for an option similar to "Above 4G Encoding". My motherboard doesn't seem to have that. Try a bootable USB drive with the High Sierra installer instead of the App Store mechanism. The USB boots great, and I can initiate the installation, but upon reboot, I get the same issue trying to boot into the installer.   Disable integrated graphics in the motherboard's BIOS    
      Below are my system details. It seems like it should be possible, based on this post, to run High Sierra with this motherboard and CPU, but I can't get the installer to run. 
      Thanks for any help!
       
      Motherboard: Gigabyte GA-Z77X-UP5-TH
      CPU: Intel Core i7-3770K
      Graphics: EVGA GeForce GTX 970 
      Clover: 5.0 r5115 with basically no mods from the default ISO aside from enabling APFS driver
       
    • By IDON-NO
      Supplemental update
      macOS Catalina 10.15.4 (19E287)
       
      Update went Fine 
       
      https://developer.apple.com/news/releases/?id=04082020b

    • By lucjac99
      salve a tutti ennesimo problema, ho Catalina nella versione 10.15.1 e ho tentato l'update alla ver 10.15.2 purtroppo il mio hackintosh dopo aver fatto il setup di installazione fa qualche operazione  e rebootta ma non ha aggiornato niente, BOH! ho llilu nuovo whatev nuovo alc nuovo Clover ultimo grazie per un aiuto
×