Jump to content
Shaneee

AMD Vanilla Guide

3 posts in this topic

Recommended Posts

Advertisement
6 hours ago, Shaneee said:

Здесь мы имеем руководство AMD ваниль. Совместимость с Windows. 

 

Нажмите здесь для руководства.

 

Для установки поможет сделать пост  здесь . И после установки помощью сделать пост  здесь .

 

Спасибо,

Shaneee

Снимок экрана 2019-10-30 12.25.31.png

Shanee, thanks for the tremendous work done in this guide.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By fojerhar
      Hi
       
      I'm 70 percent ready with my AMD hack
      Hardware:
      MoBo: Asrock Taichi TRX40
      CPU: AMD Ryzen Threadripper 3970X
      GPU: Gigabyte Aourus RX580
      Mem: 32Gb GSkill 3000MHz
      Power: EVGA Supernova 750 G2
      OS: 10.15.6 Catalina
      profile: iMacPro1,1
      With OpenCore 0.6.1
       
      Strange thing: I have a big multicore difference between win10 and Catalina with GB4, maybe OS X is written a bit better... I don't know
      win: https://browser.geekbench.com/v4/cpu/15754100
      osx: https://browser.geekbench.com/v4/cpu/15765221
       
      Things: I cannot turn off CSM support on the mob, in this case my video card won't run, only turns on, when OSX or windows starts up, so I cannot see anything before that, like BIOS or UEFi setup.
      And for above 4G decoding CSM must be off on this mono, but I cant .... But tried with my Nvidia CSM off above 4G on, but had the same results.
       
      During the installation I always stucked, froze in the 2 minutes remaining screen. So I have installed Catalina on a real Mac to an external HDD, booted from it,  and then carbon copied it into my NVme drive.
       
      Many things are working now:
      iMessage
      sleep
      cpu handling, monitoring, power management
      built in bluetooth
      i211 ethernet port
      2.5Gbs port.... with the Lucy kext I can see it, but there is no data flow
      NvMe
      usb
       
      Mainly followed this thread:
      https://dortania.github.io/OpenCore-Install-Guide/AMD/zen.html#nvram
       
      What do not works:
      Restart or Shut Down
      Firewire card not seen by system
       
      RESTART/Shutdown
      After any of these commands, the dock disappears, and computer freezes with the background screen, no reaction
      Tried to make a virtual nvram by this:
      https://dortania.github.io/OpenCore-Post-Install/misc/nvram.html#cleaning-out-the-clover-gunk
      But as I write tis line, got this error message
      root@192 ~ # sudo nvram -c
      nvram: Error clearing firmware variables: (iokit/common) not permitted
      For me it seems that the SIP is turned on, but the car-active-config 77000000 flag is used. With this flag I have this:
       
      @192 ~ % csrutil status
      System Integrity Protection status: disabled (Apple Internal).
       
      With disable SIP FF070000 I have only partial disables.
       
      Seems okay, with the other flags, I always have partial disables.
      For me seems, that the system cannot write to the nvram, but iMessages works perfectly
       
      Tried to make a FixShutdown-USB-SSDT, but I cannot find any _PWR in my DSDT, so don't know what to change
       
       
      Firewire pci card:
      This would me mandatory for me to work, have to use it for my Universal Audio interface
      On windows it is working fine, and it was natively working in my previous hack builds (with Asus prime z370A, or Gigabyte Z390 Designare with an I7 8086K)
      Tried to fix IRQ with SSDTTime, copied aml and merged the plist patches
      The UAD software writes: Driver not installed correctly. For them it means, that at the first start I have to allow this program at Security and Privacy at the first start, but there was no option for that. Tried to reinstall several times, but no success.
      Again seems like SIP and Nvram problem connection.
      In the previous hack builds by default I had my Firewire card in the System profiler/Firewire, showed my 800/400FW ports.
      Also tried to force load FW kexts in OC, no success.
      Tried both npci=0x2000 and 3000, the same. Without I stuck in PCI CONFIGURATION BEGINS
       
      If my IOreg is needed: (too big to attach here)
      https://www.dropbox.com/s/v67lzkq9spraryn/fojerhar iMac Pro.ioreg?dl=0
       
      Help me to be a happy person with this Monster working
       
      Thank you
      Viktor
       
      fojerhar config.plist
      pcidevices.txt
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
    • By Johnnycale
      Hi everybody. I'm stuck here and after a few days I'm really not able to boot.
      My setup is the following:
       
      CPU AMD Ryzen 9 3900x
      GPU Aorus RX 5700 XT
      MOTHERBOARD AsRock x570m Pro4
      SSD 1 Corsair MP600 1TB
      SSD 2 Gigabyte Aorus NVMe 1TB
      RAM Crucial Ballistix 2x32GB
      WIFI BCM94360CD

      Error message from Bios attached to this thread.

      Thanks to anyone willing to help me. I've tried different open core versions, adding and removing a lot of kexts, keeping essentials ACPIs, setting as true or false different .plist settings that I saw resolving similar issues as mine but nothing seems to work.
      opencore-2020-09-07-214007.txt
×