Jump to content

OpenCore causes UEFI to POST in safe mode


14 posts in this topic

Recommended Posts

I migrated my build from Clover to OpenCore, and now every time I boot my system I get the screen attached.

What is really weird is that macOS itself works fine: except from native NVRAM everything (boot, reboot, power off, sleep, USB and connected devices, GPU acceleration, Audio, WIFI, Bluetooth, FileVault2, AppStore, iCloud, Airdrop and HandOff) seems to work perfectly.

If I press F1, enter UEFI setup and quit immediately without saving changes the system boots fine.

 

I'm running Catalina on the following:

  • Core i7 8700
  • Asus Rog Strix H370-I gaming
  • No dGPU
  • 32GB DDR4-3200 (at 2666Mhz since that's what the CPU supports without OC)
  • Samsung 970Evo Plus
  • Broadcom BCM94352Z DW1560 WiFi card (replaced the original one)

 

Booting off a Linux Live USB drive, thus bypassing OpenCore, fixes the issue.

IMG_2956.jpg

Edited by kaworu

Digging around some more I found people having a similar issue with Asus boards. In that case the fix was related to RTC and included in an update to Clover.

 

While I have RTC disabled in my UEFI settings to begin with, I have tried applying both SSDT-AWAC and SSDT-RTC0 from OpenCore's ACPI samples (which are supposedly fixes for RTC related issues on 300 series motherboards), but no luck.

 

Can someone please help?

  • 2 weeks later...
  • 2 months later...
  • 3 months later...
  • 1 month later...
  • 1 month later...
  • 2 weeks later...

I can confirm that RTC Patch helped in my case. I upgraded to OC 0.6.0, and made some changes according to suggestions by sanity checker. Somehow it caused POSTed issue again (I know I've fixed it before). So my current settings are:

  1. Legacy RTC in BIOS
  2. SSDT-AWAC.aml
  3. AppleRTC patch

I think I don't need all 3, but I don't want to change it.

For those who use OC, you can open config.plist with a text editor and paste the patch under section: Kernel > Patch (it's an array)

  • 1 month later...
×
×
  • Create New...