Jump to content

Asus PCE-AC68 Can't turn wifi on High Sierra

4 posts in this topic

Recommended Posts

I have what's been said to be a natively supported wifi card, but for the life of me I cannot get it working properly with High Sierra. It is detected in DPCIManager but the wifi symbol at the top is hollowed and I can't turn it on.


Here's some basic info about my hackintosh. It's running an i7 9700k with an MSI Z390-A PRO, a GTX 1070, and it's SMBIOS is running as an iMac 18.1

Someone else has posted here about this with an ac66, which I think is very similar and uses the same device number 43A0. But he didn't get his problem solved in the end. And I have looked up this problem in a million different ways, I haven't found a solution that works from any yet.


I've tried a large amount of different kext patches, kexts (fakepciid, airportbrcmfixup, etc), changing fake ID, modifying kext info.plist files, and every combination of those, none have gotten it to properly work.


I have gotten it to work in one way but it's so unstable that it's unusable. Using the IO80211family.kext from yosemite works, but then it will randomly freeze about 10-15 minutes in, and then it'll not boot 9/10 times, and when it will it'll freeze on the login or right after. It gives errors about out of date kext, only way get back in is by reinstalling. So I figure this method is unusable.


I'm just stumped on why a supposed confirmed working out of box card doesn't just just work, even with every amount of tweaking and adding kexts. I'm in my 4th day of almost nonstop testing and researching on how to fix this, and I'm too stubborn and determined to just buy a different card. Any suggestions would be greatly appreciated. :D

Link to comment
Share on other sites

It doesn't turn on from the PrefPane, when I click "Turn Wi-Fi On" the "Network Name" drop down blinks for a frame, then nothing happens. I don't have any bios settings that'd turn it off, it works in windows fine and did work in mac with yosemite kexts.


I can't use LAN otherwise I would and not deal with this. If it shows I have no lan device at all it might be because I removed all internet related kexts in this reinstall so I wouldn't mess anything up.


Also without some of those previous kexts (not sure which ones fixed it), I can't boot half of the time. Around where it's loading the card kexts or doing something with the card it'll freeze and I have to force power off hoping I get lucky and it doesn't happen again. Of course I can fix this but I assume this happens because of something related to the wifi not working.


Edit: Nah I'm done. Screw hackintosh man, every thing is such a pain and requires so much time for such a small novelty. Thanks Herve for taking some time to try and help me, it's much appreciated.

Edited by bummercheese
Link to comment
Share on other sites


  • Create New...