Jump to content
thiagomenini

Clover do not apear in boot and shutdown problems

1 post in this topic

Recommended Posts

Hello everybody,

I'm from Brazil, if someone wants to write in portuguese, i will understand too. But english is fine.

 

Days ago I installed the High Sierra, using the image (HighSierraAMD V2 UEFI.dmg). I have an FX8320e, the Asus M5A78L-M / USB3 mobo, GTX 750 and 12GB of RAM.

 

Well, I build Hackintosh to run audio programs. Everything is working except the USB audio card on the card. But I read that some gyus updates to 10.13.4 or higher and it work.

But I have some problem with startup and shutdown. I had installed the Clover in different ways, but it did not appear at startup. If I do not use the pen drive to boot, I do not have access to the system.

 

I've tried different solutions. I formatted the EFI partition using the Terminal and reinstalled the Clover, but it also did not work.

 

The other problem is the shutdown. The system goes off, but the fans and the mobo remains on. I need to manually press the on/off button to turn off the computer. I had used the Clover Configurations App to set the flag (shutdonw fix) but it not work too. I think this might be related to the boot problem.

 

Thanks for any help!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By liljboi2
      Trying To Boot Mac OS X El Capitan On Surface Book 1 i5 128GB 
      Ive tried everything under the sun to try to get this to even load the installer
      ive had mixed experiences trying many different options and “combos” 
      i Can Offer Someone That Can Help A “Software Pack” Which Includes
      My EFI
      Kexts
      DSDT
      Readmes
       
      Pretty Much Everything I HaveTried And Researched
      Hopefully That Will Help As I’m Confident I Should Have All Required Files But Not So Confident On How They Should Be Coupled 
      There Is A Guide On This Platform That Goes Over Installing This But What Is Demoed Is MacOS Sierra 10.12 When My Target Is 10.11 El Capitan  Everyone In The Comments That Tried El Capitan Either Have Out Of The Gate Sucess Or Gave Up And Went To Sierra The Problem Is Besides The Guide Author Correcting A Few Mistakes There Is No Actual Diagnosis And Help Given 
       
      For A While I Was Getting Nothing But A Black Screen After Moving Files I Finally Got An Apple Logo Great!..Not Really Because that’s all it would do.
       
      i Tried EFI Folder From Guy Who Did Surface Pro 4 “Port” And after I While I Will Get Cross Where The Apple Logo Would Be So There’s Something Happening When Using His EFI ; Mines Will Just Hang At Apple Logo For As Long As I Let It 
       
      With Verbose Boot Or Boot Flag -v 
       
      I Get Errors Concerning OSXAptioFixDrv They Are Usually Different 
      If I Try OSXAptioFix2Drv I Get
       
      ...........................................
       
      if i try OSXAptioFixDrv I get 1 of 3 errors Typically Saying Similiar Things 
      About Relocating Memory 
       
      Will Try To Add Photos 
       
      This Is Not My First Hackintosh More Like 5th or 6th But Besides On HP Elitebook Revolve Where I Had Similar Issues Due To BIOS Settings 
      I simply CAN NOT Get It To Boot No Matter What I Do Or Edit Please Help Or Provide EFI Folder That Will Work For Me 
      For Now Looking To Upgrade BIOS as I think it has something to do with firmware being to old as this PC Is usually never connected to Wi-Fi unless I need to download something and I cannot stress I have done everything under the sun to get this to even boot the installer 
    • By gusbemacbe
      Hello,
       
      I am a former user of MacBook and Mac mini. Both died. One in 2014 and another last year.  I will think of giving my Hackintosh-compatible laptop to my brother that I purchased years ago, because he wants to play more than one computer, so he is a Twitch/YouTube streamer and a hardcore gamer and I will not need to lend him many times. If he wants, from my former laptop I will take only one 240GB SSD Samsung Evo with installed Arch Linux and leave one 500GB HDD for him. In the future, I will purchase a new Alienware laptop.
       
      As I got newly graduated, I moved to a new super PC with AMD Ryzen™ 7 2700X CPU and with NVIDIA GeForce™ 1660 Ti GPU. More details, you can see my signature below, that provides the complete details. I own an external SSD m.2 2280 with installed Windows 10.
       
      I will reconsider purchasing 4th drive – an external 480GB SSD m.2 2280 SATA WD Green 545MB/s or an external 1TB SSD SATA WD Green 545MB/s – for installing Hackintosh. But purchasing, I need to make sure.
       
      1. Is it worth to install Hackintosh on an external SSD m.2 2280? If I partition two partitions, one for Insansely's MyHack/Chameleon/Clover and another for Hackintosh and my new super-PC boot is natively BIOS and Grub, is it worth? Maybe I will try to install reFind on Arch Linux to replace the Grub if it is worth.
      2. I know that it will run on macOS High Sierra, Mojave and Catalina, but if I need Metal 2 to run the latest version of Sketch (the which I own an original licence) and of other apps the which I own original licences? Is NVIDIA GeForce™ 1660 Ti compatible with Metal 2?
      3. Since it be an external SSD, will I able to run Hackintosh as a portable OS in other computers?
       
       
    • By gusbemacbe
      Olá,
       
      Eu sou um ex-usuário do último computador da Apple – Mac mini – que faleceu no ano passado.
       
      Pensarei em dar meu computador portátil compatível com Hackintosh ao meu irmão que comprei anos atrás (em referência ao tópico «Sou novo ao fórum, já fui um usuário de Hackintosh e ainda pretendo montá-lo», porque ele quer jogar mais de um computador, pois ele é um streamer de Twitch e YouTube e um jogador hardcore, e não precisarei ficando emprestando-lhe muitas vezes.
      Se ele quiser, do meu antigo computador portátil, pegarei apenas um SSD Samsung Evo 860 de 240GB com o Arch Linux instalado e deixarei um HD de 500 GB para ele. No futuro, comprarei um novo laptop Alienware.
       
      Como me formei no início deste ano, mudei-me para um novo supercomputador cujo processador é AMD Ryzen™ 7 2700X e cuja placa de vídeo NVIDIA GeForce ™ 1660 Ti. Há mais detalhes que posso fornecer-lhes na minha assinatura abaixo. Possuo um SSD m.2 2280 externo com o Windows 10 instalado.
       
      Reconsiderarei a compra da quarta unidade – um externo SSD m.2 2280 SATA de 480GB 545MB/s da marca WD Green ou um externo normal SSD SATA de 1TB 545MB/s da marca WD Green – para instalar o Hackintosh. Mas antes de comprá-lo, preciso ter certeza.
       
      1. Vale a pena instalar o Hackintosh num SSD m.2 2280 externo? Se eu criar duas partições, uma para o MyHack/Chameleon/Clover do InsanelyMac e outra para o Hackintosh, e a inicialização do meu supercomputador é nativamente BIOS e Grub, vale a pena? Talvez eu tente instalar o reFind no Arch Linux para substituir o Grub, se valer a pena.
      2. Sei que macOS High Sierra, Mojave e Catalina funciona com o processador AMD Ryzen™, mas se eu precisar do Metal 2 para executar a versão mais recente do Sketch (a qual eu possuo uma licença original) e de outros aplicativos cujos possuo as licenças originais? O NVIDIA GeForce™ 1660 Ti é compatível com o Metal 2?
      3. Como é um SSD externo, poderei executar o Hackintosh como um sistema operativo portátil noutros computadores?
    • By Slice
      As I see many novices in the forum ask "How to make my Radeon working? I have bad resolution, no QE/CI...." and so on. They come to the section and have no find an answer here because all Radeons are different and they don't know where else they read about this.
      I want to explain all steps needed for launching the Radeon family of videocards.
       
      Bootloader.
      I will speak about Clover because I maintain this bootloader to know recent hardware and modern OSX. Not sure if you will have the same result with other bootloaders. I am carefully checking the injecting of ATI card and correcting it times to times. I am also accessible for bug reports.
       
      OSX version.
      Older card require older system, newer cards require new system.
      ATIRadeon9000 is possible to launch under Tiger.
      ATIRadeonMobilityX1400 requires 10.5-10.6. See RadeonHD topic.
      As I see RadeonHD3xxx was successful only in 10.5
      For new AMDRadeonHD7xxx there must be 10.8.3+ system.
       
      DeviceID.
      This must be the first question before asking about the card.
      You may know the device-id from Windows->DeviceManger->VideoCard.properties->compatibleIDs
      You may boot into system in safe mode (key -x) and see system profiler
       
      And you may boot into Clover GUI, press F2 and get preboot.log. Find here something like
      2:709 0:000 PCI (00|01:00.00) : 1002 6758 class=030000 2:709 0:000 Found Radeon model=AMD Radeon HD 6670 Series It means my DeviceID=6758 (these are hex numbers)
      Then you must check that Apple's drivers support your DeviceID. If not then add it!
      For example HD7850 has DeviceID=6819. If we look into ATI7000Controller (AMD7000... in new systems) we find 6818 here but no 6819!
       
       
      I show you how to do this with terminal commands. Launch /Application/Utilities/Terminal.app. Type in opened window:
       
      cp /System/Library/Extensions/ATI7000Controller.kext/Contents/Info.plist ~/Desktop So you get a copy of the Info.plist on Desktop. Edit it with TextEdit. Change 68181002 -> 68191002.
      Don't edit this file directly in the system folder! 
      Then copy back by terminal. Don't use finder to copy kexts! They will have wrong permissions in this case.
      sudo cp ~/Desktop/Info.plist /System/Library/Extensions/ATI7000Controller.kext/Contents/ sudo rm -r -v /System/Library/Caches/com.apple.kext.caches/* Second command make sure next reboot the kext will use your edited info.plist.
      The same operation you must do with a kext AMDRadeonAccelerator or ATIRadeonX2000 or other one. Check all candidates if they contain such list of possible IDs and choose closest to you.
       
      FakeID
      Since Clover revision 1971+ you may just inject new DeviceID into DSDT instead of correcting kexts. See instruction here.
       
      GraphicsEnabler or Injector
      OSX needs to know some properties (Model name, Family, etc...) that must be somehow injected at boot time. Yes, also real Macs got DeviceProperties string from firmware.
      Alternatives:
      1. Set InjectATI=Yes in Clover (same as GE=y in Chameleon).
      2. Use custom string made with gfxutil. For whom who knows.
      3. Write _DSM into DSDT. You should know what to write.
      4. Use some kext like ATY_init.kext or Natit.kext. If you are sure that the kext is for your card namely.
      I want to say that all this methods make the same thing. Differencies in their tuning.
      The Clover do this automatically for most known cards at this moment.
       
      Connectors.
      As you may see to start HD5000-7000 some strange names used: Pithecia, Orangutan, Elodea... What are they?
      They are configs for framebuffer. Predefined configs how connectors are solded for cards used in real Macs. Strange but these configs rear coincide with PC card. Usually gurus make advice "choose a framebuffer that most appropriate for your card". The chances 1:10. In most cases you may find a FB name that gives you main monitor working. Or nothing at all.
      Great respect to bcc9 who gives us a method to correct one of config to be exactly for you. See here.
      My retelling for Clover is here
      Success example in the thread in posts 44-52
       
      Radeon Mobility
      I tested Clover's methods with two users having Mobility Radeon HD5470 and HD5650M. We found that full memory and QE/CI will be achieved if we set in Clover's config
      LoadVBios=Yes
      even thou no file with bios is provided. This is the key to make Radeon Mobility working!
      Other problem is bad gradients or artifacts. For this case Clover accept the key
      InjectEDID=Yes
      and sometimes you also need to inject CustomEDID.
      See Clover instructions for details.
       
      And my results.
      Gigabyte Radeon HD6670
      <key>Graphics</key> <dict> <key>GraphicsInjector</key> <true/> <key>InjectEDID</key> <true/> <key>FBName</key> <string>Ipomoea</string> <key>LoadVBios</key> <false/> <key>VideoPorts</key> <integer>3</integer> <key>PatchVBios</key> <true/> </dict> <key>KernelAndKextPatches</key> <dict> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>6000</string> <key>ATIConnectorsData</key> <string>000400000403000000010000120401050008000004020000000100001102040310000000100000000001000000000002</string> <key>ATIConnectorsPatch</key> <string>040000000403000000010000100001061000000010000000000100000000000100080000040200000001000012040403</string> VTX Radeon HD5570
      <key>Graphics</key> <dict> <key>PatchVBios</key> <false/> <key>FBName</key> <string>Baboon</string> <key>VideoPorts</key> <string>3</string> <key>GraphicsInjector</key> <string>Yes</string> <key>LoadVBios</key> <string>No</string> </dict> <key>KernelAndKextPatches</key> <dict> <key>Debug</key> <false/> <key>KernelCpu</key> <false/> <key>ATIConnectorsController</key> <string>5000</string> <key>ATIConnectorsData</key> <string>040000001400000000010000010201030008000000020000007100002205020110000000100000000001000000100002</string> <key>AppleRTC</key> <true/> <key>ATIConnectorsPatch</key> <string>040000001400000000010000010001040008000000020000007100002200020510000000100000000001000000000002</string> <key>AsusAICPUPM</key> <false/> <key>KextsToPatch</key> <array> <dict> <key>Name</key> <string>AppleAHCIPort</string> <key>Find</key> <data>RXh0ZXJuYWw=</data> <key>Replace</key> <data>SW50ZXJuYWw=</data> </dict> </array> </dict> See PatchVBios=No
      for this card "yes" leads to black screen. Use with precautions.
       
      A sample for Radeon R7 240
       
      UPDATE for ElCapitan.
      It seems has more problems. My HD6670 is not working in ElCapitan OOB unlike Mavericks.
      I had to set FakeID=0x67401002 as correspond to real iMac12,2 and set this model in SMBIOS section.
      It related to GraphicsPM or GraphicsControl.
      Look these kexts to decide what you can do for your configuration.
       
      HighSierra requires change these kexts by version from Sierra 10.12.6
      for Radeon HD6xxx
      AMDRadeonX3000.kext AMDRadeonX3000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .  for Radeon HD7xxx and up AMDRadeonX4000.kext AMDRadeonX4000GLDriver.bundle IOAccelerator2D.plugin IOAcceleratorFamily2.kext .    Black screen after wake problem resolved by follow method radeon_bios_decode.0.2.zip
      ati-personality.pl.0.15.zip
      ati-personality.pl.0.15a.zip
    • By jdorz
      Hello all,

      I have successfully gotten my Hackintosh working 99 percent. The remaining issue that I am running into is that my system will randomly kernel panic upon a user issued shutdown or reboot WHEN I have either a usb sound card or usb headset plugged into any of my USB ports (both 2.0 and 3.0). If I remove the headset, it will power down with no issues. Does anyone have any suggestions?

      My system is as follows:
      MacOS 10.14 Mojave
      Gigabyte H370 HD3
      8400 i5 Coffee Lake
      Radeon RX 580 sound card

      Fixed
       
      Solution
       
      Use this folder for serie 100/200/300
      https://olarila.com/forum/viewtopic.php?f=28&t=8222
       
      reboot and extract one send_me for full dsdt patch by MaLd0n
      --Run_Me
      RunMe.app
       
       
       
×