Jump to content
Installus

[SOLVED!] Dell L502X Audio Problems.

6 posts in this topic

Recommended Posts

Posted (edited)

Hello all! Glad to be here! :)

 

I've hacked my Dell XPS L502X with an install of OS X Mavericks 10.9.5 (vanilla install). All is good and all, except that there is no WiFi (planning on buying wifi dongle) and that there is no audio.

The lack of internet irks me, but I can fix that at a later date. What I can't deal with is the lack of audio. I've tried everything, but there is no luck. AppleALC, Voodoo/AppleHDA, among others.

Oh, if I have to, I can reinstall OS X, since nothing important is on the partition.

 

All replies and answers are welcome!

Thanks in Advance!

 

Installus (Chaotic) 

 

EDIT: Thanks to Hervé, I've been able to get my audio working, and so can you! 

 

All you need is... 

 

A hackintosh that has the Realtek ALC665 codec (you can't change codecs!) 

 

AppleALC.kext (latest version) 

OR

VoodooHDA.kext (again, latest version) 

AppleHDADisabler.kext

 

A USB flash drive (if you have no WiFi on hackintosh) 

A secondary computer/way to put files onto the drive (again, no WiFi on hackintosh) 

 

 

1. Store the files you need on your hackintosh

 

1a. Download them straight thru your hackintosh

 

1b. Use a secondary device to download them and store on a flash drive. 

 

2. Open terminal on your computer and type "diskutil mount EFI" in said terminal. Of course, remove the quotation marks. 

 

3. On your EFI partition, navigate to EFI/CLOVER/kexts/Other

 

4. Drag n' Drop the kexts you have downloaded on your computer to that folder. 

 

5. Cross your fingers and reboot

 

5a. (Optional) Suffer a kernel panic during boot because VoodooPS2 doesn't like you. 

 

6. If all goes well, you'll have audio! 

 

Guaranteed works for Dell L502X, however YMMV. 

Edited by Installus
Change title to solved, and give a rudimentary guide for those who have the same laptop as I do.

Share this post


Link to post
Share on other sites
Advertisement
Posted (edited)

According to the AppleALC wiki, ALC665 is supported since Mavericks 10.9 using layout 12 or 13. VoodooHDA should have worked, provided you also install AppleHDADisabler.

 

This being said, Mavericks is getting quite long in the tooth in 2019. Why don't you switch to High Sierra instead? You'll get a modern macOS version and benefit from up-to-date ad-on kexts. HD3000 is fully supported under High Sierra. However, if you run on the Nvidia GeForce GT 525M, the last version you can run is El Capitan as you're highly unlikely to get that Fermi dGPU support in Sierra/High Sierra (no supporting Mojave for sure).

 

Edited by Hervé

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, Hervé said:

According to the AppleALC wiki, ALC665 is supported since Mavericks 10.9 using layout 12 or 13. VoodooHDA should have worked, provided you also install AppleHDADisabler.

 

This being said, Mavericks is getting quite long in the tooth in 2019. Why don't you switch to High Sierra instead? You'll get a modern macOS version and benefit from up-to-date ad-on kexts. HD3000 is fully supported under High Sierra. However, if you run on the Nvidia GeForce GT 525M, the last version you can run is El Capitan as you're highly unlikely to get that Fermi dGPU support in Sierra/High Sierra (no supporting Mojave for sure).

 

I would, but mavericks runs fast. Plus, I adore the old Aqua interface. I don't mind the flat UI, but I prefer the old design. Perhaps I may switch to 10.13

 

I'll try AppleALC + VoodooHDA + HDADisabler tomorrow (EST), as I'm limited in time.

 

Thank you for your reply!

 

SUCCESS! It worked like magic! Now I don't have to buy an audio adapter! Reddit: 0, InsanelyMac but worse: 0, InsanelyMac: 1.

Edited by Installus
To report success for audio issue.

Share this post


Link to post
Share on other sites
8 minutes ago, Hervé said:

Erm, obviously, it's AppleALC or VoodooHDA+AppleHDADisabler...

Both work, no kernel panics. 

Share this post


Link to post
Share on other sites

Wow, I just realized I kinda posted in the wrong section (I looked around and found an audio problem reporting section).

 

I made a post similar to this on that site, and got blasted because it wasn't in the laptop section or whatever. No answer

I make a post here, and I get an answer. :)

 

Audio has been treating me well so far! Just waiting on a WiFi dongle, then I'll have a mostly complete experience! Can't wait! :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dbx103
      I'm having so much problem following guide and forums making impossible for me to understand,  MaciASL, Could someone disable my Nvidia card by editing my files.
       
      origin.zip
    • By EvandroAluck
      eu tô muito perdido, sempre que eu tento instalar um driver do [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], ou até atualizar o sistema pela apple ele não incia mais. eu já instalei o sistema e reiniciei sem fazer alterações e funcionou perfeito ...

    • By chrisrlink
      hi so I recently upgrade to an Nvidia GT 730 (did an upgrade without needing a new PSU) the graphics card is detected by Mojave but no sound via the hdmi port I read Nvidia is forbidden to make web drivers past High Sierra (must be approved by apple) so how will I go about enabling sound through my HDMI (any additional info/files I'll be happy to supply)
    • By SolarStudios
      Hey I finally got OSX kinda to work. But when I boot with all settings enabled to make HDMI work I only get 10MB VRAM, I already tried changing all the FakeID but all give the same result or make it unable to boot at all. When I don't use any settings in the config.plist and boot without WhateverGreen and Lilu it works fine over VGA with 1500 something MB VRAM. But I need to work over HDMI..

      I also used another kext I saw someone else using on the 8th gen coffee lake CPU but it didn't have any effect aswel.

      I included my EFI Folder as download in this post, hopefully someone knows how to solve this because I've been searching for hours without luck 
      8mbvram.zip
×