Jump to content
5kr1p7

Troubles with Mojave on AMD FX

1 post in this topic

Recommended Posts

Just installed Mojave 10.14.1 (guided by the Shaneee tutorial) and faced a number of problems:

 

  1. Annoying USB related errors loop when system boot (if anyone got this just wait longer). Entering commands in single user mode commands was really challenging with screen full of errors
  2. Reboot/shutdown doesn't work (after lines in console just black screen. Need to push reset/power button)
  3. Computer doesn't wake up after sleep
  4. Browser are crashing on some web pages (Safari and Chrome on same pages (can't login on rutracker.org for example))

 

USB error:

...
2019-04-02 23:52:57.982767+0300 0x1adc     Default     0x0                  0      0    kernel: (AppleUSBEHCI) 000122.778171 UHC4@53000000: AppleUSBEHCI::StopUSBBus: USBSTS.HCHalted did not set as expected: USBCMD 0x00010030 USBSTS 0x00004008
2019-04-02 23:52:57.982779+0300 0x1ad3     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.778184 UHC6@56000000: AppleUSBHostController::hardwareExceptionThreadCallGated: 0x00000010
2019-04-02 23:52:57.985297+0300 0x1ad3     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.780706 UHC6@56000000: AppleUSBHostController::hardwareExceptionThreadCallGated: attempting recovery
2019-04-02 23:52:57.985320+0300 0x1ad3     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.780730 UHC6@56000000: AppleUSBHostController::hardwareExceptionThreadCallGated: 0x00000008
2019-04-02 23:52:57.985339+0300 0x1ad3     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.780750 UHC6@56000000: AppleUSBHostController::hardwareExceptionThreadCallGated: attempting recovery
2019-04-02 23:52:58.021308+0300 0x1ad1     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.816718 UHC2@52000000: AppleUSBHostController::hardwareExceptionThreadCallGated: 0x00000010
2019-04-02 23:52:58.023653+0300 0x1ad1     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.819066 UHC2@52000000: AppleUSBHostController::hardwareExceptionThreadCallGated: attempting recovery
2019-04-02 23:52:58.023664+0300 0x1ad1     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.819078 UHC2@52000000: AppleUSBHostController::hardwareExceptionThreadCallGated: 0x00000008
2019-04-02 23:52:58.023673+0300 0x1ad1     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.819087 UHC2@52000000: AppleUSBHostController::hardwareExceptionThreadCallGated: attempting recovery
2019-04-02 23:52:58.088634+0300 0x1ad7     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.884043 UHC4@53000000: AppleUSBHostController::hardwareExceptionThreadCallGated: 0x00000010
2019-04-02 23:52:58.091464+0300 0x1ad7     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.886874 UHC4@53000000: AppleUSBHostController::hardwareExceptionThreadCallGated: attempting recovery
2019-04-02 23:52:58.091481+0300 0x1ad7     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.886893 UHC4@53000000: AppleUSBHostController::hardwareExceptionThreadCallGated: 0x00000008
2019-04-02 23:52:58.091495+0300 0x1ad7     Default     0x0                  0      0    kernel: (IOUSBHostFamily) 000122.886909 UHC4@53000000: AppleUSBHostController::hardwareExceptionThreadCallGated: attempting recovery
2019-04-02 23:52:58.092790+0300 0x1ad8     Default     0x0                  0      0    kernel: (AppleUSBEHCI) 000122.888199 UHC6@56000000: AppleUSBEHCI::StopUSBBus: USBSTS.HCHalted did not set as expected: USBCMD 0x00010030 USBSTS 0x00004008
2019-04-02 23:52:58.131032+0300 0x1ae4     Default     0x0                  0      0    kernel: (AppleUSBEHCI) 000122.926440 UHC2@52000000: AppleUSBEHCI::StopUSBBus: USBSTS.HCHalted did not set as expected: USBCMD 0x00010030 USBSTS 0x00004008
2019-04-02 23:52:58.196398+0300 0x1ae9     Default     0x0                  0      0    kernel: (AppleUSBEHCI) 000122.991807 UHC4@53000000: AppleUSBEHCI::StopUSBBus: USBSTS.HCHalted did not set as expected: USBCMD 0x00010030 USBSTS 0x00004008
...

 

Can anyone who fixed theese issues share kexts archive, config.plist, kernel newer than the manual? My PC specs in signature.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By lizdav
      Hi,
       
      I would like to ask for some advice or help even.
       
      I have had some usability issues in the past with my hackintosh so I installed Mojave for the second time but it keeps producing the same exact problem. Most of the time the system stutters and lags after login. The app icons just bounce if I want to open them and even if it does it takes forever. Another thing I picked up on is that it seems like there's no internet access whenever this occurs. The problem ceases after like 2-3 restarts and everything is back to normal. 
       
      What could cause an issue like this? I had the same thing happening with my previous install but I thought that was because of unnecessary kexts I left in the EFI. I only have the bare minimum required this time so I'm kinda lost.
       
      Computer specs:
       
      Mobo: Gigabyte B360M D3H
      Graphics: Radeon Vega 64 8OC
      CPU: Intel i7 8700k
      Ram: 32 Gig
      SSD: Samsung Evo 860 250gb
       
      I also have a separate HDD with Windows 10 installed for gaming purposes. I would greatly appreciate any kind of help, thanks in advance!
       
      –David
       
       
      config.plist
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
    • By Johnnycale
      Hi everybody. I'm stuck here and after a few days I'm really not able to boot.
      My setup is the following:
       
      CPU AMD Ryzen 9 3900x
      GPU Aorus RX 5700 XT
      MOTHERBOARD AsRock x570m Pro4
      SSD 1 Corsair MP600 1TB
      SSD 2 Gigabyte Aorus NVMe 1TB
      RAM Crucial Ballistix 2x32GB
      WIFI BCM94360CD

      Error message from Bios attached to this thread.

      Thanks to anyone willing to help me. I've tried different open core versions, adding and removing a lot of kexts, keeping essentials ACPIs, setting as true or false different .plist settings that I saw resolving similar issues as mine but nothing seems to work.
      opencore-2020-09-07-214007.txt
    • By gekko.be
      I have an old Hackintosh that I have brought back to life. An ASUS P5KPLAM-SE mobo, Intel Core 2 Quad, with a Sapphire HD 5670 1GB graphics card. It used to work just fine on High Sierra 10.13.3 (I think it was .3) However I only used the DVI port. Updated to 10.13.6 and with AMD kexts rollback to the previous versions I got everything o wrk just fine: boot, HDMI video, HDMI audio etc etc. The only problem I face is that my USB keyboard and mouse freeze/hang seemingly very random... I can not seem to get it right. Unplugging and replugging the USB device makes it work again, sometimes for a few seconds sometimes for an hour ... No idea what's wrong... Have tried tons of options in clover, USBInjectall.kext with port limit patch, whatever I could find... Would there be anyone out there who would have an idea of what could be the problem?
×