Jump to content

Can't delete files from trash


1 post in this topic

Recommended Posts

Ok this is kind of silly. Running Mojave on an i7 4770K, Gigabyte Z87X-UD4H, RX 560 system. Using vanilla clover and custom DSDT from Mald0n. I have a profile for myself, and one for my wife. When reconfiguring clover for vanilla settings, both of our iMessage accounts developed issues, probably because a new serial was generated. iMessage would quit unexpectedly on both of our accounts. I deleted my iMessage plist, logged out of iCloud and then back in and it was fixed. For my wife's account, nothing I could do would fix the issue. I deleted all related plists, as well as the messages and attachments associated with iMessage, logged out and back in to iCloud, but the problem persisted. So I created a new MacOS profile, and transferred her data from the old profile to the new profile and deleted the old profile. 


Everything works great now, except in the process of transferring her data to the new profile, there was an old folder within iTunes for podcasts that I am trying to delete, and I can't empty the trash can because this folder is apparently in use. 

I have tried a bunch of different methods to delete this. I have changed permissions so that I can read-write. I went into single user mode, browsed to the trash can and tried to delete the contents, but it would say that the files are read-only. I tried using chmod in single user mode and still get read only error. I can't boot into safe mode using -x, as it just shuts the computer down (error is boot task failed fsck-safe). I transferred the contents of the trashcan on my wife's account to my own local account and attempted to delete it that way, and it's all still apparently in use. I have tried using lsof on the folders in the trash but it returns no listings. I've tried booting into the recovery partition and running first aid, but I get an error saying it can't unmount my Macintosh HD partition. 


This is a long winded way of asking how in the heck I can delete contents within the trashcan claiming to be in use. Some of these are empty folders that definitely are not in use by any program. I'm really hoping my Hack is not corrupted. :/


Any pointers??

Link to comment
Share on other sites


  • Create New...