Jump to content

Can a Windows Update make some change now my Hackintosh doesn´t boot?


4 posts in this topic

Recommended Posts

Hi. I have a hackintosh installed from few years. I'be been updating it several times. Now It is running High Sierra 10.13.5 and booting from SSD disk with Clover. In the same computer I have other disks, one with Windows 10 booting from BIOS with I want to go into it.

This configuration has been running for more than one year.


Yesterday, I decided to go into Windows so I restarted the computer and booted in it. It made some windows updates and then I let it allnight updating a software I have.


This morning I've found my computer hanged. Tried to reboot it several times without any way to boot on clover. I then reboot in Windows and it made another update (so I suspect tonight it tried to make a Windows update and in the reboot, as Windows is not my main boot disk, it tried to boot on clover unsuccesfully). 


I am able to see the APFS disk of High Sierra using Paragon in Windows and it seems to be working well.


To try to solve any other problem, I have an SSD with another Mac Os version (Yosemite) with Clover. I have connected to my computer, get into Clover but it doesn´t boot up neither. In fact, there is nothing on screen even if I check the verbose mode. 


Do you think the Windows update could make any in my BIOS or somewhere making unable to boot the MacOS? I could think in a corrupted SSD but the Yosemite version should boot up and it makes the same thing.




Link to comment
Share on other sites

Just to say I've just solved the problem. I think it is still related to something with the Windows Update or similar because it was related to the graphics card driver too. To solve it I did the following:


- Installed CLOVER from my Windows in a USB drive

- Used Paragon to access the APFS High Sierra partition and took the kext I had installed, and the apfs.uefi in UefiDrivers64

- Reboot with the USB Drive and boot High Sierra in Safe mode. This time it booted

- Verify disk with disk utility

- I reinstalled the nVidia web driver for my build version because in settings the nvidia control panel was unable to start

- Reboot


And now it works. :)



Edited by Phosy
Link to comment
Share on other sites

  • 6 months later...

Usually users are lazy to inform BIOS to boot Clover. They choose an easy way to boot from /EFI/BOOT/BOOTX64.EFI. There is the caveat.

This file can be replaced by windows by some other with similar name.

The good way is

1. Install Clover into /EFI/CLOVER/CLOVERX64.EFI

2. Start the Clover and choose second icon in low row "Add Clover as boot entry". It will be written into BIOS Boot Sequence.

Then you can do with Windows all you want, your Clover entry will remain untouched.

  • Like 1
Link to comment
Share on other sites


  • Create New...