Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
Tobiko

Shutdown kext.

40 posts in this topic

Recommended Posts

Hello,

 

I hope this is the right place. I have an HP laptop that works 100% with the exception of fully shutting off. Fix shutdown, halt enabler, rehab mans DSDT patches all of them do not seem to work. I tried editing the DSDT/SSDT's and so have few others with more experience and it just won't fully shut down. I was referred to this section by another user who suggested I ask in the Lilu Plugins section about a shutdown kext. Here is the thread if you would like more details. 

 

 

 

 

 

Thanks for your time.

Send me Craptop.zip

Share this post


Link to post
Share on other sites

Thanks MaLd0n,

 

I used your DSDT and adjusted/added the DSDT patches in the config.plist but I get the same results. The screen goes out and the keyboard backlight, power button, and Ethernet stay lit.

Send me Craptop.zip

Share this post


Link to post
Share on other sites
3 hours ago, Tobiko said:

Thanks MaLd0n,

 

I used your DSDT and adjusted/added the DSDT patches in the config.plist but I get the same results. The screen goes out and the keyboard backlight, power button, and Ethernet stay lit.

Send me Craptop.zip

Arquivo Comprimido.zip

Share this post


Link to post
Share on other sites

Thanks again maLd0n. Unfortunately, using the config.plist and DSDT.aml from the zip, I get the same results for shutdown and it does not sleep properly.

 

 

Send me Craptop.zip

Edited by Tobiko

Share this post


Link to post
Share on other sites
35 minutes ago, Tobiko said:

Thanks again maLd0n. Unfortunately, using the config.plist and DSDT.aml from the zip, I get the same results for shutdown and it does not sleep properly.

 

 

Send me Craptop.zip

u can test a emuvariable driver for check if problem is a nvram

Share this post


Link to post
Share on other sites

Okay. 

 

Should I be clearing the NVRAM before using your fixes? I know NVRAM is working to some extent, I can clear it, I can add variables and reboot and they're still there. Settings for Clover boot sound can be adjusted and stored etc etc.

 

I will remove AptioMemoryfix and replace it with Emuvariable OSAptioFIX as soon as i get back to the laptop and see what happens. 

 

 

Share this post


Link to post
Share on other sites
16 hours ago, MaLd0n said:

u can test a emuvariable driver for check if problem is a nvram

Ok i cleared nvram removed AptioMemoryFix, installed emuvariable, osxaptiofixdrv64  and rebooted same problem but i realized without rc scripts installed it wasn't creating or using the nvram.plist So... i  installed rc scripts and made sure it was using nvram.plist. Rebooted a couple times and tried to shutdown but it still is doesn't - The screen goes out and the keyboard backlight, power button, and Ethernet stay lit.

 

Also, with those attached config/dsdt:

Sleep will not work properly and the system is sluggish when using the MBP 15,2 System definition.

 

BTW Thanks for taking the time to help me out.

 

 

Send me Craptop.zip

Edited by Tobiko
forgot a word

Share this post


Link to post
Share on other sites
22 hours ago, Tobiko said:

@MaLd0n

Do you think this problem will require a special kext? 

no, u can use a debug kext by rehabman and check what cause shutdown problem

Share this post


Link to post
Share on other sites
On 2/17/2019 at 8:12 AM, tyufhl said:

Сheck this DSDT. Fix shutdown = no. DSDT.aml.zip

Dude! That worked. I had to add AddPNLF to the config.plist to get the back-light control to work and I haven't tried sleep yet. But I am stoked. Thank you. What did you do?

 

Update. Yes, sleep is working fine too. So happy!

Edited by Tobiko

Share this post


Link to post
Share on other sites
3 hours ago, Tobiko said:

Dude! That worked. I had to add AddPNLF to the config.plist to get the back-light control to work and I haven't tried sleep yet. But I am stoked. Thank you. What did you do?

 

Update. Yes, sleep is working fine too. So happy!

 

I have determined that the Intel Shutdown patch that I attempted to use in your DSDT works but only when applied to a DSDT that has been previously modified by MaLd0n.  Because of language differences, I have been unable to determine from him what patches he applies so I am in the process of trying to isolate his patches based on two (now 3) DSDT's where I have before and after versions to compare.  One or more of MaLd0n's patches, combined with the Intel Shutdown patch are what is needed to make shutdown work on laptops such as ours.

 

MaLd0n used the Intel Shutdown patch in your DSDT that worked (i.e., he created a method called SLPE and invoked it in Arg0 0x05 of _PTS.)

 

Glad you finally got that fixed.

Edited by mnfesq

Share this post


Link to post
Share on other sites
8 hours ago, Tobiko said:

Dude! That worked. I had to add AddPNLF to the config.plist to get the back-light control to work and I haven't tried sleep yet. But I am stoked. Thank you. What did you do?

 

Update. Yes, sleep is working fine too. So happy!

set to zero SLP_SMI_EN.

Share this post


Link to post
Share on other sites

Hi @tyufhl

I have problems like @Tobiko and I don't know how to deal with it. I asked Mald0n to consider this issue but it did't solve this problem. T hope you have solve the problem for @Tobiko that will solve my problem

Thank you for your help. I use mac osx 10.13. Configure my dig as signature.

 

 

 

Send me QuangBTs-MBP.net.fpt.zip

Edited by vinhkm6

Share this post


Link to post
Share on other sites
4 hours ago, vinhkm6 said:

Hi @tyufhl

I have problems like @Tobiko and I don't know how to deal with it. I asked Mald0n to consider this issue but it did't solve this problem. T hope you have solve the problem for @Tobiko that will solve my problem

Thank you for your help. I use mac osx 10.13. Configure my dig as signature.

 

 

 

Send me QuangBTs-MBP.net.fpt.zip

 

Try this:

 

DSDT.aml.zip

Share this post


Link to post
Share on other sites

×