Jump to content

Mojave and intel Q9550


6 posts in this topic

Recommended Posts

Yes, it is ... with a patched com.apple.telemetry.plugin

google mojave2core ...

But I see you have a radeon HD 5670 which is a no go because of the need for sse4.2 in Mojave AMD drivers.

I suggest you to change it for a cheap nVidia GT 600 or 700 series.


Works for me.

Edited by Mr MagOO
Link to comment
Share on other sites

  • 2 weeks later...

It seems though RX 560 does not work OOB on older Core 2 systems running Mojave. 


I've tested the RX 560 on 2 different Core 2 Quad systems that were running Mojave 10.14.2 (at the time). I used com.apple.telemetry.plugin from 10.13.6, SMBIOS 14,2 and -no_compat_check. It would black screen and reboot right before the GUI loaded. Both systems worked fine with NVidia cards I simply removed the NVidia card, disabled NVidia Web and popped in the 560.


I also tried fresh installs and other attempts. Using DOSDUDE1's patcher to 'completely' patch Mojave for a 10,1 SMBIOS. This allowed me to get to the desktop with the RX 560 but it would only show 7MB of RAM for the card under About This Mac and there was no hardware acceleration.


In both scenarios I tried removing Whatevergreen / keeping Whatevergreen along with variations of the below settings.

Device ID ATI - RX 560 - 0x67FF1002

Inject EDID - Vendor ID 0x1002


Inject ATI



With Sierra and High Sierra on these Core 2 Quad Systems the 560 worked OOB



I dropped the 560 into a newer i-7 system and it worked OOB on Mojave 10.14.3. It does not seem to work on the 10.14.4 betas like you've said.



Edited by Tobiko
Link to comment
Share on other sites


  • Create New...