Jump to content

USB 3.0 Not working with Different CPU in Mojave


8 posts in this topic

Recommended Posts

My Current working configuration is:

Asus Sabertooth X79

i7-4930k @3.4

32 GB ram

Evga GeForce GT 710 2GB DDR3 gpu

960 GB Patriot SSD

Mojave 10.14.3 Installed, all USB ports working, all the time using USBInjectAll.kext v 0.7.1, with no patching needed to increase port numbers since the available number covers all of them.

However, when I use this same SSD that Mojave is installed on, in another computer with an exact same motherboard, GPUs, etc, with an E5-2697 v2 12 core CPU instead, USB 3.0 stops working. Only USB 2.0 works.

In Sierra and High Sierra, the motherboard and all CPUs required an SSDT and GenericUSBXHCI.kext for both 2.0 and 3.0 USB ports to work, and even then the 3.0 could be temperamental, and wouldn't work if it didn't see a device when the OS booted.

My Guess? There is something in the USBInjectAll.kext that includes the i7-4039k CPU but doesn't include the E5-2697 v2?

Or there is a difference in version numbers on the motherboards?

I have confirmed all bios settings are identical.

I even tried switching all the cards in the E5-2697 v2 computer so they'd be in the same order as the i7-4930k, taking out a USB 3.0 card. Nothing solved the problem.

The only other difference is the bios version and ME versions of the board. If I remember correctly, I updated the bios to a newer version when I installed the E5-2697 v2.

I have tried various configurations with the Config file, expanding the number of USB ports, using the old SSDT from Sierra and High Sierra, different configs and EFI folders from here and from elsewhere. Nothing has solved the problem.

As I have learned, this motherboard is a pain in the neck. Its advantage is that it has the "sync all cores" in the bios, which was needed when I jumped from 10.6 to 10.8 (I think it was way back then)

I've included the config file and pictures of the drivers64UEFI and Kexts-Other folders.

I spent most of today trying to get this to work. USBInjectAll.kext is a better solution, as GenericUSBXHCI.kext always causes shutdown to hang for about 20 seconds, so I'd like to get this working with all the ports. Worst case, I'll have to use only the USB 3.0, but it's not ideal.

Any help is appreciated. 




Edited by macattackjack
Link to comment
Share on other sites

remove .dSYM

remove shiki 


AzulPatcher4600    Superseded by WhateverGreen
AppleBacklightFixup    Superseded by WhateverGreen
EnableLidWake    Superseded by WhateverGreen
BrcmWLFixup    Superseded by AirportBrcmFixup
CoreDisplayFixup    Superseded by WhateverGreen
IntelGraphicsDVMTFixup    Superseded by WhateverGreen
IntelGraphicsFixup    Superseded by WhateverGreen
NvidiaGraphicsFixup    Superseded by WhateverGreen
Shiki    Superseded by WhateverGreen

Link to comment
Share on other sites

I tried removing both Lilu.dSYM, shiki and shiki.dSYM. If that's what you meant by "remove .dSYM." USB 3.0 however still not working.

As I said, I have a USB 3.0 PCI-E card installed in both computers, and they both work. It's the internal USB 3 that isn't working.

I tried once booting the SSD with the motherboard USB 3.0, in verbose mode and while the Ports were loading the boot froze, which I take to mean that the ports became disabled by the OS as it was loading. It's doing something that is actively shutting off those ports. 

Link to comment
Share on other sites

5 hours ago, iCanaro said:

test: mXHCD.kext

remove USBinjectall and GenericUSB

patch port limit x macOS to use

pendrive emergency for KP


sorry my english :D

that made it freeze during boot

I noticed too, the cpu threat count is 27. Shouldn't it be 0 to 23 for the 12 core? Voodoosync is set to 23.


Edited by macattackjack
I am human.
Link to comment
Share on other sites

Well, the question is, why would this work in one computer, but not the other identical except for the CPU? If it's CPU dependent, are the E5-2697 v2 12 core CPU isn't written for this driver, is it possible to patch it or get a version of USBInjectAll.kext that works with the 12 core cpu?

Link to comment
Share on other sites

Okay. An new update. The question isn't why the E5-2697 v2 12 core CPU computer isn't working, but why the USB 3 ports work on computer with the i7 4930k does. I tested the OS on another identical computer as the one it's working on, that is Asus Sabertooth X79, i7-4930k @3.4, 32 GB ram, Evga GeForce GT 710 2GB DDR3 gpu, 960 GB Patriot SSD, with this build of 10.14.3 and the USBInjectAll.kext, and the 3.0 ports don't work at all., and as a matter of fact, looking at it, they weren't working with 10.12.x and the GenericUSBXHCI.kext either. I ended up buying a intatek USB card which uses a chip that has native support, and that always works fine.

So to recap, one sabertooth X79 motherboard with a i7 4930k where the USB 3 ports work, one where it doesn't in Mojave or with Sierra at all,  and one with a E5-2697 v2 where it doesn't with Mojave but does with Sierra, provided the USB device is present when the OS boots.

Or to put it another way, Apple went from a stable way of using USB ports to a unreliable one.

Link to comment
Share on other sites


  • Create New...