Jump to content
Sign in to follow this  
Followers 0
Lexies

Installing Mojave on a HP Z400 (AMD RX 570)

2 posts in this topic

Recommended Posts

I had a working Mojave installation on my HP Z400 with clover and from a VMware image.  (Because i had a Nvidia 8800GT with no Metal support.) I found a cheap AMD RX 570 card on the local market.
So i did a reinstall with a clean Mojave version from de App Store. Before the new card everything worked fijne exept the video card.
(My Englisch is not great sorry!)
 

The hardware:

  • HP Z400 Motherboard in standard ATX case.  (Some powercable and other hacks needed.)
  • Xeon W3520 (4 cores  2,67Ghz)
  • 6x 2GB DDR3 non ECC
  • Sapphire Radeon RX 570 4G Nitro+
  • SATA Harddisk
  • BIOS version 03.61 (last)

 

BIOS Settings:

File\Default Setup

  1. Restore Factory Settings as Default (You may get some new options)
  2. Apply Defaults and Exit (Reboot)

Storage\Storage Options

  1. Legacy Diskette - Write Disable
  2. Sata Emulation - RAID+AHCI

Security\Device Security

  1. legacy Diskette - Device hidden
  2. Embedded Security - Device Device hidden

Power\Hardware Power Management

  1. Everyting - Enable

Advanced\Processors

  1. Hyper-Threading – Enable

 

Install disk:

  1. Download the complete Mojeva Install App from de Appstor
  2. Make a install USB stick
  3. use the Terminal app and command
    “sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USB -- /Applications/Install\ macOS\ Mojave.app”
    Where USB is te name of the USB stick
  4. Install Clover v2.4k r4844
    Change Install Location and choose  “Install macOS Mojave”
    Customize

Select:

  • Install clover in the ESP
  • Boot Sectors\Install boot0af in MBR
  • Clover for Bios(legacy) booting\ Clover EFI 64-Bits SATA
  • BIOS Drivers, 64 Bit\ApfsDriverLoader-64     (For Apfs in Clover)
  • Everything else unchanged
  • Install


Open Clover Configurator
And open config.plist from the EFI on the USB stick

Select:

  1. Boot\Arguments   dart=0
  2. Graphics - RadeonDeInit
  3. Kernel and Kext Patches   DellSMBIOSPatch
  4. SMBIOS Choose Mac Pro 5.1

Save

 

Kexts:

And place those kexts in Clover\kexts\Other (Zie Attachments)

  • FakeSMC.kext (Mandatory)
  • AHCIPortInjector_v1.0.0_Micky1979.kext (SATA)
  • IOAHCIBlockStorageInjector_v1.0.0_Micky1979.kext (Fix SATA)
  • NullCPUPowerManagement_v1.0.0d2_tgwbd.kext (Support CPU)
  • VoodooHDA_v2.87.kext (Sound)


And install disk is ready
.
My install was Mojave 10.14.2 and with succes updated to 10.14.3

 

Everything is working great de only problem i have found is Mojave sees 7 memory slots and there are 6 slots in the system.
When i define te memory slots in Clover the problem is solved see the image.

 

kexts.zip

config.plist.zip

Screenshot-2019-01-31-at-15.15.jpg

Screenshot-2019-01-31-at-15.25.jpg

Edited by Lexies

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Gracie
      Hello, insanely kind people! 
      I had full working Speedstep on my system with El Capitan, but after installing Mojave i cant make it working again!
      Help me please. Actually system is working only with NullCPUPowerManagement.kext. As soon as i remove it from Extensions directory i've got kernel panic at the boot.
      I tried to put SSDT.aml from my previous ElCapitan clover, tried to make new by different utilities, but still no luck.

      My system is:
      Pentium G3258
      Asus Z97-K USB 3.1
      Nvidia GTX 670


      i''m attaching my new clover.plist of Mojave and old El Capitan one, which makes Speedstep fully working and overclocking my little Pentium from 3.2 to 4.5GHz. Now i see huge speed loss without SpeedStep on Mojave  Please help, anybody! Also im attaching my working SSDT.aml from El Capitan.
      El Capitan SSDT.aml
      El Capitan config.plist
      Mojave config.plist
    • By guitar201
      I’m currently getting around 30seconds on the brucex test and think I can do better.   Ive tried disabling dgpu in the bios and enabled to no availe.  Currently running 10.14.3 with corps dsdt script.  
       
      System is a:
       
      ​
       
      Core i5-8400 / Gigabyte Z370 SLI XP mobo
       
       
      Vega 64
       
       
      GC-Alpine Ridge Thunderbolt 3 card
       
       
      [https://pastebin.com/W3PVZCxh](https://pastebin.com/W3PVZCxh) My Config.plist
       
       
       
      [https://imgur.com/a/KZ9qgop](https://imgur.com/a/KZ9qgop) Contents of my EFI folder
       
      Any suggestions is appreciated.  Thanks. 
    • By End3rPower50
      Hi, is Qualcomm Atheros AR956x compatible with MacOS Mojave 10.14.3?
    • By SIGNALSOUT
      Hello,
      I don't have access to another Mac, so I downloaded the following files:
       
      InstallESDDmg.pkg
      InstallAssistantAuto.dmg
      RecoveryHDMetaDmg.pkg
       
      Build is 10.14.3
       
      These were direct downloads from Apple Servers. If I extract them all I can build a Install macOS Mojave.app from them. I have tried various things in order to get the Mojave Patcher to accept the .app but I cannot get it to boot. The USB key it creates doesn't look proper as some of the files end up on the root of the disk, such as Base. and when it's finished flashing it changes the usb key's name to OS X Base.
       
      Could someone be of assistance and provide me with a tree print out of the file structure for Install macOS Mojave.app please?
      Thank you,
      Nate
    • By Leinad12
      Olá a todos.
      Estou com o macOS Mojave instalado num Lenovo 305 (com um i3 5005 e uma HD 5500) porém tou com um problema.
      Sempre que o computador entra em pausa (Sleep) não consigo voltar a "acordar" (Wake).
      Alguém pode me ajudar pf?
×