Jump to content

[Success] Mojave - Z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630


7 posts in this topic

Recommended Posts

Budget Workstation MacOS 10.14.1 build: z370 AORUS Gaming 5 - i5-8600K - RX 580 - UHD 630

flawless iGPU/dGPU integration, fast FCPX editing/rendering, great overall performance for ~$1200 / ~£1000


Update: updated WhateverGreen and Lilu, then updated OS to 10.14.3 and everything is fine! Even iMessage, which previously I hadn't been able to make work, is now working - possibly the update flushed the NVRAM?


I'm gonna come straight out and admit it - I used newb tools which are considered taboo on InsanelyMac, and so this isn't so much an installation guide as it is a green flag to anyone considering the same hardware. My first and previous Hackintosh project was just over ten years ago and this site was massively helpful, so this is my (very small) way of giving back.






CPU: Intel i5-8600K 3.6GHz hexacore (contains UHD 630 iGPU)

CPU Cooler: be quiet! Pure Rock Slim (no paste needed, and fan facing front)

Mobo: GIGABYTE z370 AORUS Gaming 5 (WIFI)

RAM: 1x 8GB CORSAIR Vengeance LPX C16 2666MHz (in first slot)

GFX Card: Sapphire RX 580 NITRO+ SE

SATA: used ports 0, 1, 3, 5 (HDD problems when connected to port 4)

HDD: generic

DVD Drive: generic

PSU: EVGA 500W Semi Modular (but you should get 650W!)

Case: CoolerMaster CM590 III

Fans: 2x stock case fans (one sucky on front, one blowy on back), 3x be quiet! BL046 120mm fans (two blowy on top, one sucky on front). Airflow near-perfectly balanced.



With the Clover configuration, you want to pay close attention to all things relating to graphics. There are some specific settings for ACPI, Boot, Devices and Graphics which should be copied exactly in order to get the iGPU and dGPU to work in perfect harmony. For instance, make sure you use ig-platform-id 59120003 rather than 59120000 if you want FCPX to be usable. With the right settings, FCPX will not only run, but run flawlessly.


I was not able to figure out how to make NVRAM/PRAM behave itself, and I got errors when I tried to issue relevant commands. As a result, I could not at first get iMessage to work properly. It worked once on my first installation attempt but not from subsequent attempts. This Clover configuration therefore has no consideration whatsoever toward iMessage reliability - however, iMessage ended up working somehow, anyway - I noticed it after I'd updated to 10.14.3 but this may just have been coincidence.


Onboard WiFi does not work. There is no driver for it. I'm using wired ethernet to a bridge router as it was cheaper than getting a compatible PCI card.


Audio is working well after I installed the z370 audio patch, then the ALC1220 codecs, then AppleALC.


With kexts for generic 3rd party SATA and generic 3rd party eSATA, my HDDs and DVD drive work perfectly well.


Sleep/Wake functions run perfectly. iCloud functions run perfectly. Shutdown leaves the mobo LEDs on, annoyingly.


My USB 3 ports seem to suffer from low power output, and I don't know why.


Overall, this system appears to run about as well under MacOS 10.14 Mojave as it does under Windows 7. I would solidly recommend this build to anyone looking to build a computer for workstation purposes, on a budget.

Edited by RougeOne
updated with new information
  • Like 1
Link to comment
Share on other sites

  • 1 month later...

HELP!! I have a Sapphire nitro + 8GB Special edition ... I only see in 1024x760 and 3 (!!!) mega of VRAM. I follow this post carefully, but I'm not practical about SSDT etc., can someone help me? Asus P8P67 EVO 3, i7 3770k, 16 GB RAM, 1SSD, 2 SATA

Link to comment
Share on other sites

  • 2 weeks later...

i try to use these EFI from first post,  but have black screen on Mojave (


mobo: ASUS PRIME Z370-A
cpu: i5 8600K (Coffee Lake)

gpu: Sapphire Radeon RX570 nitro+ 8gb




Edited by khunpoum
Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...
  • 2 months later...
On 8/10/2019 at 4:04 PM, bubbleg5 said:

Hi I have the same motherboard as you but with i7 8700k, I have a strange problem, I have BIOS F11 but if I upgrade to version F12 or F13 I will not start anymore!
Do you have any idea?

Gigabyte Z370 Aorus Gaming 5 + F14 add the ACPI patch




Link to comment
Share on other sites


  • Create New...